View Full Version : Object crash

02/01/2011, 02:30 PM
I've recently found a bug with object handling that makes player's client crash.

It happened on my server where I have custom road [marked LP on map made by one of players] in LS with intercection object from LS Airport:


If player turn right from the road and approach the LS Airport intersection that uses EXACTLY the same object - client will crash
If player turn left, nothing will happen
If player approach the airport without entering the LP road (intersection won't be streamed) - nothing will happen
If player enter the LP road, turn around before intersection will stream and approach airport - nothing will happen
If player enter the LP road, turn around AFTER intersection will stream and approach airport - client will crash

As you can see it's clear and recreatable, don't know if it'd work with other objects though

02/01/2011, 03:02 PM
Re compile you'r objects , if fail i asking did u download 0.3c server file?

02/01/2011, 06:58 PM
Umm, it has nothing to do with the 0.3c objects, it's standard GTA:SA object ::)

03/01/2011, 01:58 PM
LS Airport road is buggy, it has nothing to do with SA-MP.

I don't know why, but don't use the modelid. It's the one with the tunnel isn't it? I've made a loop track before now, using them huge, motorway objects and crashed many times.

Use a new road Didok, plenty more roads to use instead.

03/01/2011, 02:01 PM
Maybe because your PC sucks? i had a really slow PC and i was always lagging at that road in front of the airport.

03/01/2011, 02:08 PM

I'm telling you using one of LS Airport roads (not sure which one), is crash prone. People have made race maps and because they used the object, the map would cause a player to crash.

My PC has nothing to do with it, even if I had a 400mhz piece of crap PC, it wouldn't make it any more stable.

03/01/2011, 04:57 PM
Do you use an Object Streamer? Because sometimes you lagg or crash from not using one.

03/01/2011, 05:14 PM
My PC doesn't suck, it crashed for every player
I use Streamer Plugin, it crashed even with new version
The crash occurs because of that intersection object because it kinda interferes with the same object that is placed natively near LS Airport, is recreatable and occurs for every player
I just want to know the reason of this bug (SA:MP? Streamer?) from someone competent like Rac3r, even if it's the object itself (but WHY it doesn't crash in OTHER places, only when it's near the airport?) there can be many causes of it