PDA

View Full Version : Server crashed due to an unknown error


Vince
27/04/2012, 07:44 PM
Ever since RC6 I've been experiencing crashes when I call OnPlayerRequestClass directly (through CallLocalFunction). The server crashed only a few times at that point when I was testing alone, but I just wanted to test some stuff with someone else and it crashed four times in a row.

The crashinfo is always the same and the crashdetect plugin only outputs:


[21:42:20] [debug] Server crashed due to an unknown error


Crashinfo:

--------------------------

SA-MP Server: 0.3e-RC7



Exception At Address: 0x76EF32A0



Registers:

EAX: 0x00100000 EBX: 0x0018D5A0 ECX: 0x00000000 EDX: 0x000007FF

ESI: 0x00110F20 EDI: 0x02BC0000 EBP: 0x0018D3C8 ESP: 0x0018D3A0

EFLAGS: 0x00010246



Stack:

+0000: 0x02BC0000 0x0018D5A0 0x00000000 0x73283C3A

+0010: 0x0000000A 0x0018D394 0x0018D418 0x0018D4B0

+0020: 0x76F371D5 0x7DD082CF 0x0018D4C0 0x76EF35A7

+0030: 0x02BC0000 0x0018D5A0 0x0018D490 0x00000000

+0040: 0x0B26860F 0x00000000 0x02BC0000 0x0018D5A8

+0050: 0x73195E43 0x00000000 0x0018F83C 0x0018D4E8

+0060: 0x73195EC4 0x00000001 0x00000000 0x005A72BD

+0070: 0x005A72D2 0x02BC0000 0x02BC2DE8 0x02A34C00

+0080: 0x0018D530 0x76EEE38C 0x0B268663 0x0018F83C

+0090: 0x02BC0194 0x02BC0000 0x73191814 0x02A3A290

+00A0: 0x00000003 0x00000564 0x0018D440 0x0018D444

+00B0: 0x00000000 0x00000000 0x00660029 0x00000564

+00C0: 0x00000000 0x00000000 0x029E0358 0x0018D464

+00D0: 0x00000006 0x00000000 0x00000000 0x02BC76D8

+00E0: 0x029E0048 0x029E015C 0x02A2D518 0x029E03D8

+00F0: 0x0000D5C8 0x00000000 0x01010201 0x0018F8C0

+0100: 0x76F371D5 0x01018097 0x0018D3E0 0x0018CF68

+0110: 0x0018D530 0x76F371D5 0x7DD09A9F 0x00000000

+0120: 0x0018D4E0 0x76EF3492 0x0018D5A0 0x0018D5A8

+0130: 0x0018D5A8 0x0018F83C 0x04191C30 0x0018D5A0

dugi
27/04/2012, 07:52 PM
Are you running any plugins?

Vince
27/04/2012, 07:55 PM
plugins jit crashdetect sscanf mysql streamer irc

dugi
27/04/2012, 07:59 PM
This doesn't look like a crash address related to the sa-mp server, its likely that it's one of your plugins. AFAIK the jit plugin has(or used to) issues with it crashing so try disabling it.