PDA

View Full Version : [SOLVED] samp02X on 64bit debian: libstdc++.so.6 not found


yakuzza
25/12/2008, 12:05 PM
Hey folks,

I just found out about this multiplayer project, thx for your work.

I tried to set up a linux server on my 64bit debian system:
2.6.18-5-amd64 #1 SMP Sat Dec 22 20:43:59 UTC 2007 x86_64 GNU/Linux

Just downloaded the server files: http://files.sa-mp.com/samp02Xsvr.tar.gz and extracted them via tar -xf samp02Xsvr.tar.gz

I did not change the server.cfg or any other file.

When i try to start the server i get this error:
./samp02Xsvr
./samp02Xsvr: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

Although im 100% sure its installed the debian way via apt-get:
apt-get install libstdc++6
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut... Fertig
libstdc++6 ist schon die neueste Version.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.

In english it means: libstdc++6 is already the latest version and there is no need to update it.

Is there anyway to get this working on 64bit?

thx
yakuzza

Tommis
25/12/2008, 12:48 PM
Hey,

With root, possibly try;

apt-get install compat-lib*

This might help. Worth a try.

Regards,
Tommis

yakuzza
25/12/2008, 02:12 PM
it did not help, but thx

yakuzza
27/12/2008, 12:03 PM
got it

I had to install the 32bit version of libstdc++6


apt-get install lib32stdc++6


Now the server works fine.

bourne12
28/12/2008, 06:49 PM
yakuzza your command don't go... maybe is incorrect... can you help me?

KingJ
28/12/2008, 06:52 PM
What distro you running? use apt-get for debian based systems (e.g Ubuntu) use yum for RHL based systems (e.g Fedora, CentOs)

bourne12
02/01/2009, 08:22 PM
i have a server with debian 32 bit and SA:MP don't work... what can i do?

bourne12
03/01/2009, 06:42 PM
when i do "nohup samp02Xsvr &" putty say nohup: hänge Ausgabe an ânohup.outâ an nohup: es ist nicht möglich, âsamp02Xsvrâ auszufĂĽhren: Datei oder Verzeichnis nicht gefunden.

What i have to do for fix this problem??

bourne12
05/01/2009, 07:43 PM
Nobody can help me?

Meester Proper
05/01/2009, 08:20 PM
Correct CHMOD Rights for the file/directory?

Korrekte CHMOD Rechte vergeben?

abcwarbot
28/05/2010, 02:55 PM
HI

apt-get install lib32stdc++6


Works like a charm....!!!


Best regards