SA-MP Forums

Go Back   SA-MP Forums > SA-MP > Bug Reports

Reply
 
Thread Tools Display Modes
Old 06/05/2018, 12:03 AM   #1
JR_Junior
Huge Clucker
 
Join Date: Nov 2011
Location: Brazil
Posts: 228
Reputation: 52
Question A 0.3-DL bug only?

Hello!

I'll explain my problem:
My saving system saves the last player position, Interior ID and Virtual World ID when the player disconnects.
Some interiors have Actors and some have created objects (CreateObjetc) and Actors.
If the player disconnects on its own, when it returns spawn correctly in the last position, no problem.

But if it loses connection (When that green message appears: The server is restarting...) and back to the server, when it spawns, objects created by CreateObject and the Actors disappear.

If the interior does not have created objects, only the Actors disappear.

Solution: Exit from the interior and back.

Is this a samp bug?
Can anyone confirm if this occurs in other versions of samp?
Thanks!
JR_Junior is offline   Reply With Quote
Old 06/05/2018, 12:12 AM   #2
Romz
High-roller
 
Romz's Avatar
 
Join Date: Jun 2013
Location: Ukraine
Posts: 1,041
Reputation: 59
Default Re: A 0.3-DL bug only?

This bug everyone has. http://forum.sa-mp.com/showthread.php?t=646279
__________________
Romz is online now   Reply With Quote
Old 06/05/2018, 12:21 AM   #3
JR_Junior
Huge Clucker
 
Join Date: Nov 2011
Location: Brazil
Posts: 228
Reputation: 52
Default Re: A 0.3-DL bug only?

Quote:
Originally Posted by Romz View Post
Thank you!
JR_Junior is offline   Reply With Quote
Old 17/06/2018, 10:58 PM   #4
Freshncool
High-roller
 
Freshncool's Avatar
 
Join Date: Aug 2014
Location: Kingdom of Pakistan Reputation: 9999
Posts: 1,222
Reputation: 348
Default Re: A 0.3-DL bug only?

A possible fix for this is to actually do this:

PHP Code:
SetPlayerVirtualWorld(playerid1);
SetPlayerVirtualWorld(playerid0); 
under OnPlayerConnect.
This will make the server send the model information again so the client can (down)load the models.
__________________
🍔🍔🍔🍔🍔🍔🍔🍔🍔🍔🍔🍔
Freshncool is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT. The time now is 10:33 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.