SA-MP Forums

Go Back   SA-MP Forums > SA-MP > Client Support

Reply
 
Thread Tools Display Modes
Old 18/10/2009, 07:21 PM   #1
tomozj
Big Clucker
 
Join Date: Jan 2007
Posts: 61
Reputation: 7
Default Fix for crash on load in Windows 7/8

If you're currently crashing on load (around 80%) and are running Windows 7 (a problem detailed further here). Then try either of these steps:
  • Reinstall SA into a different directory
  • Rename your current SA directory

Tested as working for me and some others, post if it works or not.

Thanks. o/

Quote:
Originally Posted by Toyotaspeed
Ah. I believe this does work. Not sure if it'll be working for everybody though.

More detailed explanation -

Go into your C:/Program Files/Rockstar Games (or where ever you keep the GTA SA directory)

Add a "2" to the end of your directory name so it says, "GTA San Andreas" to "GTA San Andreas 2".

Right click your SAMP and/or GTA SA shortcut and in the "target" and "Start in" boxes, add a 2 to the end of "GTA San Andreas" again. (example - Target: "C:\Program Files\Rockstar Games\GTA San Andreas 2\samp.exe")

SAMP will say it can't locate your directory and a menu will come up asking you to select the directory. Select the "GTA San Andreas 2" folder.

You should be able to play now.
tomozj is offline   Reply With Quote
Old 19/10/2009, 05:12 PM   #2
athens1908
Little Clucker
 
Join Date: Jun 2009
Posts: 3
Reputation: 0
Default Re: [0.3a] Temporary fix for crashing on load (80% ish) for Windows 7 users

didnt work for me
athens1908 is offline   Reply With Quote
Old 19/10/2009, 06:40 PM   #3
tomozj
Big Clucker
 
Join Date: Jan 2007
Posts: 61
Reputation: 7
Default Re: [0.3a] Temporary fix for crashing on load (80% ish) for Windows 7 users

Quote:
Originally Posted by athens1908
didnt work for me
Did you use any of the RC builds?
tomozj is offline   Reply With Quote
Old 19/10/2009, 07:54 PM   #4
Toyotaspeed
Little Clucker
 
Join Date: Aug 2008
Posts: 15
Reputation: 4
Default Re: [0.3a] Temporary fix for crashing on load (80% ish) for Windows 7 users

Ah. I believe this does work. Not sure if it'll be working for everybody though.

More detailed explanation -

Go into your C:/Program Files/Rockstar Games (or where ever you keep the GTA SA directory)

Add a "2" to the end of your directory name so it says, "GTA San Andreas" to "GTA San Andreas 2".

Right click your SAMP and/or GTA SA shortcut and in the "target" and "Start in" boxes, add a 2 to the end of "GTA San Andreas" again. (example - Target: "C:\Program Files\Rockstar Games\GTA San Andreas 2\samp.exe")

SAMP will say it can't locate your directory and a menu will come up asking you to select the directory. Select the "GTA San Andreas 2" folder.

You should be able to play now.
Toyotaspeed is offline   Reply With Quote
Old 21/10/2009, 09:06 PM   #5
Nitemare3219
Little Clucker
 
Join Date: Dec 2008
Posts: 3
Reputation: 0
Default Re: [0.3a] Temporary fix for crashing on load (80% ish) for Windows 7 users

This did in fact work for me. Thanks for posting this, I was quite afraid that I wouldn't be able to play SA-MP any longer!
Nitemare3219 is offline   Reply With Quote
Old 22/10/2009, 08:28 PM   #6
tomozj
Big Clucker
 
Join Date: Jan 2007
Posts: 61
Reputation: 7
Default Re: [0.3a] Temporary fix for crashing on load (80% ish) for Windows 7 users

I had a problem where it reverted to broken for some reason - just wanted to say that renaming it AGAIN fixed that.
tomozj is offline   Reply With Quote
Old 22/10/2009, 08:53 PM   #7
KevKo95
Banned
 
Join Date: Jan 2008
Location: Ontario, Canada
Posts: 470
Reputation: 0
Default Re: [0.3a] Temporary fix for crashing on load (80% ish) for Windows 7 users

Not working for me. The GTASA process starts but will not run. Running the RC.
KevKo95 is offline   Reply With Quote
Old 23/10/2009, 10:55 PM   #8
ledzep
Huge Clucker
 
Join Date: Nov 2007
Posts: 361
Reputation: 2
Default Re: [0.3a] Temporary fix for crashing on load (80% ish) for Windows 7 users

Installing GTA:SA by running setup.exe in Windows XP or 2000 compatibility worked for me.
ledzep is offline   Reply With Quote
Old 25/10/2009, 02:24 PM   #9
kevinwalter
Big Clucker
 
Join Date: Apr 2008
Posts: 86
Reputation: 0
Default Re: [0.3a] Temporary fix for crashing on load (80% ish) for Windows 7 users

ehm
i have windows 7 and it works normally i dont need to setup that capatibilitie (or something)
an i have the final utlimate version:O (Dutch Version)
kevinwalter is offline   Reply With Quote
Old 27/10/2009, 02:58 PM   #10
Shoie13
Little Clucker
 
Join Date: Oct 2009
Posts: 5
Reputation: 0
Default Re: [0.3a] Temporary fix for crashing on load (80% ish) for Windows 7 users





I have no mods, I've reinstalled SAMP and GTASA several times, I've tried renaming the directories, I've deleted the gta set file, I don't have any of the mentioned .dll's, I've run it as administrator, run it in compatibility mode for every other version of Windows, and set the user permissions all up to Administrator, tried running it without visual themes, have used both the 02 and 03 client versions, and probably a few other things I can't remember yet SAMP still crashes at 80% with this error. Anything else?

Running Vista Ultimate 64-bit, Radeon 4870HD, Phenom 9850 2.5ghz Quad, 4GB DDR2.
Shoie13 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Windows Server 2008 Plugin load fails GeorgeBrown Scripting Help 9 22/11/2012 03:02 PM
Windows 7 Professional 64bit Crash on load. Think Client Support 7 07/05/2011 11:03 AM
Windows 7 RC :: Wont Load by 2 ways b00m Client Support 7 09/05/2009 10:16 PM


All times are GMT. The time now is 07:54 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.