SA-MP Forums

Go Back   SA-MP Forums > SA-MP Scripting and Plugins > Scripting Help

Reply
 
Thread Tools Display Modes
Old 14/01/2018, 01:02 PM   #31
SacrificeGaming
Gangsta
 
Join Date: Oct 2012
Posts: 537
Reputation: 36
Default Re: Sa-mp server doesn't start

I fixed everything thanks everyone for help. Take the scriptfiles from the 2014 version and the server will start but the next problem is poping up... seee screenshot

https://imgur.com/a/us1K4
SacrificeGaming is offline   Reply With Quote
Old 14/01/2018, 01:03 PM   #32
Runn3R
Huge Clucker
 
Runn3R's Avatar
 
Join Date: Dec 2013
Location: Croatia, Split
Posts: 389
Reputation: 35
Default Re: Sa-mp server doesn't start

You should at least post the solution to your problem as someone will see this topic in the future and it may help them with their problem.
Runn3R is offline   Reply With Quote
Old 14/01/2018, 01:35 PM   #33
SacrificeGaming
Gangsta
 
Join Date: Oct 2012
Posts: 537
Reputation: 36
Default Re: Sa-mp server doesn't start

Problem has been fixed you will be able to log into the server (uploaded wrong db)

https://i.imgur.com/88Ia6iH.png

But be aware there are still alot of mysql errors you get because there are things missing.

Serverlog

https://pastebin.com/7eH5TE0f
SacrificeGaming is offline   Reply With Quote
Old 14/01/2018, 03:51 PM   #34
Sew_Sumi
Godfather
 
Join Date: Jun 2008
Posts: 5,273
Reputation: 427
Default Re: Sa-mp server doesn't start

Quote:
Originally Posted by Runn3R View Post
You should at least post the solution to your problem as someone will see this topic in the future and it may help them with their problem.
I actually said about it 5 times in this thread, and the NGG thread.


The SFs folder in the release, needs to be copied to your ScriptFiles folder (That's what 'SFs' stands for).

The second issue with it, is the DB was not initialized, and hence it needed the database installed.

Quote:
Originally Posted by SacrificeGaming View Post
But be aware there are still alot of mysql errors you get because there are things missing.
This is likely due to incorrectly importing the DB, or not importing all of it.

Review what you've done as it should be working, and if it's not working out, chase up the release thread. If you keep having issues, hit up the release thread as THEY should be supporting this.
Sew_Sumi is offline   Reply With Quote
Old 14/01/2018, 03:56 PM   #35
SacrificeGaming
Gangsta
 
Join Date: Oct 2012
Posts: 537
Reputation: 36
Default Re: Sa-mp server doesn't start

Quote:
Originally Posted by Sew_Sumi View Post
I actually said about it 5 times in this thread, and the NGG thread.


The SFs folder in the release, needs to be copied to your ScriptFiles folder (That's what 'SFs' stands for).

The second issue with it, is the DB was not initialized, and hence it needed the database installed.
I know that but the thing is once I copy things whats inside SF's It doesn't work but when I copy the scriptfiles from the 2014 version it works only 10000 mysql querry errors in the console
SacrificeGaming is offline   Reply With Quote
Old 14/01/2018, 03:57 PM   #36
Runn3R
Huge Clucker
 
Runn3R's Avatar
 
Join Date: Dec 2013
Location: Croatia, Split
Posts: 389
Reputation: 35
Default Re: Sa-mp server doesn't start

Quote:
Originally Posted by Sew_Sumi View Post
I actually said about it 5 times in this thread, and the NGG thread.


The SFs folder in the release, needs to be copied to your ScriptFiles folder (That's what 'SFs' stands for).

The second issue with it, is the DB was not initialized, and hence it needed the database installed.
The OP needs to type what fixed his problem so the people can know that the problem was resolved by doing that.
Runn3R is offline   Reply With Quote
Old 14/01/2018, 04:06 PM   #37
Sew_Sumi
Godfather
 
Join Date: Jun 2008
Posts: 5,273
Reputation: 427
Default Re: Sa-mp server doesn't start

Quote:
Originally Posted by Runn3R View Post
The OP needs to type what fixed his problem so the people can know that the problem was resolved by doing that.
Because the OP doesn't even know what's fixed the issue... They simply blindly copied random files over to the folder from an older release.

They were missing files in the first instance, hence why it was 'hanging' on startup, as demonstrated by the fread error on the crashdetect log.

The MySQL errors start with a reference to check the MySQL.log file for an error... It's HIGHLY LIKELY that the reasons that every query after that error is failing, and it's probably a big point that that, could be explained in the log itself.


Seriously, if the release is broken then tell the release... It's their responsibility to fix it.

However it's more likely though that inexperience, and the overwhelming urge to rush a job and get a new server online with everything simply edited to change the name/domain/'ownership' details has got the better of the people who are having issues, and because of inexperience, it makes them have problems.
Sew_Sumi is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Server doesn't start DarkZero Scripting Help 5 29/06/2014 09:57 AM
Server doesn't start Lucius1992 Scripting Help 0 25/12/2012 11:49 AM
I Need Help In My Server It Doesn't Start Omar Amir Scripting Help 11 25/08/2012 06:06 PM
Server doesn't start janx221 Scripting Help 3 12/01/2012 08:03 PM


All times are GMT. The time now is 01:21 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.