SA-MP Forums

Go Back   SA-MP Forums > SA-MP Scripting and Plugins > Scripting Help

Reply
 
Thread Tools Display Modes
Old 13/07/2015, 03:50 PM   #1
HarrisonC
Big Clucker
 
HarrisonC's Avatar
 
Join Date: Aug 2012
Location: United Kingdom
Posts: 91
Reputation: 21
Angry AttachedObjects disappearing when exiting a vehicle

Hi All,

Has anyone experienced an issue where their attached objects disappear when they exit a vehicle?
I haven't found anything in my script that would cause this to happen explicitly with RemovePlayerAttachedObject(playerid, index) and cannot seem to resolve this issue.

I have even stored the SetPlayerAttachedObject data in PVars and created a method that is called at the end of OnPlayerStateChange which will RemovePlayerAttached & reattach it with the saved data but it still disappears.

Any advice?
HarrisonC is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Teleporting after exiting vehicle Lemonaidz Scripting Help 1 24/02/2013 10:01 AM
Exiting vehicle as passenger Rac3r Bug Reports 0 07/04/2012 05:41 PM
How can I disable exiting a vehicle? grand.Theft.Otto Help Archive 11 12/03/2011 05:30 AM
[Possible Bug] Objects don't appear until exiting vehicle Redirect Left Help Archive 6 12/12/2010 03:13 PM
NPC Exiting Vehicle niCe Help Archive 2 04/10/2009 01:49 PM


All times are GMT. The time now is 02:20 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.