SA-MP Forums

Go Back   SA-MP Forums > SA-MP > Client Support

Reply
 
Thread Tools Display Modes
Old 12/05/2011, 07:33 PM   #1
Jay_
Beta Tester
 
Jay_'s Avatar
 
Join Date: Jul 2009
Posts: 636
Reputation: 172
Default Client Crash

Hi,

On random occasions my client is crashing. I suspect it may be related to objects or object draw distance but I have nothing to back this up.

The address is

Code:
SA-MP 0.3c-R3
Exception At Address: 0x00415D47

Registers:
EAX: 0x00000C62	EBX: 0x0028F48C	ECX: 0xC002E500	EDX: 0x3EB9D6F5
ESI: 0x1A117258	EDI: 0x0B59013D	EBP: 0x0028EE10	ESP: 0x0028EC1C
EFLAGS: 0x00210202

Stack:
+0000: 0x1A117258   0xBEC0C000   0x3FF07000   0x3F493400
+0010: 0x129B9338   0x127D2720   0xBE2E2000   0xBDE58000
+0020: 0x3F8E4400   0x3FC4BA00   0xBE2E2000   0xBE2D1000
+0030: 0xC002E500   0x3F493400   0x3F2B2B0E   0x00FF0000
+0040: 0xBEFFC02F   0xC0D2EFA1   0xC11B856D   0x3F7DE1B0
+0050: 0x415736D4   0x41276E75   0x3FFF0000   0x0A613EB0
+0060: 0x44AA34AF   0x4419A468   0x4424EF5B   0x40328A00
+0070: 0x44AA2E14   0xBE2E2000   0xBE2D1000   0x004184B5
+0080: 0x0028ECFC   0x0028ECD8   0x1A118620   0x00000C62
+0090: 0x1A117288   0x00000063   0x0028F48C   0x0028FAEC
+00A0: 0x0028EE4C   0x0028EE50   0x0B352034   0x00000000
+00B0: 0x1A117C38   0x00000063   0x1A117288   0xBE907000
+00C0: 0x3F714400   0xBF022000   0x3EB9D6F5   0xC419AF39
+00D0: 0xBE907000   0x3F714400   0xBF022000   0x1A117258
+00E0: 0xBE2E2000   0xBE2D1000   0xC002E500   0x3EB9D6F5
+00F0: 0x00000000   0xBE2E2000   0xBE2D1000   0xC002E500
+0100: 0x008371F8   0xBE907000   0x3F714400   0xBF022000
+0110: 0x0028FB00   0x44AA34AF   0x4419A468   0x4424EF5B
+0120: 0x3EB9D6F5   0x00000000   0x44AA3119   0x4419EB8A
+0130: 0x442551B8   0x3EB9D6F5   0xC419AF39   0x44AA34AF
+0140: 0x4419A468   0x4424EF5B   0x0041AFAC   0x44AA3119
+0150: 0x4419EB8A   0x442551B8   0x0028EDC0   0xBE2E2000
+0160: 0xBE2D1000   0xC002E500   0x3F800000   0x80000000
+0170: 0x00000000   0x01010101   0x00000000   0x3F800000
+0180: 0x00000000   0x00000000   0x80000000   0x00000000
+0190: 0x3F800000   0x442549F4   0xC4AA3A20   0xC419AF39
+01A0: 0xC4257240   0x44AA3162   0x00000000   0x00000000
+01B0: 0x0028FD84   0x008371D8   0xFFFFFFFF   0x0041B119
+01C0: 0x0028EE38   0x0028EE2C   0x00000063   0x0028EE4C
+01D0: 0x0028EE10   0x0028F48C   0x00B6F338   0x0028FB40
+01E0: 0x00B6F338   0x0028FBC8   0x0128F2A4   0x3F0AF8AC
+01F0: 0x3DAF8AC2   0x00000000   0x3F800000   0x3F2B2B0E
+0200: 0x3A83126F   0xBE536000   0x40030900   0x40353200
+0210: 0xBDE57E26   0x3F8E4446   0x3FC4B9EC   0x44AA34AF
+0220: 0x4419A468   0x4424EF5B   0x3EB9D6F5   0x00000000
+0230: 0x00000001   0x0B352034   0x0451013D   0x00000001
+0240: 0x00000001   0x00000000   0x000000D5   0x00000001
+0250: 0x00000001   0x0B351E98   0x00000183   0x2A200001
+0260: 0x74654701   0x00000000   0x00000085   0x74730000
+0270: 0x20747201   0x0B351B60   0x0000052D   0x6F590000

SCM Op: 0x2BF, lDbg: 0

Game Version: US 1.0

State Information: Ped Context: 0
P1 (0,0)
I have searched these forums and there have been no other reports of this crash. I am using a fresh installation of the game. Other players in my server have experienced the same crash.

If a developer could clarify the reason I would much appreciate it.

Thanks

Regards
Jay_ is offline   Reply With Quote
Old 12/05/2011, 07:37 PM   #2
Jean_Pierre
Huge Clucker
 
Jean_Pierre's Avatar
 
Join Date: Apr 2011
Location: Vantaa, Finland
Posts: 339
Reputation: 2
Default Re: Client Crash

0.3G R3 again. Try to Downgrade to R1, crashes should be gone then
__________________
Jean_Pierre is offline   Reply With Quote
Old 12/05/2011, 08:24 PM   #3
Tenshi
Huge Clucker
 
Join Date: Feb 2007
Location: USA/East Coast (for now)
Posts: 210
Reputation: 32
Default Re: Client Crash

Quote:
Originally Posted by Jean_Pierre View Post
0.3G R3 again. Try to Downgrade to R1, crashes should be gone then
What the hell is 0.3G R3?.....
NO such sa-mp verson lol....
__________________
Quote:
* 07:52:58 [AM] * You were kicked from #sa-mp by JailBait (Refusing to get naked.)
Tenshi is offline   Reply With Quote
Old 12/05/2011, 08:27 PM   #4
Jean_Pierre
Huge Clucker
 
Jean_Pierre's Avatar
 
Join Date: Apr 2011
Location: Vantaa, Finland
Posts: 339
Reputation: 2
Default Re: Client Crash

C, i mean. iPod fixing...
__________________
Jean_Pierre is offline   Reply With Quote
Old 12/05/2011, 08:36 PM   #5
Kalcor
SA-MP Developer
 
Join Date: Apr 2005
Posts: 620
Reputation: 1938
Default Re: Client Crash

I'd say it could be script related. It's something to do with the particular camera mode (GTA:SA's internal camera). I'm guessing players that get this crash would be doing the same thing when it crashes. Does that help?

I can try find out exactly which camera mode it is.

Edit:

Is this only happening with the 0.3c-R3 client or do you have the same reports from people running R1?
Kalcor is offline   Reply With Quote
Old 12/05/2011, 09:03 PM   #6
Jean_Pierre
Huge Clucker
 
Jean_Pierre's Avatar
 
Join Date: Apr 2011
Location: Vantaa, Finland
Posts: 339
Reputation: 2
Default Re: Client Crash

Kalcor. Every client problems crashes have came From R3 So Its somehow Connected. Downgrading should help.
__________________
Jean_Pierre is offline   Reply With Quote
Old 21/05/2011, 02:12 PM   #7
Jay_
Beta Tester
 
Jay_'s Avatar
 
Join Date: Jul 2009
Posts: 636
Reputation: 172
Default Re: Client Crash

Sorry for the delay in reverting.

This happens on both the R1 and R3 client. I've also noticed an in game client message displaying: Warning:(s007): Exception 0xC0000005 at 0x415D47.

I've done some research and investigated the problem further and come to the conclusion it is indeed script related as you suggested as it is happening for every player under the same scenario.

I've debugged the script and found that as I earlier suspected it is object related. Upon decreasing the number of created objects for a player (from ~ 350 to 150) the issue appears to have resolved.

Thanks for your help.
Jay_ is offline   Reply With Quote
Old 22/05/2011, 08:34 PM   #8
Jay_
Beta Tester
 
Jay_'s Avatar
 
Join Date: Jul 2009
Posts: 636
Reputation: 172
Default Re: Client Crash

My previous assumption is wrong. It appears to happen when a select few 0.3c objects are loaded together at once for the client. It's odd however that nobody has reported this before so it can't be very common or serious. I've tried loading the 80 or so objects that it appears to happen for on a clean gamemode with no other objects or vehicles and with only two players connected and it still happened...

Perhaps using the above additional details provided this could be narrowed down further? Again, any help would be much appreciated.

Just for reference, here's the test command http://pastebin.com/3iiEkLRd
Jay_ is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Odd Client Crash [VnR]Clan Server Support 0 20/01/2011 12:17 AM
client crash armyoftwo Help Archive 1 01/12/2010 01:46 PM
SA:MP Client 0.3a Crash Nikolai Bratva Client Support 1 31/12/2009 07:43 AM
SA-MP 0.3a Client Crash loechner Help Archive 1 18/10/2009 08:31 PM


All times are GMT. The time now is 05:41 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.