SA-MP Forums

Go Back   SA-MP Forums > SA-MP Server > Server Support

Reply
 
Thread Tools Display Modes
Old 26/04/2015, 10:20 AM   #1
PrivatioBoni
Gangsta
 
Join Date: May 2013
Location: Ya
Posts: 978
Reputation: 162
Default [Video] Players disappearing/flashing

https://www.youtube.com/watch?v=qJpOrpgWkSE
(Sorry, couldn't figure out how to embed).

Has anyone ever seen this before (could barely find any results on the SA:MP forum) and knows roughly what causes it?

- Restarting didn't help
- First properly started happening when around 15 player I believe, later settled down but then started to happen with only a couple of people online
- It is not an interior or virtual world problem. I have been spamming /getint and /getvw on players and the interiors/VWs remained.
- I use Fallout streamer at this point
- No code under OnPlayerUpdate

I'll add more detail as I think of it.

Thanks.


EDIT after changing streamer to Incognito (I now doubt whether this is the actual issue):
- The bug re-occurs, there were around 5-6 players online on this occasion
- If I remember correctly, someone reported that the script spams a hint message, one you get when your state changes to driver/passenger)
- A user reported to me that vehicles disappeared for him
- I still maintain this is not a VW/interior bug though.

New video:

https://www.youtube.com/watch?v=5mJARgpY1lc

EDIT:

- Removed all mapping and building removals
- Disabled /spec command and removed its related functionality

EDIT:
- Readded mapping and building removals to see if the problem is in fact the /spec functionality

EDIT:
- Re-added /spec but it's now more simple
- Maybe forgot to mention some things.

- This bug has not occurred since.
- I then happened to experience a server-hanging bug which also hasn't happened since (the question is, since when?!)

Last edited by PrivatioBoni; 29/04/2015 at 08:52 PM.
PrivatioBoni is offline   Reply With Quote
Old 26/04/2015, 10:27 AM   #2
Write
Banned
 
Join Date: Nov 2014
Posts: 312
Reputation: 149
Default Re: [Video] Players disappearing/flashing

How many objects do you have in your server? sometimes, too many objects makes things flicker.
Write is offline   Reply With Quote
Old 26/04/2015, 11:05 AM   #3
Michael B
High-roller
 
Michael B's Avatar
 
Join Date: Oct 2014
Location: Romania
Posts: 1,179
Reputation: 127
Default Re: [Video] Players disappearing/flashing

Is that happening with one single player, or with most of them?

The player you've seen could use AFK and teleport cheats.
__________________
Michael B is offline   Reply With Quote
Old 26/04/2015, 12:01 PM   #4
PrivatioBoni
Gangsta
 
Join Date: May 2013
Location: Ya
Posts: 978
Reputation: 162
Default Re: [Video] Players disappearing/flashing

Quote:
Originally Posted by Write View Post
How many objects do you have in your server? sometimes, too many objects makes things flicker.
Around 1600, using Fallout streamer.

Quote:
Originally Posted by StuartIndia View Post
Strange problem
Yes, it is. And it's one I want to get resolved as soon as possible.

Quote:
Originally Posted by Michael B View Post
Is that happening with one single player, or with most of them?

The player you've seen could use AFK and teleport cheats.
It was happening to everyone, I believe. Or maybe only ones in a proximity.

I'm going to change to Incognito streamer, and remove some of the unneeded objects, and see if this reoccurs.

It seems to make a huge mess of the whole server, though. For example, someone reported that they tried to use the seatbelt command but it said they weren't in a vehicle, so it's likely causing mass desync.
PrivatioBoni is offline   Reply With Quote
Old 26/04/2015, 03:25 PM   #5
Write
Banned
 
Join Date: Nov 2014
Posts: 312
Reputation: 149
Default Re: [Video] Players disappearing/flashing

Pretty weird. There's something in your script that is causing this then. I noticed their cameras changing swiftly over and over again, try looking over OnPlayerUpdate.
Write is offline   Reply With Quote
Old 26/04/2015, 03:59 PM   #6
PrivatioBoni
Gangsta
 
Join Date: May 2013
Location: Ya
Posts: 978
Reputation: 162
Default Re: [Video] Players disappearing/flashing

Thanks for your help, but as the OP mentions, there is nothing under OnPlayerUpdate.

I'm uploading another video soon, which captures the problem in a different way.
PrivatioBoni is offline   Reply With Quote
Old 26/04/2015, 04:58 PM   #7
Write
Banned
 
Join Date: Nov 2014
Posts: 312
Reputation: 149
Default Re: [Video] Players disappearing/flashing

There has to be something that you made, something new, a function that caused this. Or maybe you put a new include.

Do you have any filterscripts?
Write is offline   Reply With Quote
Old 26/04/2015, 05:02 PM   #8
PrivatioBoni
Gangsta
 
Join Date: May 2013
Location: Ya
Posts: 978
Reputation: 162
Default Re: [Video] Players disappearing/flashing

Quote:
Originally Posted by Write View Post
There has to be something that you made, something new, a function that caused this. Or maybe you put a new include.

Do you have any filterscripts?
I have an animations filterscript and also gl_realtime.


Unfortunately it is very hard to go back to a point where I know everything was okay. We only had a few people on at a time for testing (and we usually weren't online for long) and everything seemed fine. Thinking about it, there was 1 occasion when we had a similar problem, but I can't remember how (and if) I fixed it...

The includes I use:

Code:
#include 	<a_samp>
#include 	<sscanf2>
#include 	<ZCMD>
#include 	<YSI\y_ini>
#include 	<streamer>
#include 	<crashdetect>
#include 	<foreach>
PrivatioBoni is offline   Reply With Quote
Old 26/04/2015, 09:23 PM   #9
Write
Banned
 
Join Date: Nov 2014
Posts: 312
Reputation: 149
Default Re: [Video] Players disappearing/flashing

Try removing all of your filterscripts and see if that does the trick, something is conflicting with your script or it's within your script, I remember a similar bug a long time ago but It only lasted untill the owner removed all of his filterscripts.

Hope it helps, I have no idea what it is if it dosen't.
Write is offline   Reply With Quote
Old 27/04/2015, 02:37 AM   #10
Abagail
High-roller
 
Join Date: Dec 2013
Location: GetPlayerPos(playerid, pos); Scripter/Mapper.
Posts: 3,524
Reputation: 437
Default Re: [Video] Players disappearing/flashing

That streamer is from 2010. I am sure using an up-to-date streamer will provide a better result.
Abagail is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Video: SA-MP 0.3z Bug 1: Players in AFK mode can be killed ..Bobby.. Scripting Help 38 29/01/2014 09:32 PM
Advanced Role Players SACG Video br0adyb0ii Screenshots and Videos 4 08/10/2010 11:45 PM
Vehicles/players unsynced/disappearing Luka P. Server Support 12 26/09/2010 03:46 PM
Advanced Role Players (Promo Video) br0adyb0ii Screenshots and Videos 2 16/08/2010 08:13 AM
SA-MP Players list disappearing [MOB]DarKy Client Support 4 01/09/2009 08:07 AM


All times are GMT. The time now is 02:31 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.