PDA

View Full Version : GameMode: Unknown


Kalli749
28/08/2011, 08:28 AM
Hello,

i have a problem with my server: GameMode: Unknown

All plugins that are registered in the cfg are also in the Server Folder.

Server Log:

----------
Loaded log file: "server_log.txt".
----------

SA-MP Dedicated Server
----------------------
v0.3c R5, (C)2005-2011 SA-MP Team

[00:29:45]
[00:29:45] Server Plugins
[00:29:45] --------------
[00:29:45] Loading plugin: mysql.so
[00:29:45] SA:MP MySQL Plugin v2.1.1 Loaded.
[00:29:45] Loaded.
[00:29:45] Loading plugin: MapAndreas.so
[00:29:45] [MySQL] Thread running. Threadsafe: Yes.
[00:29:45] Loaded.
[00:29:45] Loading plugin: streamer.so
[00:29:45]

*** Streamer Plugin v2.3.8 by Incognito loaded ***

[00:29:45] Loaded.
[00:29:45] Loaded 3 plugins.

[00:29:45]
[00:29:45] Ban list
[00:29:45] --------
[00:29:45] Loaded: samp.ban
[00:29:45]
[00:29:45]
[00:29:45] Filter Scripts
[00:29:45] ---------------
[00:29:45] Loading filter script 'bfx_stream.amx'...
[00:29:45]
--------------------------------------
[00:29:45] [[ BFX Object Streamer 4.3 ( Stable ) ]]
[00:29:45] [[ (c) 2010 By BlackFoX_UD_ ]]
[00:29:45] --------------------------------------

[00:29:45] Loaded 1 filter scripts.

[00:29:48] [junkbuster] [WARNING!]
[00:29:48] [junkbuster] JunkBuster is not used in gamemode or OnGameModeInit returns 0.
[00:29:48] [junkbuster] Make sure you use JunkBuster.inc in your gamemode. If you want to
[00:29:48] [junkbuster] use JunkBuster in filterscripts, too, include JunkBusterFS.inc in
[00:29:48] [junkbuster] your filterscript.
[00:29:48] [junkbuster] It's recommended to include JunkBuster.inc in your gamemode
[00:29:48]

[00:29:48] [junkbuster] Current JunkBuster configuration:
[00:29:48] [junkbuster] - WeaponHack = 1
[00:29:48] [junkbuster] - MoneyHack = 1
[00:29:48] [junkbuster] - Jetpack = 1
[00:29:48] [junkbuster] - HealthHack = 1
[00:29:48] [junkbuster] - ArmourHack = 1
[00:29:48] [junkbuster] - DriveBy = 1
[00:29:48] [junkbuster] - Spam = 0
[00:29:48] [junkbuster] - CommandSpam = 0
[00:29:48] [junkbuster] - BadWords = 1
[00:29:48] [junkbuster] - CarJackHack = 1
[00:29:48] [junkbuster] - TeleportHack = 1
[00:29:48] [junkbuster] - MaxPing = 1000
[00:29:48] [junkbuster] - SpectateHack = 1
[00:29:48] [junkbuster] - Blacklist = 1
[00:29:48] [junkbuster] - IpBans = 1
[00:29:48] [junkbuster] - TempBans = 1
[00:29:48] [junkbuster] - SpawnKill = 3
[00:29:48] [junkbuster] - CapsLock = 1
[00:29:48] [junkbuster] - 3DSpeed = 0
[00:29:48] [junkbuster] - MaxSpeed = 230
[00:29:48] [junkbuster] - AdminImmunity = 1
[00:29:48] [junkbuster] - Advertisement = 0
[00:29:48] [junkbuster] - FreezeUpdate = 0
[00:29:48] [junkbuster] - SpawnTime = 10
[00:29:48] [junkbuster] - CheckpointTeleport = 1
[00:29:48] [junkbuster] - Airbreak = 1
[00:29:48] [junkbuster] - TankMode = 1
[00:29:48] [junkbuster] - WarnPlayers = 0
[00:29:48]

[00:29:48] [junkbuster] 0 IP-bans have been loaded.
[00:29:48] [junkbuster] 0 temporary bans have been loaded.
[00:29:48] [junkbuster] 0 whitelist entries have been loaded.
[00:29:48] [junkbuster] 5 blacklist entries have been loaded.
[00:29:48] [junkbuster] 41 bad words have been loaded.
[00:29:48] [junkbuster] 4 forbidden weapons have been loaded.
[00:29:48] [junkbuster] JunkBuster has been configurated.
[00:29:48] [junkbuster] JunkBuster has successfully been loaded.
[00:29:48]
[00:29:48]
[00:29:48]
[00:29:48] MYSQL: Attempting to connect to server...
[00:29:48] [MySQL] Connected (0) to 'sampserver'@'Localhost via UNIX socket'.
[00:29:48] [MySQL] Server Version 5.0.51a-24+lenny5.
[00:29:48] MYSQL: Database connection established.
[00:29:48] Number of vehicle models: 31

SetGameModeText("Test");

main()
{
print(" ");
print(" ");
print("Script made by xyz");
print("_____________________");
print("xyz Reallife");
print(" ");
SendRconCommand("mapname San Andreas");
MySQLConnect(MYSQL_HOST,MYSQL_USER,MYSQL_PASS,MYSQ L_DB);
}

I hope someone can help me.

Best regards

=WoR=Varth
28/08/2011, 08:30 AM
SetGameModeText("Test");

Where is it?

uprp
28/08/2011, 08:30 AM
missing scriptfiles? MYSQL not setup right? using linux?

Elbert_Hutchinson
28/08/2011, 09:00 AM
[00:29:48] [junkbuster] [WARNING!]
[00:29:48] [junkbuster] JunkBuster is not used in gamemode or OnGameModeInit returns 0.
[00:29:48] [junkbuster] Make sure you use JunkBuster.inc in your gamemode. If you want to

Kalli749
28/08/2011, 09:40 AM
SetGameModeText("Test");

It's in "OnGameModeInit"

missing scriptfiles? MYSQL not setup right? using linu

I looked it up and nothing is missing..

[00:29:48] [junkbuster] [WARNING!]
[00:29:48] [junkbuster] JunkBuster is not used in gamemode or OnGameModeInit returns 0.
[00:29:48] [junkbuster] Make sure you use JunkBuster.inc in your gamemode. If you want to

And how to fix it?

Best Regards ;)

Bakr
28/08/2011, 09:43 AM
Load JunkBuster as filterscript when your server starts! (Add it in server.cfg)
Include JunkBuster.inc in all your scripts except for the JunkBuster filterscripts.
==> Read the README carefully.


Retrieved from the Junkbuster topic

Generation-X
28/08/2011, 12:13 PM
I had this problem before, I was using Linux - I re-compiled the plugins then it works.

Kalli749
28/08/2011, 12:26 PM
I don't have the actual version of Junk Buster. (Update 6)
So i don't have to load a filterscript in my cfg.

Maybe the Server.cfg is broken?

echo Executing Server Config...

lanmode 0
rcon_password asd
maxplayers 30
port 7788
password test
hostname asd
gamemode0 egr
filterscripts bfx_stream
announce 1
query 1
weburl www.xyz.de
bindip myip
maxnpc 0
onfoot_rate 40
incar_rate 40
weapon_rate 40
stream_rate 1100
plugins mysql.so MapAndreas.so streamer.so