PDA

View Full Version : I cant Compile


sanjil_rijal
09/04/2012, 08:22 AM
Can anyone help me after i updated to the latest version of YSI i cannot compile it says something like this:
D:\Pujan's gaming\Extension Gaming Roleplay\pawno\include\YSI\y_iterate.inc(197) : fatal error 111: user error: "Old foreach.inc files are no longer compatible with YSI."


Compilation aborted.Pawn compiler 3.2.3664 Copyright (c) 1997-2006, ITB CompuPhase


1 Error.

DannySnoopy
09/04/2012, 08:25 AM
Are you 100 percent sure you updated to the newest version of foreach?

Reklez
09/04/2012, 08:28 AM
update your foreach to new one which can be download here (http://forum.sa-mp.com/showthread.php?t=92679)

sanjil_rijal
09/04/2012, 08:30 AM
Thanks a lot dude given u a rep+

sanjil_rijal
09/04/2012, 08:39 AM
Damn! Replaced in the pawno/include but still the same problem while compiling D=

Jack Shred
09/04/2012, 09:00 AM
Are you sure you put it in the right server folder?
Are you sure you opened pawno.exe from the same server folder?
Try running pawno.exe as an administrator.

sanjil_rijal
09/04/2012, 09:06 AM
Done but the problem is not fixed

Cjgogo
09/04/2012, 09:09 AM
You have really big problems related to YSI,try this at top of your gamemode:
#define MAX_INI_ENTRY_TEXT 130
#include <YSI/y_ini>