PDA

View Full Version : Stock doesnt work?


CoDeZ
21/05/2012, 10:19 AM
Hello...
This is line that i get error at

MySQL_Login(playerid)


then i used this

stock MySQL_Login(playerid)
{
// my code goes here
}


And i get this error.

error 017: undefined symbol "MySQL_Login"

Any help?

Dan.
21/05/2012, 12:27 PM
MySQL_Login(playerid);

Maybe?

CoDeZ
21/05/2012, 01:07 PM
Still the same.
when i type stock , it doesnt appear like the blue light color , but it appears black

Vince
21/05/2012, 01:11 PM
The syntax highlighting on the forum is not a 100% correct. It is supposed to be black. Nevertheless, stock is just a modifier that hides the function/variable from the compiler if it is not used. It should not in any way interfere with the inner workings of the function.

The problem is most likely in the wrong usage of pre-processor directives, notoriously #if defined FILTERSCRIPT.

CoDeZ
21/05/2012, 01:25 PM
Ehm.. thats a home made script using my pc
Also i didnt use any filterscripts , and i tried opening the grandlrc script that comes with the server package and tried to use stock but still the same problem..

[FMJ]PowerSurge
21/05/2012, 02:34 PM
Make sure all your braces are matched. Also, make sure that your stock definition isn't inside another function.

If you still can't get it to work, PM me on the FMJ forum or hit me up ingame.