PDA

View Full Version : Gamemode Problem.


Rudy_
07/06/2012, 11:50 AM
Hello guys i have a damn problem... When i run samp-server.exe
it gives this.
~~~LOGS~~~

SA-MP Dedicated Server
----------------------
v0.3e, (C)2005-2012 SA-MP Team

[16:55:47] filterscripts = "" (string)
[16:55:47]
[16:55:47] Server Plugins
[16:55:47] --------------
[16:55:47] Loading plugin: sscanf
[16:55:48] Failed.
[16:55:48] Loaded 0 plugins.

[16:55:48] I couldn't load any gamemode scripts. Please verify your server.cfg
[16:55:48] It needs a gamemode0 line at the very least.

Here are my Server.cfg

echo Executing Server Config...
lanmode 0
rcon_password PASSWORD
maxplayers 500
port 7777
hostname Survival v0
gamemode0 Survival
filterscripts
plugins sscanf
announce 1
query 1
weburl none
onfoot_rate 40
incar_rate 40
weapon_rate 40
stream_distance 300.0
stream_rate 1000
maxnpc 0
logtimeformat [%H:%M:%S]

Everything is fine and in it's place..

carz0159
07/06/2012, 11:55 AM
This is how your config should look. You were close, but a few things needed to be done.

echo Executing Server Config...
lanmode 0
rcon_password PASSWORD
maxplayers 500
port 7777
hostname Survival v0
gamemode0 Survival 1
filterscripts
plugins sscanf.so streamer.so
announce 1
query 1
weburl none
onfoot_rate 40
incar_rate 40
weapon_rate 40
stream_distance 300.0
stream_rate 1000
maxnpc 0
logtimeformat [%H:%M:%S]

Also, I highly reccomend getting the streamer plugin, that's why i added it's name to the config.
Also check the port to make sure its correct and check how many slots your server is, and update that as well.
I hope i solved your problem

Rudy_
07/06/2012, 11:58 AM
i have it already btw



----------
Loaded log file: "server_log.txt".
----------

SA-MP Dedicated Server
----------------------
v0.3e, (C)2005-2012 SA-MP Team

[17:07:43] filterscripts = "" (string)
[17:07:43]
[17:07:43] Server Plugins
[17:07:43] --------------
[17:07:43] Loading plugin: sscanf.dll
[17:07:44] Failed.
[17:07:44] Loading plugin: streamer.dll
[17:07:44]

*** Streamer Plugin v2.6.1 by Incognito loaded ***

[17:07:44] Loaded.
[17:07:44] Loaded 1 plugins.

[17:07:44] I couldn't load any gamemode scripts. Please verify your server.cfg
[17:07:44] It needs a gamemode0 line at the very least.

deltapro
07/06/2012, 12:08 PM
As i can see your sscanf plugin dosnt't load. Download the latest version of sscanf and re-compile the script.


----------
Loaded log file: "server_log.txt".
----------

SA-MP Dedicated Server
----------------------
v0.3e, (C)2005-2012 SA-MP Team

[17:07:43] filterscripts = "" (string)
[17:07:43]
[17:07:43] Server Plugins
[17:07:43] --------------
[17:07:43] Loading plugin: sscanf.dll
[17:07:44] Failed. // see it doesnt't load
[17:07:44] Loading plugin: streamer.dll
[17:07:44]
--Rep me if i helped you ! ;)
*** Streamer Plugin v2.6.1 by Incognito loaded ***

[17:07:44] Loaded.
[17:07:44] Loaded 1 plugins.

[17:07:44] I couldn't load any gamemode scripts. Please verify your server.cfg
[17:07:44] It needs a gamemode0 line at the very least.

Rudy_
07/06/2012, 12:09 PM
FIXED!!

JohnBroddy
20/06/2016, 08:12 AM
I Have Fixed.