PDA

View Full Version : Need help with some few errors


HyDrAtIc
15/09/2012, 05:08 PM
Hello guys


help me fixing those errors

C:\Users\Mohamed\Desktop\New York City Roleplay\gamemodes\NYRP.pwn(16901) : error 017: undefined symbol "distance"
C:\Users\Mohamed\Desktop\New York City Roleplay\gamemodes\NYRP.pwn(16901) : warning 215: expression has no effect
C:\Users\Mohamed\Desktop\New York City Roleplay\gamemodes\NYRP.pwn(16901) : error 001: expected token: ";", but found ")"
C:\Users\Mohamed\Desktop\New York City Roleplay\gamemodes\NYRP.pwn(16901) : error 029: invalid expression, assumed zero
C:\Users\Mohamed\Desktop\New York City Roleplay\gamemodes\NYRP.pwn(16901) : fatal error 107: too many error messages on one line

Compilation aborted.Pawn compiler 3.2.3664 Copyright (c) 1997-2006, ITB CompuPhase


4 Errors.



Here's the line:

HouseInfo[iIndex][hTextID] = CreateDynamic3DTextLabel(szFileStr, COLOR_GREEN, HouseInfo[iIndex][hExteriorX], HouseInfo[iIndex][hExteriorY], HouseInfo[iIndex][hExteriorZ]+0.5,30.0, .testlos = 1, .distance = 30.0);

RLGaming
15/09/2012, 05:09 PM
Change .distance to .streamdistance! :)

HouseInfo[iIndex][hTextID] = CreateDynamic3DTextLabel(szFileStr, COLOR_GREEN, HouseInfo[iIndex][hExteriorX], HouseInfo[iIndex][hExteriorY], HouseInfo[iIndex][hExteriorZ]+0.5,30.0, .testlos = 1, .streamdistance = 30.0);

There you go.

Cxnnor
15/09/2012, 05:10 PM
HouseInfo[iIndex][hTextID] = CreateDynamic3DTextLabel(szFileStr, COLOR_GREEN, HouseInfo[iIndex][hExteriorX], HouseInfo[iIndex][hExteriorY], HouseInfo[iIndex][hExteriorZ]+0.5,30.0, .testlos = 1, .streamdistance = 30.0) Semi-colon isn't needed. If that doesn't work, check to ensure you have the two brackets.

{
// Code
}

BiosMarcel
15/09/2012, 05:10 PM
HouseInfo[iIndex][hTextID] = CreateDynamic3DTextLabel(szFileStr, COLOR_GREEN, HouseInfo[iIndex][hExteriorX], HouseInfo[iIndex][hExteriorY], HouseInfo[iIndex][hExteriorZ]+0.5,30.0, 1,30);

Semi-Colon is needed but he must remove the words

HyDrAtIc
15/09/2012, 05:38 PM
Marcel;2119652']HouseInfo[iIndex][hTextID] = CreateDynamic3DTextLabel(szFileStr, COLOR_GREEN, HouseInfo[iIndex][hExteriorX], HouseInfo[iIndex][hExteriorY], HouseInfo[iIndex][hExteriorZ]+0.5,30.0, 1,30);

Semi-Colon is needed but he must remove the words

Thanks this one worked but now i have these errors

C:\Users\Mohamed\Desktop\New York City Roleplay\gamemodes\NYRP.pwn(16901) : warning 217: loose indentation
C:\Users\Mohamed\Desktop\New York City Roleplay\gamemodes\NYRP.pwn(52475) : error 017: undefined symbol "distance"
C:\Users\Mohamed\Desktop\New York City Roleplay\gamemodes\NYRP.pwn(52475) : warning 215: expression has no effect
C:\Users\Mohamed\Desktop\New York City Roleplay\gamemodes\NYRP.pwn(52475) : error 001: expected token: ";", but found ")"
C:\Users\Mohamed\Desktop\New York City Roleplay\gamemodes\NYRP.pwn(52475) : error 029: invalid expression, assumed zero
C:\Users\Mohamed\Desktop\New York City Roleplay\gamemodes\NYRP.pwn(52475) : fatal error 107: too many error messages on one line

Compilation aborted.Pawn compiler 3.2.3664 Copyright (c) 1997-2006, ITB CompuPhase


4 Errors.


Line:

HouseInfo[house][hTextID] = CreateDynamic3DTextLabel( string, COLOR_GREEN, HouseInfo[house][hExteriorX], HouseInfo[house][hExteriorY], HouseInfo[house][hExteriorZ]+0.5, 30.0, .testlos = 1, .distance = 30.0);
return 1;

RLGaming
15/09/2012, 05:42 PM
As I said before..

Change .distance to .streamdistance.
HouseInfo[iIndex][hTextID] = CreateDynamic3DTextLabel(szFileStr, COLOR_GREEN, HouseInfo[iIndex][hExteriorX], HouseInfo[iIndex][hExteriorY], HouseInfo[iIndex][hExteriorZ]+0.5,30.0, .testlos = 1, .streamdistance = 30.0);

I had this problem before, changing it to .streamdistance fixed it for me.

HyDrAtIc
15/09/2012, 05:51 PM
As I said before..

Change .distance to .streamdistance.


I had this problem before, changing it to .streamdistance fixed it for me.

I actually did that didn't work but just one note I'm using the sa-mp 0.3d includes

RLGaming
15/09/2012, 05:52 PM
Oh, no idea then sorry!

Presumed you were using 0.3e

HyDrAtIc
15/09/2012, 05:53 PM
Oh, no idea then sorry!

Presumed you were using 0.3e

Well,no problem anyway thank you for helping!

HyDrAtIc
15/09/2012, 06:16 PM
Bumb