PDA

View Full Version : "File or function is not found" error


Heni
25/01/2013, 11:39 AM
Hello Brothers!

I think most of you know this problem ((Read the title))
and this error comes from plugins, but my problem is when I
start the server ((click on Start-Server)) the plugin ''audio.dll'' deleted automatically. I tried several times to copy it in the folder and try again, but I did not succeed, so can you please help me?

[14:00:57] Script[gamemodes/myserver.amx]: Run time error 19: "File or function is not found"
[14:00:57] Number of vehicle models: 0

DiGiTaL_AnGeL
25/01/2013, 11:43 AM
There is a plugin missing, post server.cfg too.

Gortex
25/01/2013, 11:44 AM
i've got the same problem but when i run it in HomeHost works fine but when on Volt Host i've got a problem and yes i'm using .os on volt host

DiGiTaL_AnGeL
25/01/2013, 11:47 AM
You 2 must create a folder called "plugins" in the server's main folder, and then upload the FSs you use.

Heni
25/01/2013, 02:37 PM
There is a plugin missing, post server.cfg too.

I know that audio.dll missing because when I start the server this plugin auto-deleted, I do not know why. [By the way] days ago, I tried to disable the antivirus and it works correctly, but now no more :confused:

Mean
25/01/2013, 02:44 PM
Make sure to add .so after plugin name on linux, so the line in server cfg looks like this:


plugins mysql.so whirlpoo.so blabla.so


It's not needed to add ".dll" in windows, but you must add ".so" on linux.

I know that audio.dll missing because when I start the server this plugin auto-deleted, I do not know why. [By the way] days ago, I tried to disable the antivirus and it works correctly, but now no more :confused:

.dll? you must use .so plugins on linux

Blackazur
25/01/2013, 02:45 PM
Have you that on top of your script?

main( ) { }

Heni
25/01/2013, 02:47 PM
I'm using Windows and i added the plugins in server.cfg
plugins audio.dll sscanf.dll streamer.dll


Logs ?

SA-MP Dedicated Server
----------------------
v0.3e-R2, (C)2005-2012 SA-MP Team

[17:01:57]
[17:01:57] Server Plugins
[17:01:57] --------------
[17:01:57] Loading plugin: audio.dll
[17:01:57] Failed.
[17:01:57] Loading plugin: sscanf.dll
[17:01:57]

[17:01:57] ===============================

[17:01:57] sscanf plugin loaded.

[17:01:57] Version: 2.8.1

[17:01:57] (c) 2012 Alex "******" Cole

[17:01:57] ===============================

[17:01:57] Loaded.
[17:01:57] Loading plugin: streamer.dll
[17:01:57]

*** Streamer Plugin v2.6.1 by Incognito loaded ***

[17:01:57] Loaded.
[17:01:57] Loaded 2 plugins.

[17:01:57]
[17:01:57] Filterscripts
[17:01:57] ---------------
[17:01:57] Loading filterscript 'buttons.amx'...
[17:01:57] Loading filterscript 'anims.amx'...
[17:01:58] Loaded 2 filterscripts.

[17:01:58] Script[gamemodes/myserver.amx]: Run time error 19: "File or function is not found"
[17:01:58] Number of vehicle models: 0

Heni
25/01/2013, 02:51 PM
Have you that on top of your script?

main( ) { }

Sure

main()
{
print(" ");
print("-------------------------------------------");
print("Loading...");
print("Welcome to my server name");
print("-------------------------------------------");
print(" ");
}

bathushan
25/01/2013, 04:19 PM
Check it out Tho.
It can help you!
http://forum.sa-mp.com/showthread.php?t=408940