PDA

View Full Version : RP server bug?


Almero
05/02/2013, 07:43 AM
Hi

I'm new to this game and the whole modding thing but while trying to set-up this server and put it online on my home PC on the new 0.3x SAMP, i keep on getting some errors.

Server Downloaded: http://forum.sa-mp.com/showthread.php?t=132226

When starting the server it keeps on giving the same error "Server connection closed".

AllowPlayerTeleport() : function is deprecated. Please see OnPlayerClickMap()


Thinking if i downloaded the fixes.inc file that someone recommended in another thread to add it to the game mode file it would finally help and compile, so i added the #include <fixes> and went ahead to compile and the following error...

fixes.inc(3848) : error 001: expected token: ";", but found "}"

Line 3848 is "}" only, so here is part of the code that i hope someone can be assistance of.

Lines 3842-3851

#else
stock FIXES_AllowPlayerTeleport(playerid, allow)
{
if (0 <= playerid < MAX_PLAYERS)
{
CallRemoteFunction(FIXES_gscAllowTeleport, FIXES_gscSpec@ii, playerid, allow)
}
return 0;
}
#endif

I'm guessing this has something to do with the fact the server wasn't created obviously for 0.3x SA-MP which is the newest and this mode was released in 2010 or so.

Thank a bunch for reading and appreciate any kind of help.

Any ideas?
Thanks

Maraudeur
05/02/2013, 08:25 AM
Add a ;

CallRemoteFunction(FIXES_gscAllowTeleport, FIXES_gscSpec@ii, playerid, allow);

Almero
05/02/2013, 09:04 AM
Thanks that worked. ;o

Beats the hell out of me with such simple errors.

Thank you