PDA

View Full Version : Apostrophe bug in commands


sidney123
11/08/2013, 02:03 PM
Hello,

So we are having a huge bug with the commands. We are not allowed to talk with apostrophes in a command, /ooc for example. I already looked in the anticheat and the anti-advertisement system but I can't find it there. It's really annoying and it only appears in commands. When we talk normally (using 'T' without commands) then it works fine.

I'm not sure if it's a scripting bug or a server bug, as it worked before and I'm 99,9% sure that we didn't change the anticheat nor any other files which could cause the bug before.

Yours sincerely,
Sidney.

-- EDIT --

My development team already fixed this issue. Thanks for the help!
It was the escape thing indeed.

RajatPawar
11/08/2013, 02:43 PM
What I gather is - something in (IF YOU USE ZCMD) OnPlayerCommandText/OnPlayerCommandText that goes through the command executed.. Check for all those callbacks

Vince
11/08/2013, 02:47 PM
Are you logging commands with SQL? If yes, have you escaped your inputs?

sidney123
11/08/2013, 11:01 PM
@Vince - Yes, we are logging commands with SQL, and I don't think that it's escaped.

-- EDIT --

My development team already fixed it before I knew it. Thanks for the help anyway.