PDA

View Full Version : urgent help!!


Haz
17/11/2013, 01:29 PM
hello guys,
i added map in my server game mode and i recompiled it it was good and when i host it so it gave me this


Script[gamemodes/LSGW.amx]: Run time error 19: "File or function is not found"

help pls quickk



thnx

SAMProductions
17/11/2013, 01:31 PM
Use Native Checker, It helps you find out which problem is it;

First of all,

NativeChecker Plugin:
[Plugin] nativechecker (http://forum.sa-mp.com/showthread.php?t=249226)

Check your "Plugins" Directory, and Look for "nativechecker.dll" or "nativechecker.so",

If you don't have "nativechecker.dll" or "nativechecker.so",

Download it here,

[Plugin] nativechecker (http://forum.sa-mp.com/showthread.php?t=249226)

Installation:


Copy the Plugin File plugins.
Open server.cfg and add the plugin's name on plugins line.


and Make sure to update all your Include and Plugins to the Latest Version;

Installation:


Copy the Plugin File plugins.
Open server.cfg and add the plugin's name on plugins line.


It will write or print "Error: Function not registered: '...'", etc. on your Server Log else this kind of text will shown or print on your SA-MP Server CMD;

Post it here.

and

By the way, it sometimes gives that kind of error(s) (Run time error 19: "File or function is not found"), if you get that kind of error(s) it means the version of your plugins are too old, so i suggest to you to update that plugins into the latest version one :)

Haz
17/11/2013, 01:46 PM
thnx for help i did what u tell me and got this

[09:46:10] Error: Function not registered: 'SSCANF_Init'
[09:46:10] Error: Function not registered: 'SSCANF_Join'
[09:46:10] Error: Function not registered: 'SSCANF_Leave'
[09:46:10] Script[gamemodes/LSGW.amx]: Run time error 19: "File or function is not found"
[09:46:10] Number of vehicle models: 0

Bect
17/11/2013, 01:49 PM
add in server.cfg

plugins streamer


i think you use CreateDynamicObject .

Haz
17/11/2013, 01:51 PM
yes thnx Bect

Bect
17/11/2013, 01:53 PM
Haz, it's working ? pm me ! or post here or edit your post and say yes, it's working.

SAMProductions
17/11/2013, 01:59 PM
yes thnx Bect

Haz, it's working ? pm me ! or post here or edit your post and say yes, it's working.

Don't you read whats Haz's Previous Post, he/she said it's working and "Thanks To You Bect" ?,

Anyways, It's Awesome how you fixed it, Great Job :)

Haz
18/11/2013, 06:04 AM
no guys i added the shit thing streamer but still the same problem xD what to do ???

]Rafaellos[
18/11/2013, 06:06 AM
Post you'r map.

Haz
18/11/2013, 06:25 AM
man what u mean post map see this 5.175.145.69:7772

StuartD
18/11/2013, 06:28 AM
Have you installed the sscanf plugin?

[09:46:10] Error: Function not registered: 'SSCANF_Init'
[09:46:10] Error: Function not registered: 'SSCANF_Join'
[09:46:10] Error: Function not registered: 'SSCANF_Leave'

EDIT: http://forum.sa-mp.com/showthread.php?t=120356

Haz
18/11/2013, 06:29 AM
its asking for sscanf2 plugin and i dont have that shit

Haz
18/11/2013, 06:33 AM
i dont know how to add it from pastbin i never used pastbin so can u do it for me?

Haz
18/11/2013, 06:37 AM
i think this is the problem but where should i add this

native SSCANF_Init(players, invalid, len);
native SSCANF_Join(playerid, const name[], npc);
native SSCANF_Leave(playerid);

PakistaniBaba
18/11/2013, 06:49 AM
Mate , Can you post your mapping code's here , So we easily find the problem
Also server.cfg (CODE) :)
Thank You!!