PDA

View Full Version : help +rep for helper [MYSQL]


kosa451
17/05/2014, 01:57 PM
./includes/mysql.pwn(198) : error 017: undefined symbol "mysql_ping"
./includes/mysql.pwn(211) : error 017: undefined symbol "mysql_ping"
Pawn compiler 3.2.3664 Copyright (c) 1997-2006, ITB CompuPhase


2 Errors.



Lines -


198 - if(mysql_ping(MainPipeline) < 1)
211 - if(mysql_ping(ShopPipeline) < 1)

Spartaaaaa
17/05/2014, 02:10 PM
Download mysql plugin :)
Goto your server dictionary/plugin/ paste there then goto server.cfg put mysql.dll on plugins line

http://forum.sa-mp.com/showthread.php?t=56564&highlight=G-stylez+Mysql
-------- -------------- -------------- -------------
If there is still an error try
Replace this code with 198

198

if(mysql_ping(MainPipeline) == -1)

211

if(mysql_ping(ShopPipeline) == -1)

kosa451
17/05/2014, 02:43 PM
I'm still getting the errors

i do have the mysql plugin too and include.
even configured in the config file

yusei
17/05/2014, 02:47 PM
Try to re-download the whole MySQL package and replace them, open pawno.exe firtsly and browse your gamemode then re-compile it.

kosa451
17/05/2014, 02:49 PM
Try to re-download the whole MySQL package and replace them, open pawno.exe firtsly and browse your gamemode then re-compile it.

I have done that a couple of times but i'm still getting the error

Spartaaaaa
17/05/2014, 03:02 PM
Did you download the mysql ? if yes still getting errors?
Update your Whole Mysql package as yusei said...

kosa451
17/05/2014, 03:12 PM
:eek:Did you download the mysql ? if yes still getting errors?
Update your Whole Mysql package as yusei said...

I HAVE TOLD YOU I HAVE DONE THAT THOUSANDS OF TIMES BUT I AM STILL GETTING THE ERRORS