PDA

View Full Version : Error 001: expected token: "}", but found "new"


DropBasser
13/08/2014, 04:14 PM
Hi, I has this error when I compile the gm with Pawno:

-(1637) Error 001: expected token: "}", but found "new"

Code:
// Boombox //1636
new Boombox[MAX_PLAYERS]; //1637
new BoomboxObject[MAX_PLAYERS]; //1638
new BoomboxStream[MAX_PLAYERS]; //1639
new BoomboxPlayer[MAX_PLAYERS]; //1640
new BoomboxURL[MAX_PLAYERS][256]; //1641
new Float:bpos[MAX_PLAYERS][4]; //1642


Thank alot guys! :P

Misiur
13/08/2014, 04:16 PM
Show us 10 lines up as well

Blast3r
13/08/2014, 04:17 PM
Could you show the lines before 1637? It's possible you didn't close a function with } before those defines.


EDIT: Up was faster D:

DropBasser
13/08/2014, 04:53 PM
Show us 10 lines up as well

Could you show the lines before 1637? It's possible you didn't close a function with } before those defines.


EDIT: Up was faster D:

// About / Crediti // 1612
#define DIALOG_ABOUT 291

new Abt[][200] = {
"Credits of A:RP Workteam:\n\n",
""COE"Michel\t\t"CWE"Comunity Owner\n",
""COE"Django\t\t"CWE"Community Owner\n",
""COE"Simon\t\t"CWE"Head Admin\n",
""COE"Max\t\t"CWE"Head Admin\n",
""COE"All Staff\t\t"CWE"Always Standing Ready For Us\n",
""COE"All Testers\t"CWE"Helping with testing\n"

/*new Abt[][200] = {
""CWE"\nHere is a small information about the \"About / Credits\"\n",
"We using the zGaming Gamemode because we love the modern 0.3e Funictions\n",
"Also its a very nice gamemode, we try to make it bug free and maybe release it later\n",
"Do you need more information? go to Roy Nash or the Community Staff Team\n\n\n",
"Credits:\n\n"COE"iRage\t\t"CWE"zGaming\n",
""COE"Roy Nash\t"CWE"Edition\n",
""COE"SA-MP\t\t"CWE"Dev. Team\n",
"\n\n\n{FF0000}This script is copyrighted to iRage.\n",
"It may be edited, hosted, renamed, redistributed, etc. as long as credit is given to me."
};*/
// 1635

PrivatioBoni
13/08/2014, 04:55 PM
@Below - explain how you resolved it so others can see this thread and resolve it too :)

(My original comment made no sense)

DropBasser
13/08/2014, 04:55 PM
I've resolved the problem, thanks anyway!