PDA

View Full Version : Server_login problem


KamalBa
09/07/2015, 06:30 AM
----------
Loaded log file: "server_log.txt".
----------

SA-MP Dedicated Server
----------------------
v0.3.7, (C)2005-2015 SA-MP Team

[09:30:09]
[09:30:09] Server Plugins
[09:30:09] --------------
[09:30:09] Loading plugin: MerRandom
[09:30:09] Plugin MerRandom v2.1 - by Cyber_Punk got loaded.
[09:30:09] Loaded.
[09:30:09] Loading plugin: PointToPoint
[09:30:09] PointToPoint Plugin Loaded.
[09:30:09] Loaded.
[09:30:09] Loading plugin: streamer
[09:30:09]

*** Streamer Plugin v2.7.2 by Incognito loaded ***

[09:30:09] Loaded.
[09:30:09] Loading plugin: nativechecker
[09:30:09] Loaded.
[09:30:09] Loading plugin: sscanf
[09:30:09]

[09:30:09] ===============================

[09:30:09] sscanf plugin loaded.

[09:30:09] Version: 2.8.1

[09:30:09] (c) 2012 Alex "******" Cole

[09:30:09] ===============================

[09:30:09] Loaded.
[09:30:09] Loaded 5 plugins.

[09:30:09]
[09:30:09] Filterscripts
[09:30:09] ---------------
[09:30:09] Loading filterscript 'buildings.amx'...
[09:30:09] Loading filterscript 'oupdates.amx'...
[09:30:09] Error: Function not registered: 'SSCANF_Init'
[09:30:09] Error: Function not registered: 'SSCANF_Join'
[09:30:09] Error: Function not registered: 'SSCANF_Leave'
[09:30:09] Error: Function not registered: 'sscanf'
[09:30:09] OnFilter
[09:30:09] Loaded 2 filterscripts.

[09:30:09] Error: Function not registered: 'SSCANF_Init'
[09:30:09] Error: Function not registered: 'SSCANF_Join'
[09:30:09] Error: Function not registered: 'SSCANF_Leave'
[09:30:09] SSCANF2 Loaded
[09:30:10] Filterscript 'oupdates.amx' load failed.
[09:30:10] SSCANF2 Loaded
[09:30:10] Number of vehicle models: 107



server.cfg

echo Executing Server Config...
lanmode 0
rcon_password -----
maxplayers 30
port 7777
hostname Repexlona Gaming [0.3.7]
gamemode0 roleplaying
filterscripts buildings oupdates
plugins MerRandom PointToPoint streamer nativechecker sscanf
announce 0
query 1
chatlogging 0
weburl Coming Soon!
onfoot_rate 40
incar_rate 40
weapon_rate 40
stream_distance 300.0
stream_rate 1000
maxnpc 0
logtimeformat [%H:%M:%S]
language English
map San Andreas


Help how to fix this ?

SoFahim
09/07/2015, 06:37 AM
You must Update all your Plugins, Recompile with latest plugin's includes. whole FilterScript and Gamemode.
FilterScript doesn't need to recompile if there no plugin's includes. like #includes <etc.inc>

KamalBa
09/07/2015, 07:08 AM
Let me try

JuanStone
09/07/2015, 07:10 AM
Try.


echo Executing Server Config...
lanmode 0
rcon_password -----
maxplayers 30
port 7777
hostname Repexlona Gaming [0.3.7]
gamemode0 roleplaying
filterscripts buildings oupdates
plugins MerRandom PointToPoint streamer sscanf nativechecker
announce 0
query 1
chatlogging 0
weburl Coming Soon!
onfoot_rate 40
incar_rate 40
weapon_rate 40
stream_distance 300.0
stream_rate 1000
maxnpc 0
logtimeformat [%H:%M:%S]
language English
map San Andreas

KamalBa
09/07/2015, 07:22 AM
while compile found in test_cmds

a lot of errors and i can't solve it


C:\Users\win7\Desktop\RP server\filterscripts\test_cmds.pwn(53) : error 017: undefined symbol "INVALID_ACTOR_ID"
C:\Users\win7\Desktop\RP server\filterscripts\test_cmds.pwn(53) : error 008: must be a constant expression; assumed zero
C:\Users\win7\Desktop\RP server\filterscripts\test_cmds.pwn(88) : error 017: undefined symbol "CreateExplosionForPlayer"
C:\Users\win7\Desktop\RP server\filterscripts\test_cmds.pwn(82) : warning 203: symbol is never used: "Radius"
C:\Users\win7\Desktop\RP server\filterscripts\test_cmds.pwn(82) : warning 203: symbol is never used: "type"
C:\Users\win7\Desktop\RP server\filterscripts\test_cmds.pwn(82) : warning 203: symbol is never used: "Z"
C:\Users\win7\Desktop\RP server\filterscripts\test_cmds.pwn(82) : warning 203: symbol is never used: "Y"
C:\Users\win7\Desktop\RP server\filterscripts\test_cmds.pwn(82) : warning 203: symbol is never used: "X"
C:\Users\win7\Desktop\RP server\filterscripts\test_cmds.pwn(124) : error 029: invalid expression, assumed zero
C:\Users\win7\Desktop\RP server\filterscripts\test_cmds.pwn(124) : warning 215: expression has no effect
C:\Users\win7\Desktop\RP server\filterscripts\test_cmds.pwn(124) : warning 215: expression has no effect
C:\Users\win7\Desktop\RP server\filterscripts\test_cmds.pwn(124) : warning 215: expression has no effect
C:\Users\win7\Desktop\RP server\filterscripts\test_cmds.pwn(124) : warning 215: expression has no effect
C:\Users\win7\Desktop\RP server\filterscripts\test_cmds.pwn(124) : error 001: expected token: ";", but found ")"
C:\Users\win7\Desktop\RP server\filterscripts\test_cmds.pwn(124) : error 029: invalid expression, assumed zero
C:\Users\win7\Desktop\RP server\filterscripts\test_cmds.pwn(124) : fatal error 107: too many error messages on one line

Compilation aborted.Pawn compiler 3.2.3664 Copyright (c) 1997-2006, ITB CompuPhase


7 Errors.

KamalBa
09/07/2015, 07:32 AM
Line 53- new test_actor_id = INVALID_ACTOR_ID;
Line 82 - stock CreateExplosionEx(Float:X, Float:Y, Float:Z, type, Float:Radius, virtualworld)
Line 88 - CreateExplosionForPlayer(x, X, Y, Z, type, Radius);
Line 124 - ShowPlayerDialog(playerid,2,DIALOG_STYLE_TABLIST_H EADERS,"Buy Weapon",listitems,"Select","Cancel");

KamalBa
09/07/2015, 07:49 AM
nvm fixed