PDA

View Full Version : Mapping compile error


Nucky
16/09/2015, 05:50 PM
I'm not sure if I have to compile this .pwn but it's located in my includes inside pawno folder.
This is my mapping file and uses LoadObjects()

Once I try to compile I get this error. I know it's because I don't have any functions in the .pwn but the file worked even without compile it's just that I can't change it. It won't update. So I can't add new maps / delete maps. There is no .amx file in the folder as well, so I don't think compiling is needed? Or is compiling always needed for .pwns no matter what?

This is the error I get (on a line that doesn't exist)
(5159) : error 013: no entry point (no public functions)

rappy93
16/09/2015, 06:00 PM
Just make sure that you include this file at the top of your gamemode and compile your gamemode. It will compile this file as well.

Use #include <IncludeName> at the top.

Nucky
16/09/2015, 06:01 PM
I added
#include <a_samp> and it compiled. But I don't think its still loading in game.

Nucky
16/09/2015, 06:04 PM
There is no limit for CreateDynamicObject?

I also removed some objects from the map file but they are still there. And the new ones won't appear.
I am using Incognito Streamer plugin, newest version. I've added .amx and .pwn, and also included the mapfile in my gamemode script.

rappy93
16/09/2015, 06:17 PM
There is a limit for everything but I highly doubt it that your map has more objects than the streamer can take.

Try taking the code with "CreateDynamicObject" from the map file and put it into your gamemode directly.

Nucky
16/09/2015, 06:25 PM
I'll try that. But there is no problem at all using a .pwn as an include? Or should I rename it to .inc?

EDIT: I added some of the mapfile in the gamemode and now it loaded. What am I doing wrong?
If you miss something from me, just let me know. Maybe something you should know. The mapfile uses LoadObjects(); and pragma tabsize 0 in the top.

I removed a mapping from that file and rebooted server. That mapping I removed from the mapfile is still on the server. And the new ones I have to add in the script.


AND I renamed the map.pwn to something else and I still get objects loaded on the server that does not exist -_-

rappy93
16/09/2015, 06:44 PM
It you have objects spawned that shouldn't be there it means they are created somewhere in the script. Try debugging your code. You could do some searches for "CreateDynamicObject(objectid".

Nucky
16/09/2015, 06:46 PM
I deleted the mapfile and then the objects in the script and the one that didn't exist disappeared. So the script CreateDynamicObject gets removed because I delete the mapfile? MAkes no sense.

Nucky
16/09/2015, 07:19 PM
Something is very wrong with the streamer plugin. I added RemoveBuildingForPlayer and that worked.
I now have removed includes from script and deleted map.pwn from include / pawno. Still, won't load maps in the script.