PDA

View Full Version : Need help with server not loading


1fret
17/09/2015, 04:07 PM
Ok i am making a new server and when i complie the script i only get this error can someone tell me how to resolve it please.. And i dont have a line 1755 so what could have caused that error..
C:\Users\DJNADAN\Desktop\New folder\sampserver 2\pawno\include\YSI\y_hooks/impl.inc(1755) : error 025: function heading differs from prototype
Pawn compiler 3.2.3664 Copyright (c) 1997-2006, ITB CompuPhase


1 Error.


And here is another problem that i have been having, my sscanf is up to date(version 2.9.2 i think is the latest), i have the include in my script, i also wrote it in my server.cfg and i still get this error

[21:20:00] Error: Function not registered: 'SSCANF_Init'
[21:20:00] Error: Function not registered: 'SSCANF_IsConnected'
[21:20:00] Error: Function not registered: 'SSCANF_Join'
[21:20:00] Error: Function not registered: 'SSCANF_Leave'
[21:20:00] Error: Function not registered: 'sscanf'
[21:20:00] Script[gamemodes/RD.amx]: Run time error 19: "File or function is not found"
[21:20:00] Number of vehicle models: 0

Also i have already tried to fix the mvcr100 error and still get this

rappy93
17/09/2015, 04:48 PM
@SSCANF issue: Do you have sscanf.dll(Win) or sscanf.so(Linux) in your plugins folder?

The other problem resides within the y_hooks include. "include\YSI\y_hooks". Its most likely a problem with the include's version.

1fret
17/09/2015, 05:18 PM
yes i have the win version in the plugins folder

Michael B
17/09/2015, 05:26 PM
Make sure you write sscanf only at the plugins line, when hosting on Windows. If the problem persists, download nativechecker plugin from here (http://forum.sa-mp.com/showthread.php?t=249226), place it as the last at the plugins line and run the server.

rappy93
17/09/2015, 05:26 PM
Then install nativechecker plugin and run the server. This should tell you what the problem is.

1fret
18/09/2015, 02:30 AM
i have solved the sscanf error but is there a way to fix the y_hooks, im currently using an win 8.1 OS at the moment