PDA

View Full Version : Run time error 19


CopKing123
06/03/2016, 08:54 PM
Need help to solve the following errors, when running my gamemode
Will +REP!

[02:52:32] Error: Function not registered: 'mysql_log'
[02:52:32] Error: Function not registered: 'mysql_connect'
[02:52:32] Error: Function not registered: 'mysql_errno'
[02:52:32] Error: Function not registered: 'mysql_format'
[02:52:32] Error: Function not registered: 'mysql_tquery'
[02:52:32] Error: Function not registered: 'WP_Hash'
[02:52:32] Error: Function not registered: 'cache_get_data'
[02:52:32] Error: Function not registered: 'cache_get_field_content'
[02:52:32] Error: Function not registered: 'cache_get_field_content_int'
[02:52:32] Error: Function not registered: 'cache_insert_id'
[02:52:32] Script[gamemodes/tdm.amx]: Run time error 19: "File or function is not found"
[02:52:32] Number of vehicle models: 0


Thank you

itsCody
06/03/2016, 09:01 PM
You're probably missing those plugins.

MySQL: https://github.com/pBlueG/SA-MP-MySQL/releases
Whirlpool: http://forum.sa-mp.com/showthread.php?t=570945

CopKing123
06/03/2016, 09:21 PM
Alright let me check..

CopKing123
07/03/2016, 08:31 AM
alright I downloaded/addes the plugins u told me..
compiled the script, no errors, added them in the plugins in server.cfg
now left with these errors..

[14:30:56] Error: Function not registered: 'CA_DestroyObject'
[14:30:56] Error: Function not registered: 'CA_RayCastLine'
[14:30:56] Error: Function not registered: 'CA_RemoveBuilding'
[14:30:56] Error: Function not registered: 'CA_Init'
[14:30:56] Error: Function not registered: 'regex_match'

CopKing123
07/03/2016, 08:37 AM
ok after adding plugins of the desired gm..
it shows this

[14:36:36] *** Streamer Plugin: Include file version (0x26104) does not match plugin version (0x279001) (script might need to be recompiled with the latest include file)

I do have re-compiled with the new streamer plugin 2.8v, but why is it saying does not match plugin??
Need help please

xTURBOx
07/03/2016, 09:02 AM
Because plugin version and include version don't match

CopKing123
07/03/2016, 10:31 AM
Ok I've downloaded new one, now when I'm starting the server, it shows Streamer plugin failed to load..
!WHY! :'(

MicroKyrr
07/03/2016, 11:14 AM
Make sure u put the streamer in the plugins line , check if there is typo.The latest streamer.inc should be put in "Pawno/include" folder. and latest streamer.dll should be put in "plugins" folder

CopKing123
07/03/2016, 11:21 AM
yea I know, I've placed the files in correct folder, still getting the error :/

CopKing123
07/03/2016, 11:24 AM
[17:23:57] Error: Function not registered: 'mysql_log'
[17:23:57] Error: Function not registered: 'mysql_connect'
[17:23:57] Error: Function not registered: 'mysql_errno'
[17:23:57] Error: Function not registered: 'CreateDynamicObject'
[17:23:57] Error: Function not registered: 'mysql_format'
[17:23:57] Error: Function not registered: 'mysql_tquery'
[17:23:57] Error: Function not registered: 'WP_Hash'
[17:23:57] Error: Function not registered: 'cache_get_data'
[17:23:57] Error: Function not registered: 'cache_get_field_content'
[17:23:57] Error: Function not registered: 'cache_get_field_content_int'
[17:23:57] Error: Function not registered: 'cache_insert_id'

here r the errors im getting.. I do have MYSQL & Whirlpool