PDA

View Full Version : Problem with object.


dhelz7
04/05/2016, 07:18 AM
After I finished past problem. I got a new problem.
We have some mappings for LSPD. But we couldn't found the objects.
It took a long time to get the objects back (slow load).
Can anyone tell me the problems also the way out? Thank u.

Sorry for my bad english

Micko123
04/05/2016, 07:30 AM
Are you using CreateDynamicObject??

colonel-top
04/05/2016, 07:31 AM
If Using streamer object check that your stream range is correct or try

Streamer_Update(playerid);

dhelz7
04/05/2016, 07:46 AM
If Using streamer object check that your stream range is correct or try

Streamer_Update(playerid);


Where I should put that text?

dhelz7
04/05/2016, 07:48 AM
Also how to set stream range? Thank u

colonel-top
04/05/2016, 07:48 AM
OnPlayerSpawn

BTW make sure that in native you didn't change default value I think original is 250
And Keep in mind CreateDynamicObject can stream 1000 object at most per area & range
and you might check in server.cfg that stream range are not too low


To Check Stream Range find Streamer.inc and open it inside have native CreateDynamicObject

and make sure that object you create bu CreateDynamicCP "Correctly Syntax"


CreateDynamicCP(Float:x, Float:y, Float:z, Float:size, worldid = -1, interiorid = -1, playerid = -1, Float:distance);

Sew_Sumi
04/05/2016, 11:05 AM
CreateDynamicObject(modelid, Float: x, Float:y, Float:z, Float:rx, Float:ry, Float:rz, worldid = -1, interiorid = -1, playerid = -1, Float: streamdistance = STREAMER_OBJECT_SD, Float: drawdistance = STREAMER_OBJECT_DD, STREAMER_TAG_AREA areaid = STREAMER_TAG_AREA -1) ;