PDA

View Full Version : Load Object problem...


mikianto
07/05/2016, 12:45 PM
Hello.
The my gamemode not load object...Using incognito streamer, version 2.8 (latest version).
public LoadObject()
{
//BLOCCO TRANSFENDER E PAY N SPRAY
CreateDynamicObject(989, 2386.70483, 1043.52673, 11.44947, 0.00000, 0.00000, 286.84296);
CreateDynamicObject(988, 1025.03699, -1029.45557, 30.93327, 0.00000, 0.00000, 0.00000);
CreateDynamicObject(988, 1041.50537, -1026.05627, 30.93327, 0.00000, 0.00000, 0.00000);
CreateDynamicObject(988, 488.36600, -1734.66736, 10.52410, 0.00000, 0.00000, 172.50017);
CreateDynamicObject(989, 2646.23853, -2039.14233, 13.89580, 0.00000, 0.00000, -253.14000);
CreateDynamicObject(989, 2643.74536, -2039.12061, 13.89580, 0.00000, 0.00000, -253.14000);
CreateDynamicObject(986, -2716.17505, 217.11937, 4.82140, 0.00000, 0.00000, -90.17999);
CreateDynamicObject(986, -1904.57056, 277.80841, 41.67360, 0.00000, 0.00000, 180.00000);
CreateDynamicObject(986, -1929.35754, 277.73895, 41.67360, 0.00000, 0.00000, 180.00000);
CreateDynamicObject(986, -1937.07458, 277.76700, 41.67360, 0.00000, 0.00000, 180.00000);
CreateDynamicObject(986, -1936.45581, 239.37950, 34.17360, 0.00000, 0.00000, 180.00000);
CreateDynamicObject(986, -2425.41113, 1028.17395, 50.88490, 0.00000, 0.00000, 0.00000);
CreateDynamicObject(986, -1420.64099, 2591.10059, 55.19740, 0.00000, 0.00000, 0.00000);
CreateDynamicObject(986, 1968.39722, 2154.65063, 10.80780, 0.00000, 0.00000, 89.82000);
CreateDynamicObject(986, 1968.45544, 2162.43774, 10.80780, 0.00000, 0.00000, 89.82000);
CreateDynamicObject(986, 1968.41162, 2170.96216, 10.80780, 0.00000, 0.00000, 89.82000);
CreateDynamicObject(986, 1968.34900, 2145.92749, 10.80780, 0.00000, 0.00000, 89.82000);
CreateDynamicObject(986, 1958.93701, 2141.01392, 10.80780, 0.00000, 0.00000, 0.00000);
CreateDynamicObject(986, 1950.54810, 2140.88989, 10.80780, 0.00000, 0.00000, 0.00000);
CreateDynamicObject(986, 1942.40320, 2140.94067, 10.80780, 0.00000, 0.00000, 0.00000);
CreateDynamicObject(986, -100.05380, 1111.40076, 19.23130, 0.00000, 0.00000, -180.00000);
CreateDynamicObject(986, 719.71716, -462.52942, 16.10560, 0.00000, 0.00000, 180.00000);
CreateDynamicObject(986, 2071.57544, -1831.88855, 12.54010, 0.00000, 0.00000, -90.00000);
CreateDynamicObject(986, 1843.33435, -1855.94788, 10.87100, 0.00000, 0.00000, 90.00000);
// FINE BLOCCO TRASNFENDER E PAY N SPRAY
}

I put it under OnGameModeInit.Sorry my bad english.

mikianto
07/05/2016, 05:37 PM
Help me please :(

Sew_Sumi
07/05/2016, 06:46 PM
Post up the compiler output when you compile.

Also post up the server.log for when you start the server.

mikianto
08/05/2016, 07:27 AM
Compiler output:
Pawn compiler 3.2.3664 Copyright (c) 1997-2006, ITB CompuPhase

Header size: 8464 bytes
Code size: 503588 bytes
Data size: 12811812 bytes
Stack/heap size: 16384 bytes; estimated max. usage: unknown, due to recursion
Total requirements:13340248 bytes


server log:

----------
Loaded log file: "server_log.txt".
----------

SA-MP Dedicated Server
----------------------
v0.3.7, (C)2005-2015 SA-MP Team

[09:33:44] weburl = "www.sa-mp.com" (string)
[09:33:44]
[09:33:44] Server Plugins
[09:33:44] --------------
[09:33:44] Loading plugin: streamer.dll
[09:33:44]

*** Streamer Plugin v2.8 by Incognito loaded ***

[09:33:44] Loaded.
[09:33:44] Loading plugin: sscanf.dll
[09:33:44]

[09:33:44] ===============================

[09:33:44] sscanf plugin loaded.

[09:33:44] Version: 2.8.1

[09:33:44] (c) 2012 Alex "******" Cole

[09:33:44] ===============================

[09:33:44] Loaded.
[09:33:44] Loading plugin: mysql.dll
[09:33:44] >> plugin.mysql: R34 successfully loaded.
[09:33:44] Loaded.
[09:33:44] Loading plugin: nativechecker.dll
[09:33:44] Loaded.
[09:33:44] Loaded 4 plugins.

[09:33:44]
[09:33:44] Ban list
[09:33:44] --------
[09:33:44] Loaded: samp.ban
[09:33:44]
[09:33:44]
[09:33:44] Filterscripts
[09:33:44] ---------------
[09:33:44] Loading filterscript 'ctuningv22.amx'...
[09:33:44]
--------------------------------------
[09:33:44] Car tunning menu v.2.1, by HeLiOn PrImE, Rsts[Lucas] and kaisersouse
[09:33:44] --------------------------------------

[09:33:44] Loading filterscript 'gare.amx'...
[09:33:44]
+--------------------------------+
[09:33:44] | Sistema Gare yrace 0.4 |
[09:33:44] +--------------LOADED------------+

[09:33:44] Loading filterscript 'actions.amx'...
[09:33:44] Loading filterscript 'corda.amx'...
[09:33:44] Loaded 4 filterscripts.

[09:33:44] Database Mysql caricato
[09:34:26] Concessionari caricati
[09:34:26]
----------------------------------
[09:34:26] United Italian Roleplay
[09:34:26] ----------------------------------

[09:34:26] Number of vehicle models: 0

Sew_Sumi
08/05/2016, 07:54 AM
Try this, all I've done is changed your comments to print out to server.log when it's called. If those lines don't turn up in the server.log, then the issue must be in how you're calling it in OnGamemodeInit.

Maybe try putting it right down near the end of OnGamemodeInit.

If you could post up some of the OnGamemodeInit around where you call the function, it may be interesting to see.

public LoadObject()
{
print("BLOCCO TRANSFENDER E PAY N SPRAY");
CreateDynamicObject(989, 2386.70483, 1043.52673, 11.44947, 0.00000, 0.00000, 286.84296);
CreateDynamicObject(988, 1025.03699, -1029.45557, 30.93327, 0.00000, 0.00000, 0.00000);
CreateDynamicObject(988, 1041.50537, -1026.05627, 30.93327, 0.00000, 0.00000, 0.00000);
CreateDynamicObject(988, 488.36600, -1734.66736, 10.52410, 0.00000, 0.00000, 172.50017);
CreateDynamicObject(989, 2646.23853, -2039.14233, 13.89580, 0.00000, 0.00000, -253.14000);
CreateDynamicObject(989, 2643.74536, -2039.12061, 13.89580, 0.00000, 0.00000, -253.14000);
CreateDynamicObject(986, -2716.17505, 217.11937, 4.82140, 0.00000, 0.00000, -90.17999);
CreateDynamicObject(986, -1904.57056, 277.80841, 41.67360, 0.00000, 0.00000, 180.00000);
CreateDynamicObject(986, -1929.35754, 277.73895, 41.67360, 0.00000, 0.00000, 180.00000);
CreateDynamicObject(986, -1937.07458, 277.76700, 41.67360, 0.00000, 0.00000, 180.00000);
CreateDynamicObject(986, -1936.45581, 239.37950, 34.17360, 0.00000, 0.00000, 180.00000);
CreateDynamicObject(986, -2425.41113, 1028.17395, 50.88490, 0.00000, 0.00000, 0.00000);
CreateDynamicObject(986, -1420.64099, 2591.10059, 55.19740, 0.00000, 0.00000, 0.00000);
CreateDynamicObject(986, 1968.39722, 2154.65063, 10.80780, 0.00000, 0.00000, 89.82000);
CreateDynamicObject(986, 1968.45544, 2162.43774, 10.80780, 0.00000, 0.00000, 89.82000);
CreateDynamicObject(986, 1968.41162, 2170.96216, 10.80780, 0.00000, 0.00000, 89.82000);
CreateDynamicObject(986, 1968.34900, 2145.92749, 10.80780, 0.00000, 0.00000, 89.82000);
CreateDynamicObject(986, 1958.93701, 2141.01392, 10.80780, 0.00000, 0.00000, 0.00000);
CreateDynamicObject(986, 1950.54810, 2140.88989, 10.80780, 0.00000, 0.00000, 0.00000);
CreateDynamicObject(986, 1942.40320, 2140.94067, 10.80780, 0.00000, 0.00000, 0.00000);
CreateDynamicObject(986, -100.05380, 1111.40076, 19.23130, 0.00000, 0.00000, -180.00000);
CreateDynamicObject(986, 719.71716, -462.52942, 16.10560, 0.00000, 0.00000, 180.00000);
CreateDynamicObject(986, 2071.57544, -1831.88855, 12.54010, 0.00000, 0.00000, -90.00000);
CreateDynamicObject(986, 1843.33435, -1855.94788, 10.87100, 0.00000, 0.00000, 90.00000);
print("FINE BLOCCO TRASNFENDER E PAY N SPRAY");
}

You've done well in providing what was requested ;)

mikianto
08/05/2016, 08:21 AM
I solved it by putting on top in OnGameModeInit function.
Thank you very much! +REP.

Sew_Sumi
08/05/2016, 01:49 PM
Check your OnGamemodeInit for issues.

put print("Stage #1 Complete"); and #2 #3 #4 at various stages in the callback, and at the end of it put print("OnGamemodeInit Complete");

It shouldn't matter too much where it goes in there, but what could be happening is somewhere that callback is being stopped mid-way.

Find where it's stopping and figure out why.