PDA

View Full Version : I can't start the server


Ronen765001
15/04/2017, 11:47 AM
It shows me this error:
----------
Loaded log file: "server_log.txt".
----------

SA-MP Dedicated Server
----------------------
v0.3.7-R2, (C)2005-2015 SA-MP Team

[14:29:41] filterscripts = "" (string)
[14:29:41]
[14:29:41] Server Plugins
[14:29:41] --------------
[14:29:41] Loading plugin: streamer
[14:29:41]

*** Streamer Plugin v2.5.2 by Incognito loaded ***

[14:29:41] Loaded.
[14:29:41] Loading plugin: sscanf
[14:29:41]

[14:29:41] ===============================

[14:29:41] sscanf plugin loaded.

[14:29:41] (c) 2009 Alex "******" Cole

[14:29:41] ===============================

[14:29:41] Loaded.
[14:29:41] Loading plugin: mysql
[14:29:41] >> plugin.mysql: R41-2 successfully loaded.
[14:29:41] Loaded.
[14:29:41] Loaded 3 plugins.

[14:29:41]
[14:29:41] Filterscripts
[14:29:41] ---------------
[14:29:41] Loaded 0 filterscripts.

[14:29:41] Script[gamemodes/D-RP.amx]: Run time error 19: "File or function is not found"
[14:29:41] Number of vehicle models: 0


This is the includes that are included:
http://imgur.com/ppullwr

And this is the includes that the script has:
http://imgur.com/M014SXx

I need help, I've been trying to solve that problem and no success.

AndreiWow
15/04/2017, 11:58 AM
You are probably using the wrong version of MySQL :?

Ronen765001
15/04/2017, 12:47 PM
You are probably using the wrong version of MySQL :?

Nope..

Loinal
15/04/2017, 12:56 PM
Check the plugins in the script and make sure its in cfg

Ronen765001
15/04/2017, 03:14 PM
Check the plugins in the script and make sure its in cfg

I am not too sure what is a plugin and what is not.
A picture is provided with the list on the includes, can you help me out?
As far as I know:
MySQL
Streamer
Sscanf

Ronen765001
15/04/2017, 09:04 PM
Any idea guys?

iSanchez
15/04/2017, 09:06 PM
You don't have a missing plugin or you have the wrong version.

Check your scripts for a #include <strange-plugin-name-here>.

If you don't find it, use this:

https://github.com/Zeex/samp-plugin-crashdetect/releases

It will give you more information

LazzyBoy
15/04/2017, 09:06 PM
download and include crashdetect plugin and it will show whats the matter

Ronen765001
15/04/2017, 09:12 PM
You don't have a missing plugin or you have the wrong version.

Check your scripts for a #include <strange-plugin-name-here>.

If you don't find it, use this:

https://github.com/Zeex/samp-plugin-crashdetect/releases

It will give you more information

download and include crashdetect plugin and it will show whats the matter

Now it shows this:

----------
Loaded log file: "server_log.txt".
----------

SA-MP Dedicated Server
----------------------
v0.3.7-R2, (C)2005-2015 SA-MP Team

[00:03:49] filterscripts = "" (string)
[00:03:49]
[00:03:49] Server Plugins
[00:03:49] --------------
[00:03:49] Loading plugin: streamer
[00:03:49]

*** Streamer Plugin v2.5.2 by Incognito loaded ***

[00:03:49] Loaded.
[00:03:49] Loading plugin: mysql
[00:03:49] >> plugin.mysql: R41-2 successfully loaded.
[00:03:49] Loaded.
[00:03:49] Loading plugin: sscanf
[00:03:49]

[00:03:49] ===============================

[00:03:49] sscanf plugin loaded.

[00:03:49] (c) 2009 Alex "******" Cole

[00:03:49] ===============================

[00:03:49] Loaded.
[00:03:49] Loading plugin: FCNPC
[00:03:49]
[00:03:49] -------------------------------------------------
[00:03:49] FCNPC - Fully Controllable NPC v1.7.0
[00:03:49] Windows SA-MP 0.3.7 R2-1
[00:03:49] Apr 2 2017 at 13:48:40
[00:03:49]
[00:03:49] Author: OrMisicL (2013 - 2015)
[00:03:49] Continued by: ziggi (2016 - present)
[00:03:49] Contributors: kurta999, Neutralneu
[00:03:49] -------------------------------------------------
[00:03:49]
[00:03:49] Loading...
[00:03:49] Loaded.
[00:03:49] Loading plugin: crashdetect
[00:03:49] CrashDetect v4.18.1 is OK.
[00:03:49] Loaded.
[00:03:49] Loaded 5 plugins.

[00:03:49]
[00:03:49] Filterscripts
[00:03:49] ---------------
[00:03:49] Loaded 0 filterscripts.

[00:03:49] Warning: the maxnpc limit is 0 (you will not be able to create NPCs unless you change it)
[00:03:49] [debug] Run time error 19: "File or function is not found"
[00:03:49] [debug] SSCANF_Init
[00:03:49] [debug] SSCANF_Join
[00:03:49] [debug] SSCANF_Leave
[00:03:49] [debug] cache_get_field_content_int
[00:03:49] [debug] cache_get_field_content_float
[00:03:49] [debug] cache_get_field_content
[00:03:49] [debug] WP_Hash
[00:03:49] [debug] SetDynamicObjectMaterialText
[00:03:49] [debug] SetDynamicObjectMaterial
[00:03:49] [debug] cache_get_data
[00:03:49] [debug] EditDynamicObject
[00:03:49] [debug] AttachDynamicObjectToVehicle
[00:03:49] [debug] cache_get_row
[00:03:49] [debug] cache_get_row_int
[00:03:49] [debug] Streamer_ToggleItem
[00:03:49] [debug] Streamer_GetTickRate
[00:03:49] [debug] Streamer_SetTickRate
[00:03:49] [debug] Streamer_GetMaxItems
[00:03:49] [debug] Streamer_SetMaxItems
[00:03:49] [debug] Streamer_GetVisibleItems
[00:03:49] [debug] Streamer_SetVisibleItems
[00:03:49] [debug] Streamer_GetRadiusMultiplier
[00:03:49] [debug] Streamer_SetRadiusMultiplier
[00:03:49] [debug] Streamer_IsToggleCameraUpdate
[00:03:49] [debug] Streamer_ToggleCameraUpdate
[00:03:49] [debug] Streamer_IsToggleIdleUpdate
[00:03:49] [debug] Streamer_ToggleIdleUpdate
[00:03:49] [debug] GetPlayerVisibleDynamicCP
[00:03:49] [debug] Streamer_GetCellDistance
[00:03:49] [debug] Streamer_GetCellSize
[00:03:49] [debug] Streamer_ToggleErrorCallback
[00:03:49] [debug] Streamer_DestroyAllItems
[00:03:49] [debug] Run time error 19: "File or function is not found"
[00:03:49] [debug] SSCANF_Init
[00:03:49] [debug] SSCANF_Join
[00:03:49] [debug] SSCANF_Leave
[00:03:49] [debug] cache_get_field_content_int
[00:03:49] [debug] cache_get_field_content_float
[00:03:49] [debug] cache_get_field_content
[00:03:49] [debug] WP_Hash
[00:03:49] [debug] SetDynamicObjectMaterialText
[00:03:49] [debug] SetDynamicObjectMaterial
[00:03:49] [debug] cache_get_data
[00:03:49] [debug] EditDynamicObject
[00:03:49] [debug] AttachDynamicObjectToVehicle
[00:03:49] [debug] cache_get_row
[00:03:49] [debug] cache_get_row_int
[00:03:49] [debug] Streamer_ToggleItem
[00:03:49] [debug] Streamer_GetTickRate
[00:03:49] [debug] Streamer_SetTickRate
[00:03:49] [debug] Streamer_GetMaxItems
[00:03:49] [debug] Streamer_SetMaxItems
[00:03:49] [debug] Streamer_GetVisibleItems
[00:03:49] [debug] Streamer_SetVisibleItems
[00:03:49] [debug] Streamer_GetRadiusMultiplier
[00:03:49] [debug] Streamer_SetRadiusMultiplier
[00:03:49] [debug] Streamer_IsToggleCameraUpdate
[00:03:49] [debug] Streamer_ToggleCameraUpdate
[00:03:49] [debug] Streamer_IsToggleIdleUpdate
[00:03:49] [debug] Streamer_ToggleIdleUpdate
[00:03:49] [debug] GetPlayerVisibleDynamicCP
[00:03:49] [debug] Streamer_GetCellDistance
[00:03:49] [debug] Streamer_GetCellSize
[00:03:49] [debug] Streamer_ToggleErrorCallback
[00:03:49] [debug] Streamer_DestroyAllItems
[00:03:49] Script[gamemodes/D-RP.amx]: Run time error 19: "File or function is not found"
[00:03:49] Number of vehicle models: 0

Ronen765001
15/04/2017, 11:43 PM
Now it's this:


----------
Loaded log file: "server_log.txt".
----------

SA-MP Dedicated Server
----------------------
v0.3.7-R2, (C)2005-2015 SA-MP Team

[02:33:30] filterscripts = "" (string)
[02:33:30]
[02:33:30] Server Plugins
[02:33:30] --------------
[02:33:30] Loading plugin: mysql
[02:33:30] >> plugin.mysql: R41-2 successfully loaded.
[02:33:30] Loaded.
[02:33:30] Loading plugin: sscanf
[02:33:30]

[02:33:30] ===============================

[02:33:30] sscanf plugin loaded.

[02:33:30] (c) 2009 Alex "******" Cole

[02:33:30] ===============================

[02:33:30] Loaded.
[02:33:30] Loading plugin: crashdetect
[02:33:30] CrashDetect v4.18.1 is OK.
[02:33:30] Loaded.
[02:33:30] Loading plugin: streamer
[02:33:30]

*** Streamer Plugin v2.8.2 by Incognito loaded ***

[02:33:30] Loaded.
[02:33:30] Loading plugin: FCNPC
[02:33:30]
[02:33:30] -------------------------------------------------
[02:33:30] FCNPC - Fully Controllable NPC v1.7.0
[02:33:30] Windows SA-MP 0.3.7 R2-1
[02:33:30] Apr 2 2017 at 13:48:40
[02:33:30]
[02:33:30] Author: OrMisicL (2013 - 2015)
[02:33:30] Continued by: ziggi (2016 - present)
[02:33:30] Contributors: kurta999, Neutralneu
[02:33:30] -------------------------------------------------
[02:33:30]
[02:33:30] Loading...
[02:33:30] Loaded.
[02:33:30] Loaded 5 plugins.

[02:33:30]
[02:33:30] Filterscripts
[02:33:30] ---------------
[02:33:30] Loaded 0 filterscripts.

[02:33:31] [debug] Run time error 19: "File or function is not found"
[02:33:31] [debug] SSCANF_Init
[02:33:31] [debug] SSCANF_Join
[02:33:31] [debug] SSCANF_Leave
[02:33:31] [debug] cache_get_field_content_int
[02:33:31] [debug] cache_get_field_content_float
[02:33:31] [debug] cache_get_field_content
[02:33:31] [debug] WP_Hash
[02:33:31] [debug] cache_get_data
[02:33:31] [debug] cache_get_row
[02:33:31] [debug] cache_get_row_int
[02:33:31] [debug] Run time error 19: "File or function is not found"
[02:33:31] [debug] SSCANF_Init
[02:33:31] [debug] SSCANF_Join
[02:33:31] [debug] SSCANF_Leave
[02:33:31] [debug] cache_get_field_content_int
[02:33:31] [debug] cache_get_field_content_float
[02:33:31] [debug] cache_get_field_content
[02:33:31] [debug] WP_Hash
[02:33:31] [debug] cache_get_data
[02:33:31] [debug] cache_get_row
[02:33:31] [debug] cache_get_row_int
[02:33:31] Script[gamemodes/D-RP.amx]: Run time error 19: "File or function is not found"
[02:33:31] Number of vehicle models: 0


Also guys please view the first pics in the first post..

AndreiWow
15/04/2017, 11:56 PM
Update all your plugins... get the latest versions with includes and recompile.

DRIFT_HUNTER
16/04/2017, 01:03 AM
sscanf and mysql are the wrong versions. you need newest for both. Dont forget to update includes to and recompile your script after that.

Ronen765001
16/04/2017, 02:31 AM
Okay I got the script to work thanks.
But there is a problem:

[05:18:13] [debug] Run time error 4: "Array index out of bounds"
[05:18:13] [debug] Attempted to read/write array element at index 65535 in array of size 2000
[05:18:13] [debug] AMX backtrace:
[05:18:13] [debug] #0 001bad24 in public cmd_aveh (0, 170631040) from D-RP.amx
[05:18:13] [debug] #1 native CallLocalFunction () from samp-server.exe
[05:18:13] [debug] #2 000100ec in public OnPlayerCommandText (0, 170630992) from D-RP.amx
[05:18:16] [debug] Run time error 4: "Array index out of bounds"
[05:18:16] [debug] Attempted to read/write array element at index 65535 in array of size 2000
[05:18:16] [debug] AMX backtrace:
[05:18:16] [debug] #0 001bad24 in public cmd_aveh (0, 170631040) from D-RP.amx
[05:18:16] [debug] #1 native CallLocalFunction () from samp-server.exe
[05:18:16] [debug] #2 000100ec in public OnPlayerCommandText (0, 170630992) from D-RP.amx
[05:18:25] [debug] Run time error 4: "Array index out of bounds"
[05:18:25] [debug] Attempted to read/write array element at index 65535 in array of size 2000
[05:18:25] [debug] AMX backtrace:
[05:18:25] [debug] #0 001bad24 in public cmd_aveh (0, 170631040) from D-RP.amx
[05:18:25] [debug] #1 native CallLocalFunction () from samp-server.exe
[05:18:25] [debug] #2 000100ec in public OnPlayerCommandText (0, 170630992) from D-RP.amx
[05:18:27] [debug] Run time error 4: "Array index out of bounds"
[05:18:27] [debug] Attempted to read/write array element at index 65535 in array of size 2000
[05:18:27] [debug] AMX backtrace:
[05:18:27] [debug] #0 001bad24 in public cmd_aveh (0, 170631040) from D-RP.amx
[05:18:27] [debug] #1 native CallLocalFunction () from samp-server.exe
[05:18:27] [debug] #2 000100ec in public OnPlayerCommandText (0, 170630992) from D-RP.amx

I don't know why is this happening, but the script still works.
This happen when the server runs btw.

iSanchez
16/04/2017, 03:16 AM
Okay I got the script to work thanks.
But there is a problem:

[05:18:13] [debug] Run time error 4: "Array index out of bounds"
[05:18:13] [debug] Attempted to read/write array element at index 65535 in array of size 2000
[05:18:13] [debug] AMX backtrace:
[05:18:13] [debug] #0 001bad24 in public cmd_aveh (0, 170631040) from D-RP.amx
[05:18:13] [debug] #1 native CallLocalFunction () from samp-server.exe
[05:18:13] [debug] #2 000100ec in public OnPlayerCommandText (0, 170630992) from D-RP.amx
[05:18:16] [debug] Run time error 4: "Array index out of bounds"
[05:18:16] [debug] Attempted to read/write array element at index 65535 in array of size 2000
[05:18:16] [debug] AMX backtrace:
[05:18:16] [debug] #0 001bad24 in public cmd_aveh (0, 170631040) from D-RP.amx
[05:18:16] [debug] #1 native CallLocalFunction () from samp-server.exe
[05:18:16] [debug] #2 000100ec in public OnPlayerCommandText (0, 170630992) from D-RP.amx
[05:18:25] [debug] Run time error 4: "Array index out of bounds"
[05:18:25] [debug] Attempted to read/write array element at index 65535 in array of size 2000
[05:18:25] [debug] AMX backtrace:
[05:18:25] [debug] #0 001bad24 in public cmd_aveh (0, 170631040) from D-RP.amx
[05:18:25] [debug] #1 native CallLocalFunction () from samp-server.exe
[05:18:25] [debug] #2 000100ec in public OnPlayerCommandText (0, 170630992) from D-RP.amx
[05:18:27] [debug] Run time error 4: "Array index out of bounds"
[05:18:27] [debug] Attempted to read/write array element at index 65535 in array of size 2000
[05:18:27] [debug] AMX backtrace:
[05:18:27] [debug] #0 001bad24 in public cmd_aveh (0, 170631040) from D-RP.amx
[05:18:27] [debug] #1 native CallLocalFunction () from samp-server.exe
[05:18:27] [debug] #2 000100ec in public OnPlayerCommandText (0, 170630992) from D-RP.amx

I don't know why is this happening, but the script still works.
This happen when the server runs btw.

That error happens because there is a bad code on the "cmd_aveh"


paste the cmd_aveh code here to help you

Ronen765001
16/04/2017, 08:48 AM
COMMAND:aveh(playerid, params[])
{
new type[64];
if(sscanf(params, "s[64]", type)) SendClientMessage(playerid, COLOR_ERROR, "USAGE: /aveh [vehicle model id/model name] [respawn 1/0]");
else
{
if (GetPVarInt(playerid, "PlayerLogged") == 0) return SendClientMessage(playerid, COLOR_WHITE, "You must be logged in to use this.");
if(GetPVarInt(playerid, "Admin") >= 7)
{
new model;
if(IsNumeric(type))
{
model = strval(type);
}
else
{
for(new i = 0; i < sizeof(VehicleName) - 1; i++)
{
if(strfind(VehicleName[i], type, true) != -1)
{
model = 400 + i;
break;
}
}
}

new Float:X,Float:Y,Float:Z,vehicleid;
GetPlayerPos(playerid,X,Y,Z);
GetXYInFrontOfPlayer(playerid, X, Y, 3.0);
vehicleid = CreateVehicle(model,X,Y,Z, 90.7350, -1, -1, -1);
VehicleInfo[vehicleid][vFuel] = 100;
VehicleInfo[vehicleid][vWindows] = 0;
VehicleInfo[vehicleid][vEngine] = 0;
VehicleInfo[vehicleid][vType] = VEHICLE_ADMIN;
VehicleInfo[vehicleid][vID] = 0;
VehicleInfo[vehicleid][vEngineStats][1] = 1;
VehicleInfo[vehicleid][vEngineStats][2] = 1;
VehicleInfo[vehicleid][vBattery][1] = 1;
VehicleInfo[vehicleid][vBattery][2] = 1;
Iter_Add(VehicleIterator, vehicleid);
LinkVehicleToInteriorEx(vehicleid, GetPlayerInterior(playerid));
SetVehicleVirtualWorld(vehicleid, GetPlayerVirtualWorld(playerid));
SendClientMessage(playerid, COLOR_WHITE, "Vehicle has been spawned.");
}
else SendClientMessage(playerid, COLOR_ERROR, "You do not have access to this command!");
}
return 1;
}