PDA

View Full Version : Objects disapear when player isn't close to


Suttix
03/08/2017, 10:34 AM
Hello, it's me again with the same problem xD

Map problem on all gamemodes,home server and other servers whichever I join.
http://imgur.com/a/l88TT
This is picture so I'm realy tired of this issue.
Only I have this problem and when I upload gamemode to hosting other player got same issue on my server.
Please help me :(

Dayrion
03/08/2017, 10:38 AM
Do you use streamer plugin? If yes, try to increase the distance where objects are stream.
CreateDynamicObjectEx(modelid, Float:x, Float:y, Float:z, Float:rx, Float:ry, Float:rz, Float:streamdistance = STREAMER_OBJECT_SD, Float:drawdistance = STREAMER_OBJECT_DD, worlds[] = { -1 }, interiors[] = { -1 }, players[] = { -1 }, STREAMER_TAG_AREA areas[] = { STREAMER_TAG_AREA -1 }, priority = 0, maxworlds = sizeof worlds, maxinteriors = sizeof interiors, maxplayers = sizeof players, maxareas = sizeof areas);
200.0 is fine

jlalt
03/08/2017, 10:54 AM
You may need to take rid of some CreateObject codes if you got. [ change CreateObjects to CreateDynamicObjects ].

and then you may also need to use Streamer_SetVisibleItems. by default 500 objects being streamed at once you can increase it up to 1000 as maximum.

so after changing CreateObject to CreateDynamicObject you may wanna add this under ongamemodeinit

Streamer_SetVisibleItems(STREAMER_TYPE_OBJECT, 800);

Suttix
03/08/2017, 11:20 AM
It happens on all servers,plugins aren't problem because it happens on already hosted servers ...
If only I can see this problem and it only happens to me I don't care but when I upload gamemode to host then other players will got this issue on my server.
I installed os windows 7 x64 and after installing windows I installed gta san andreas,samp and downloaded gamemode and got run time 19 error.I fixed it by downloading visual c++ and then i got this issue with objects...
I really have no idea how to fix it. Maybe about 6 months of searching for a solution but nothing....

Suttix
03/08/2017, 04:35 PM
I just played GTA San Andreas singleplayer and objects are streaming very slow and distance is also problem as I said must be close to any object to see it.Objects like breakable trees and some rocks disapear when I'm not close enough.
I don't have any mod or cheat.

Suttix
03/08/2017, 07:23 PM
Anyone?

Logic_
04/08/2017, 09:12 AM
Use a CLEO mod that fixes models not loading on time and stuff like that.

Suttix
04/08/2017, 09:22 AM
Use a CLEO mod that fixes models not loading on time and stuff like that.

Do you believe it'll fix and samp problem?