SA-MP Forums

SA-MP Forums (https://forum.sa-mp.com/index.php)
-   Tutorials (https://forum.sa-mp.com/forumdisplay.php?f=70)
-   -   [Tutorial] Login and Register System - Dialogs - Using Y_INI (https://forum.sa-mp.com/showthread.php?t=273088)

SantarioLeone 30/08/2011 05:57 PM

Re: Login and Register System - Dialogs - Using Y_INI
 
When i conenct it says my Y_ini is working, but when i /q there are no player files in the Users folder.

Coffeemonster 30/08/2011 08:57 PM

Re: Login and Register System - Dialogs - Using Y_INI
 
Did you manually create a folder called Users in the scriptfiles and are you sure the script is valid and not missing some saving functions?

Tigerbeast11 31/08/2011 11:21 AM

Re: Login and Register System - Dialogs - Using Y_INI
 
I'm having some problems. I downloaded your "full package" but when I run it, it doesn't really work... I log on and it asks me to register so i enter a password. Then when the server restarts, it asks me to re-create my account. I looked in the scriptfile/users directory and it seems that the .ini files are not being created.

Note: I have not editted anything in the script...

SantarioLeone 31/08/2011 02:09 PM

Re: Login and Register System - Dialogs - Using Y_INI
 
Quote:

Originally Posted by Coffeemonster (Post 1376167)
Did you manually create a folder called Users in the scriptfiles and are you sure the script is valid and not missing some saving functions?

Yes i have manually created the folder "Users" and that didnt work, i even tried to redefine the saving path, to a new folder, "UserData" but that didnt work either. and the script complies perfectly. But it just wont save any data.

Tigerbeast11 31/08/2011 02:16 PM

Re: Login and Register System - Dialogs - Using Y_INI
 
^^^ Same problem for me :(

HammerSmith 31/08/2011 05:21 PM

Re: Login and Register System - Dialogs - Using Y_INI
 
When I try to compile, I get this error.

Yes, I extracted everything correctly, etc.



C:\Users\Nick\Desktop\SAMPScripting\gamemodes\scri pting.pwn(3) : fatal error 100: cannot read from file: "YSI\y_ini"

Compilation aborted.Pawn compiler 3.2.3664 Copyright (c) 1997-2006, ITB CompuPhase


1 Error.

Coffeemonster 31/08/2011 05:22 PM

Re: Login and Register System - Dialogs - Using Y_INI
 
You must have the YSI include package in your pawno/includes

HammerSmith 31/08/2011 05:29 PM

Re: Login and Register System - Dialogs - Using Y_INI
 
Quote:

Originally Posted by Coffeemonster (Post 1377655)
You must have the YSI include package in your pawno/includes

I do..

Kush 31/08/2011 07:22 PM

Re: Login and Register System - Dialogs - Using Y_INI
 
Alright, to answer everyone's questions:

1) I've just re-done the Y_ini Full Package download using the tutorial. I've registered my account and it saves. I re-logged to check, and it successfully logs me in. It works.

2) 'fatal error 100: cannot read from file: "YSI\y_ini"' > Open Pawno in the include folder in which you've downloaded the Full Package! then open the gamemode. This might be reasons in which you have accessed the application without having the correct includes.

Glorian 01/09/2011 02:18 PM

Re: Login and Register System - Dialogs - Using Y_INI
 
When i register and quit and login i get the Stay within the world boundies.


All times are GMT. The time now is 09:23 PM.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.