SA-MP Forums

SA-MP Forums (https://forum.sa-mp.com/index.php)
-   Help Archive (https://forum.sa-mp.com/forumdisplay.php?f=89)
-   -   AttachObjectToVehicle (https://forum.sa-mp.com/showthread.php?t=278864)

Dragony92 24/08/2011 09:12 AM

AttachObjectToVehicle
 
GameMod Using: Ravens RP (Fully edited by me)

This command dont want to attach object on vehicle....just send message and nothing else....

This is part of this FS http://forum.sa-mp.com/showthread.ph...highlight=neon
FS also dont want to work on my server....
I'm running server on 0.3c R5 (Linux) with plugins streamer(last update, by Incognito) and sscanf(last update), FS junkbuster(v10), that's all...

On my home server everything works fine, on windows with same plugins and FS....
pawn Code:
if(strcmp(cmd, "/undercover", true) == 0)
    {
        if(IsACop(playerid) || IsAFreecop(playerid))
        {
            SetPVarInt(playerid, "undercover", CreateDynamicObject(18646,0,0,0,0,0,0));
            SetPVarInt(playerid, "undercover1", CreateDynamicObject(18646,0,0,0,0,0,0));
            AttachObjectToVehicle(GetPVarInt(playerid, "undercover"), GetPlayerVehicleID(playerid), -0.5, -0.2, 0.8, 2.0, 2.0, 3.0);
            AttachObjectToVehicle(GetPVarInt(playerid, "undercover1"), GetPlayerVehicleID(playerid), -0.5, -0.2, 0.8, 2.0, 2.0, 3.0);
            SendClientMessage(playerid, 0xFFFFFFAA, "You have Attched Undercover light on your vehicle!");
        }
        else
        {
            SendClientMessage(playerid, COLOR_GREY, "**You are not a Cop!");
        }
        return 1;
    }

Wesley221 24/08/2011 09:19 AM

Re: AttachObjectToVehicle
 
pawn Code:
new UnderCoverobj[3];
UnderCoverobj[0] = CreateDynamicObject(18646,0,0,0,0,0,0);
UnderCoverObj[1] = CreateDynamicObject(18646,0,0,0,0,0,0);
AttachObjectToVehicle(UnderCoverobj[0], GetPlayerVehicleID(playerid), -0.5, -0.2, 0.8, 2.0, 2.0, 3.0);
AttachObjectToVehicle(UnderCoverobj[1], GetPlayerVehicleID(playerid), -0.5, -0.2, 0.8, 2.0, 2.0, 3.0);
You have to create the object before you can attach it. And i dont think this can be done through PVars.

Gh0sT_ 24/08/2011 09:24 AM

Re: AttachObjectToVehicle
 
You can't attach dynamic object, you must use CreateObject

Dragony92 24/08/2011 09:35 AM

Re: AttachObjectToVehicle
 
Nothing...i tryed with normal objects (CreateObject)....

Wesley221 24/08/2011 09:36 AM

Re: AttachObjectToVehicle
 
Try it the way like i said b4. Just add the pieces to your code, and remove the createobjects in the pvars

Dragony92 24/08/2011 09:39 AM

Re: AttachObjectToVehicle
 
Same...
pawn Code:
if(strcmp(cmd, "/undercover", true) == 0)
    {
        if(IsACop(playerid) || IsAFreecop(playerid))
        {
            new UnderCoverobj[3];
            UnderCoverobj[0] = CreateObject(18646,0,0,0,0,0,0);
            UnderCoverobj[1] = CreateObject(18646,0,0,0,0,0,0);
            AttachObjectToVehicle(UnderCoverobj[0], GetPlayerVehicleID(playerid), -0.5, -0.2, 0.8, 2.0, 2.0, 3.0);
            AttachObjectToVehicle(UnderCoverobj[1], GetPlayerVehicleID(playerid), -0.5, -0.2, 0.8, 2.0, 2.0, 3.0);
            SendClientMessage(playerid, 0xFFFFFFAA, "You have Attched Undercover light on your vehicle!");
        }
        else
        {
            SendClientMessage(playerid, COLOR_GREY, "**You are not a Cop!");
        }
        return 1;
    }

Edit; Object is creted on coordinates 0 0 0 but not attached...

Wesley221 24/08/2011 09:40 AM

Re: AttachObjectToVehicle
 
Are you sure you got the right co÷rds of the neon?

Dragony92 24/08/2011 09:41 AM

Re: AttachObjectToVehicle
 
Object is creted on coordinates 0 0 0 but not attached to vehicle...
Yeah because i paste it from working FS http://forum.sa-mp.com/showthread.ph...highlight=neon
Edit: It works on windows server but not on Linux...


All times are GMT. The time now is 07:25 PM.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.