SA-MP Forums

SA-MP Forums (https://forum.sa-mp.com/index.php)
-   Scripting Help (https://forum.sa-mp.com/forumdisplay.php?f=12)
-   -   SAMP_INCLUDES_VERSION warning (https://forum.sa-mp.com/showthread.php?t=673519)

MrCesar 29/03/2020 05:29 AM

SAMP_INCLUDES_VERSION warning
 
Hello guys, a weird warning I am getting, I am updating to mysql r41-4 plugin, and once I installed the new plugin, and copy pasted the script from here

Now, the script works fine and everything works fine, but after 1 time I launch the server I suddenly start getting these error:

pawn Code:
(381) : warning 203: symbol is never used: "SAMP_INCLUDES_VERSION"

line 381 is the end of the script, it's actual copy paste from the link, nothing was defined by me..

Anyone knows what may cause this error? Thanks!

SiaReyes 29/03/2020 05:43 AM

Re: SAMP_INCLUDES_VERSION warning
 
You can find that in a_samp.inc. I don't know for what it is used for. You can comment it!
Code:

public const SAMP_INCLUDES_VERSION = 0x037030;

MrCesar 29/03/2020 05:47 AM

Re: SAMP_INCLUDES_VERSION warning
 
Quote:

Originally Posted by SiaReyes (Post 4136540)
You can find that in a_samp.inc. I don't know for what it is used for. You can comment it!
Code:

public const SAMP_INCLUDES_VERSION = 0x037030;

Weird, downloaded a new server and my a_samp.inc doesn't have this line

SiaReyes 29/03/2020 05:49 AM

Re: SAMP_INCLUDES_VERSION warning
 
Quote:

Originally Posted by MrCesar (Post 4136542)
Weird, downloaded a new server and my a_samp.inc doesn't have this line

oh, can you show the full warning?

MrCesar 29/03/2020 06:00 AM

Re: SAMP_INCLUDES_VERSION warning
 
Quote:

Originally Posted by SiaReyes (Post 4136543)
oh, can you show the full warning?

Well, now I am getting confused..I've tried compiling it with pawno and it gave no errors, now when I go back to my sublime text is says can't read from file a_samp?:confused::confused:


EDIT: found out what was bugging it, the text editor - subslime had it build path set to pawncc.exe from the previous folder version and not the new one..

MrCesar 29/03/2020 06:40 AM

Re: SAMP_INCLUDES_VERSION warning
 
EDIT: Please delete, didn't notice the double post..


All times are GMT. The time now is 10:45 PM.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.