SA-MP Forums

SA-MP Forums (https://forum.sa-mp.com/index.php)
-   Русский/Russian (https://forum.sa-mp.com/forumdisplay.php?f=32)
-   -   [HELP]Обновление YSI библиотеки (https://forum.sa-mp.com/showthread.php?t=477954)

Mr.4o-4o 27/11/2013 09:44 AM

[HELP]Обновление YSI библиотеки
 
Я хочу обновить библиотеку YSI с v1.0 до v3.1. Заменил инклуды, папки, но при компилировании происходит crash pawno. Мб. кто-нибудь подскажет как правильно обновить библиотеку YSI(скачивал с офф.сайта YSI). Просматривая тему YSI 3.1 и переводя англ.текст поверхностно, я попробывал вставить в начало мода это:
PHP Code:

#define YSI_DO_USER_UPGRADE
#define PP_YSI

#define MODE_NAME "RunMeOnceOnly"

#include <YSI\y_users> 

Увы, это тоже не принесло успеха.

White_116 27/11/2013 10:02 AM

Re: [HELP]Обновление YSI библиотеки
 
А вам не приходило в голову что v1.0 может кардинально отличатся от v3.1?
И то, что ваш мод использует функции v1.0 в v3.1 может вовсе не быть.

Mr.4o-4o 27/11/2013 11:12 AM

Re: [HELP]Обновление YSI библиотеки
 
Quote:

Originally Posted by White_116 (Post 2797261)
А вам не приходило в голову что v1.0 может кардинально отличатся от v3.1?
И то, что ваш мод использует функции v1.0 в v3.1 может вовсе не быть.

Вообще, да, но обновляя другие инклуды, pawno выдавало errors и warnings, и после исправлял их, а здесь просто происходит crash pawno. Поэтому я и предположил, что мб. обновляю, как то не так.

Mr.4o-4o 27/11/2013 11:35 AM

Re: [HELP]Обновление YSI библиотеки
 
Проблему решил. Тема закрыта. Спасибо White_116


All times are GMT. The time now is 12:59 PM.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.