View Single Post
Old 13/06/2018, 07:16 PM   #1
Stefand
Gangsta
 
Stefand's Avatar
 
Join Date: Sep 2011
Location: The Netherlands
Posts: 781
Reputation: 27
Default Runtime error 20

Hello,

So my server crashed randomly recently so I added crashdetect, now my console is being spammed by any action with "[debug] Run time error 20: "Invalid index parameter (bad entry point)""

I looked it up and followed this fix tutorial: http://forum.sa-mp.com/showthread.php?t=482429

I have it below my includes and it still gives the runtime error so I am out of clues..

Code:
#include <LVRP/a_samp>
#include <LVRP/mysql>
#include <LVRP/crashdetect>
#include <LVRP/foreach>
#include <LVRP/Camera>
#include <LVRP/YSI\y_timers>
#include <LVRP/YSI\y_hooks>
#include <LVRP/streamer>
#include <LVRP/j_fader>
#include <LVRP/cuffs>
#include <LVRP/mSelection>
#include <LVRP/regex>
#include <LVRP/sscanf>
#include <LVRP/strlib>
#include <LVRP/discord-connector>
#include <LVRP/zcmd>
#include <s_fader> 
main(){}

//MYSQL SETTINGS

new MySQL:conne;

#define			SCRIPT_MODE			"Roleplay"
#define     	SCRIPT_VERSION      "0.0.1"
#define     	Server_Hostname	    "Las Venturas Roleplay"

#define TimeZoneCorrection 7200

PreloadAnimLib(playerid, animlib[]) ApplyAnimation(playerid,animlib,"null",0.0,0,0,0,0,0);

public OnGameModeInit()
{

	OnGameModeInitEx();

	#if defined main_OnGameModeInit
		return main_OnGameModeInit();
	#else
		return 1;
	#endif
}

	#if defined _ALS_OnGameModeInit
		#undef OnGameModeInit
	#else
		#define _ALS_OnGameModeInit
	#endif

#define OnGameModeInit main_OnGameModeInit
#if defined main_OnGameModeInit
	forward main_OnGameModeInit();
#endif


/*======================================================================================================
										[Modules]
=======================================================================================================*/
__________________


Scripter & Mapper
_______________________
Stefand is offline   Reply With Quote