SA-MP Forums

Go Back   SA-MP Forums > SA-MP Scripting and Plugins > Scripting Help > Tutorials

Reply
 
Thread Tools Display Modes
Old 17/04/2012, 08:04 PM   #21
itrenor
Little Clucker
 
Join Date: Jun 2011
Posts: 5
Reputation: 0
Default Re: Login/Register System with dialog

The code works perfectly except for one thing. I register in my server but it doesn't save the registration. If I try to log back in it says I'm not registered and I have to keep on registering and it doesn't save anything. Please. help?
itrenor is offline   Reply With Quote
Old 01/05/2012, 03:50 PM   #22
Flashhiee
Gangsta
 
Flashhiee's Avatar
 
Join Date: Mar 2012
Posts: 923
Reputation: 304
Question Re: Login/Register System with dialog

file is not saved
Flashhiee is offline   Reply With Quote
Old 21/07/2012, 10:00 AM   #23
Rivera
Big Clucker
 
Join Date: Feb 2011
Posts: 143
Reputation: 7
Default Re: Login/Register System with dialog

Quote:
Originally Posted by Lorenc_ View Post
Nice although DINI is so old, you're better of having a new system then that. Well Old and Slow = rubbish. Not saying you're TUT is rubbish but i suggest you're Next TUT thats about registering, maybe y_ini?

Anyway once again nice.
Haha I'm replying like after 1 year because I quit SAMP and I'm starting to program in C++ and/or Lua (For WoW mainly). I thought that Y_ini route is really hard and I was a beginner by that time so that's why I chose dini

P.S.: I forgot almost everything about scripting, lol. This lang is really really close to C++..
__________________
My works

[Tutorial]Full usage of dcmd(updated)
[Tutorial]Login/Register System with dialogs


// Prefered Servers------------------------------

US-RP.INFO / Best Roleplay Server / 213.5.176.156:7777

^^__^^
Rivera is offline   Reply With Quote
Old 21/07/2012, 08:48 PM   #24
Goldilox
Huge Clucker
 
Join Date: Mar 2012
Posts: 265
Reputation: 8
Default Re: Login/Register System with dialog

I used Copy/Paste and replaced with OnPlayerConnect and OnPlayerDisconnect but it doesn't come up, it says ot have 10 errors.
Goldilox is offline   Reply With Quote
Old 22/07/2012, 03:31 PM   #25
Karl[NDZ]
Big Clucker
 
Karl[NDZ]'s Avatar
 
Join Date: Mar 2012
Location: In Bergen with a hibbo
Posts: 86
Reputation: 0
Default Re: Login/Register System with dialog

When I register it dosen't save.
Karl[NDZ] is offline   Reply With Quote
Old 07/05/2017, 03:30 AM   #26
zedshadowzw
Banned
 
Join Date: May 2017
Location: Los Santos lel
Posts: 40
Reputation: 3
Default Re: Login/Register System with dialog

I get this error whenever I try to compile
Code:
C:\Users\Family\Desktop\Server\gamemodes\RoleplayMe.pwn(149) : error 017: undefined symbol "PlayerInfo"
C:\Users\Family\Desktop\Server\gamemodes\RoleplayMe.pwn(149) : warning 215: expression has no effect
C:\Users\Family\Desktop\Server\gamemodes\RoleplayMe.pwn(149) : error 001: expected token: ";", but found "]"
C:\Users\Family\Desktop\Server\gamemodes\RoleplayMe.pwn(149) : error 029: invalid expression, assumed zero
C:\Users\Family\Desktop\Server\gamemodes\RoleplayMe.pwn(149) : fatal error 107: too many error messages on one line

Compilation aborted.Pawn compiler 3.2.3664	 	 	Copyright (c) 1997-2006, ITB CompuPhase


4 Errors.
zedshadowzw is offline   Reply With Quote
Old 07/05/2017, 09:49 AM   #27
Lamy
Little Clucker
 
Join Date: Apr 2017
Location: Tunisia
Posts: 30
Reputation: 4
Default Re: Login/Register System with dialog

Quote:
Originally Posted by zedshadowzw View Post
I get this error whenever I try to compile
Code:
C:\Users\Family\Desktop\Server\gamemodes\RoleplayMe.pwn(149) : error 017: undefined symbol "PlayerInfo"
C:\Users\Family\Desktop\Server\gamemodes\RoleplayMe.pwn(149) : warning 215: expression has no effect
C:\Users\Family\Desktop\Server\gamemodes\RoleplayMe.pwn(149) : error 001: expected token: ";", but found "]"
C:\Users\Family\Desktop\Server\gamemodes\RoleplayMe.pwn(149) : error 029: invalid expression, assumed zero
C:\Users\Family\Desktop\Server\gamemodes\RoleplayMe.pwn(149) : fatal error 107: too many error messages on one line

Compilation aborted.Pawn compiler 3.2.3664	 	 	Copyright (c) 1997-2006, ITB CompuPhase


4 Errors.
Show The Lines
Lamy is offline   Reply With Quote
Old 07/05/2017, 09:54 AM   #28
coool
Gangsta
 
coool's Avatar
 
Join Date: Feb 2013
Location: Republic of Pakistan
Posts: 578
Reputation: 53
Default Re: Login/Register System with dialog

Quote:
Originally Posted by zedshadowzw View Post
I get this error whenever I try to compile
Code:
C:\Users\Family\Desktop\Server\gamemodes\RoleplayMe.pwn(149) : error 017: undefined symbol "PlayerInfo"
C:\Users\Family\Desktop\Server\gamemodes\RoleplayMe.pwn(149) : warning 215: expression has no effect
C:\Users\Family\Desktop\Server\gamemodes\RoleplayMe.pwn(149) : error 001: expected token: ";", but found "]"
C:\Users\Family\Desktop\Server\gamemodes\RoleplayMe.pwn(149) : error 029: invalid expression, assumed zero
C:\Users\Family\Desktop\Server\gamemodes\RoleplayMe.pwn(149) : fatal error 107: too many error messages on one line

Compilation aborted.Pawn compiler 3.2.3664	 	 	Copyright (c) 1997-2006, ITB CompuPhase


4 Errors.
You have bumped years old thread, what ever you have forgot this part. Re read that part
Code:
enum pInfo {
	AdminLevel,
	level,
	cash,
	pw,
}
new PlayerInfo[MAX_PLAYERS][pInfo];
__________________
coool is offline   Reply With Quote
Old 07/05/2017, 12:24 PM   #29
zedshadowzw
Banned
 
Join Date: May 2017
Location: Los Santos lel
Posts: 40
Reputation: 3
Default Re: Login/Register System with dialog

Quote:
Originally Posted by coool View Post
You have bumped years old thread, what ever you have forgot this part. Re read that part
Code:
enum pInfo {
	AdminLevel,
	level,
	cash,
	pw,
}
new PlayerInfo[MAX_PLAYERS][pInfo];
I appreciate your help, I added the enum thing into my gamemode script but I still have errors, but atleast it got decreased by one...
Code:
C:\Users\Family\Desktop\Server\gamemodes\RoleplayMe.pwn(201) : error 035: argument type mismatch (argument 2)
C:\Users\Family\Desktop\Server\gamemodes\RoleplayMe.pwn(201) : error 001: expected token: ",", but found ";"
C:\Users\Family\Desktop\Server\gamemodes\RoleplayMe.pwn(402) : error 021: symbol already defined: "OnDialogResponse"
C:\Users\Family\Desktop\Server\gamemodes\RoleplayMe.pwn(411) : warning 203: symbol is never used: "ret_memcpy"
Pawn compiler 3.2.3664	 	 	Copyright (c) 1997-2006, ITB CompuPhase


3 Errors.
zedshadowzw is offline   Reply With Quote
Old 09/05/2017, 01:10 AM   #30
zedshadowzw
Banned
 
Join Date: May 2017
Location: Los Santos lel
Posts: 40
Reputation: 3
Default Re: Login/Register System with dialog

Nevermind guys! I already fixed the errors myself! Anyways, thanks for the help!
zedshadowzw is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[Tutorial] Dialog Register/Login System using DJson sekol Tutorials 15 28/04/2015 08:18 AM
Login/Register System with dialog Rivera Help Archive 3 27/04/2011 12:56 PM
[Help] Register/Login System with DIALOG BMGP Help Archive 5 14/12/2010 05:34 PM
How to make login/register system with DIALOG? juseong111 Help Archive 3 20/10/2009 01:20 PM


All times are GMT. The time now is 08:57 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.