SA-MP Forums

Go Back   SA-MP Forums > Non-English > Languages > Русский/Russian

Reply
 
Thread Tools Display Modes
Old 25/02/2016, 01:00 PM   #31
[Saint]
Gangsta
 
Join Date: Sep 2009
Posts: 772
Reputation: 23
Default Re: DestroyVehicle - вызывает краш (падение) сервера

Quote:
Originally Posted by ZiGGi View Post
Я же не техподдержка по установке линукса, по вопросам установки есть масса информации в интернете, а у меня и своих дел полно. Скомпилировать тебе я согласился, но исходники ты мне так и не скинул.
да да конечно...

Quote:
Originally Posted by ZiGGi View Post
Я про твой мультиплеер для Vice City, он закрытый, хотя основывается на исходниках, которые лежали в свободном доступе (на сколько мне известно).
он такой же закрытый как и sa-mp, однако что-то делать для закрытого sa-mp у тебя интерес есть, ну ладно это твой выбор и я его принял, по поводу исходников из открытого доступа, только исходники VC-MP 0.1c by SA-MP Team 2005 когда которые и я и взял за основу на старте проекта, остальное это не так....

Quote:
Originally Posted by ZiGGi View Post
Раз надо, так надо, на логичное объяснение я и не надеялся.
ну а какое тут может быть ещё логичнее объяснение если в данный момент там дейтсительно требуется тип данных байт

Quote:
Originally Posted by ZiGGi View Post
Я знаю, но при чём здесь это?
И да, всего четыре строчки и эти типы уже есть:
PHP Code:
#define BOOL    int
#define DWORD   unsigned long
#define BYTE    unsigned char
#define WORD    unsigned short 
спасибо, но про это мне хорошие люди тоже разказали

Quote:
Originally Posted by ZiGGi View Post
А теперь перечитай свои сообщения в этой теме и скажи, как люди могли тебе помочь?
Особенно это:

Quote:
Originally Posted by [Saint] View Post
тут проблема заключается именно в работе функции DestroyVehicle
разве это не так? сервер крашит после использования функции DestroyVehicle
соответственно и тема так называется т.к. изначально я думал что проблема именно в ней
а то что проблема оказалась чуток в другом месте, так это уже не мой косяк, а разработчика sa-mp и прошу заметить что изначально я спрашивал была ли подобная проблема у кого-то ещё...

Quote:
Originally Posted by ZiGGi View Post
или вот эта откровенная ложь:

Quote:
Originally Posted by [Saint] View Post
забыл добавить, тестировал на SA-MP 0.2x / SA-MP 0.3a / SA-MP 0.3.7 везде проблема одинаковая т.к. тело функции DestroyVehicle из версии в версию не менялось
не имею такой привычки лгать, я действительно тестировал это как на собственной версии сервера, так и на указанных в цитате, а так же сравнивал их через IDA что на самом деле и показало что тело функции не менялось...

Quote:
Originally Posted by ZiGGi View Post
P.S. В следующий раз лучше сразу указывать, что используешь свой собственный сервер, чтобы не тратить время других людей.
прошу прощения что вы добровольно потратили своё драгоценное время для такого мудака как я
[Saint] is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Странное падение сервера. Stevka Русский/Russian 43 08/07/2015 08:02 PM
Проблема, неизвестное падение сервера Parlianment Русский/Russian 1 16/03/2015 04:19 PM
Падение сервера во время рестарта OstGot Русский/Russian 5 31/01/2015 12:59 PM
Падение сервера при подключении Dreik Русский/Russian 5 29/11/2012 10:51 AM
Падение сервера ][Noname][ Русский/Russian 24 26/04/2011 05:30 PM


All times are GMT. The time now is 05:55 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.