SA-MP Forums

Go Back   SA-MP Forums > SA-MP Scripting and Plugins > Scripting Help

Reply
 
Thread Tools Display Modes
Old 15/02/2018, 09:28 PM   #1
Saddin
Huge Clucker
 
Saddin's Avatar
 
Join Date: Mar 2011
Posts: 372
Reputation: 35
Default Vehicles on server got mixed up with IDs

I have vehicle ownership and it was working fine until suddenly other normal vehicles that are not used for ownership starting to get ID of the owner.

Does anyone know how can I debug it and find solution to problem.

There are over 600 vehicles on server that are bought by players and some of the properties of ownership can be used with vehicles that are not in ownership.

This system worked for more than 5 years and I can't find any reason why is it mixing..

Any ideas?
Saddin is offline   Reply With Quote
Old 15/02/2018, 09:40 PM   #2
Abagail
High-roller
 
Join Date: Dec 2013
Location: GetPlayerPos(playerid, pos); Scripter/Mapper.
Posts: 3,133
Reputation: 445
Default Re: Vehicles on server got mixed up with IDs

Quote:
This system worked for more than 5 years and I can't find any reason why is it mixing..
Well, what has changed since around the time this stopped working? Can you track code changes?
Abagail is offline   Reply With Quote
Old 15/02/2018, 09:44 PM   #3
RogueDrifter
High-roller
 
RogueDrifter's Avatar
 
Join Date: Dec 2017
Location: SA-MP Drifting world.
Posts: 1,193
Reputation: 420
Default Re: Vehicles on server got mixed up with IDs

used to happen with me, make sure after deleting a vehicle you set the variable's value to INVALID_VEHICLE_ID
__________________
Quote:
Originally Posted by Andy
My anti cheat is still relevant *puts shades on* https://github.com/RogueDrifter/Anti_cheat_pack

[Github]:Link [Gists]:Link [Forum]:Link [Server]:Link [Discord]:Link

RogueDrifter is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ID's mixed up conor565 Scripting Help 11 18/10/2015 07:43 PM
Per-player vehicles - Id's get mixed up (Car stealing problem) denNorske Scripting Help 8 17/06/2015 12:21 PM
Group ids getting mixed up upon server start conor565 Scripting Help 0 30/08/2013 12:49 AM
Timers mixed up again bartje01 Scripting Help 9 05/12/2011 09:25 AM
Dynamic vehicles mixed up.. remyguys Scripting Help 11 29/11/2011 01:26 PM


All times are GMT. The time now is 07:31 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.