SA-MP Forums

Go Back   SA-MP Forums > SA-MP Scripting and Plugins > Plugin Development

Reply
 
Thread Tools Display Modes
Old 01/09/2014, 11:59 PM   #171
xeeZ
Huge Clucker
 
Join Date: Feb 2013
Posts: 320
Reputation: 382
Default Re: JIT compiler v1.2.5

JIT 2.0.2 is released!
  • Fixed crash on invalid instruction
  • Fixed crash when executing non-existent public function
  • Fixed stupid bug in lctrl 0/1 instructions
  • Fixed crash in CallLocal/RemoteFunction() when running plugins that use GDK (e.g. streamer 2.7.3)
Download
xeeZ is offline   Reply With Quote
Old 02/09/2014, 12:57 AM   #172
oOFotherOo
Gangsta
 
oOFotherOo's Avatar
 
Join Date: May 2012
Location: Tokyo
Posts: 639
Reputation: 49
Default Respuesta: JIT compiler v1.2.5

My server crash, why?

Code:
[18:51:54]  Loading plugin: jit.so
[18:51:54]   JIT plugin v2.0.2 is OK.
[18:51:54]   Loaded.
[18:51:54]  Loading plugin: streamer.so
[18:51:54]   Loaded.
[18:51:54]  Loading plugin: gvar.so
[18:51:54] 

*** GVar Plugin v1.3 by Incognito loaded ***

[18:51:54]   Loaded.
[18:51:54]  Loading plugin: MapAndreas.so
[18:51:54]   Loaded.
[18:51:54]  Loaded 8 plugins.

[18:51:54] 
[18:51:54] Filterscripts
[18:51:54] ---------------
[18:51:54]   Loading filterscript 'MAPAS.amx'...
[18:51:54]   Loaded 1 filterscripts.

[18:51:54] [jit] Invalid or unsupported instruction at address 0000328c:
[18:51:54] [jit]   => jrel 0
[18:51:54]  
[18:51:54]  
[18:51:54]  
[18:51:54]  ======================================= 
[18:51:54]  |                                     | 
[18:51:54]  |        YSI version 4.00.0001        | 
[18:51:54]  |        By Alex "******" Cole        | 
[18:51:54]  |                                     | 
[18:51:54]  ======================================= 
[18:51:54]
__________________
[IMG]http://************/kjjafed[/IMG]
oOFotherOo is offline   Reply With Quote
Old 02/09/2014, 01:24 AM   #173
paulommu
Little Clucker
 
paulommu's Avatar
 
Join Date: Oct 2011
Location: Brazil
Posts: 30
Reputation: 7
Default Re: JIT compiler v1.2.5

Server crashes when I load a filterscript that uses some of the YSI includes, such as sscanf, y_hooks, y_iterate and y_va.

EDIT: Tested on 2.0.2, still the same problem.
paulommu is offline   Reply With Quote
Old 02/09/2014, 06:36 AM   #174
xeeZ
Huge Clucker
 
Join Date: Feb 2013
Posts: 320
Reputation: 382
Default Re: JIT compiler v1.2.5

It doesn't work with YSI.
xeeZ is offline   Reply With Quote
Old 02/09/2014, 08:10 PM   #175
uZ1
Banned
 
Join Date: Oct 2008
Posts: 33
Reputation: 4
Default Re: JIT compiler v1.2.5

Do I need to compile my scripts with -d2 or something similar?
uZ1 is offline   Reply With Quote
Old 02/09/2014, 08:37 PM   #176
xeeZ
Huge Clucker
 
Join Date: Feb 2013
Posts: 320
Reputation: 382
Default Re: JIT compiler v1.2.5

Quote:
Originally Posted by uZ1 View Post
Do I need to compile my scripts with -d2 or something similar?
No, you don't need that.
xeeZ is offline   Reply With Quote
Old 03/09/2014, 02:32 AM   #177
ProjectMan
Big Clucker
 
Join Date: Jun 2013
Location: SA-MP Awesomeness: 99999
Posts: 191
Reputation: 17
Exclamation Re: JIT compiler v1.2.5

Zeex, any malloc possibility plan with this plugin?
__________________


Looking for beta testers and helpers (who can script simple stuff like adding checkpoints and vehicles etc.), the rest will be scripted by me for a new Cops and Robbers script. Send me a PM if interested!
ProjectMan is offline   Reply With Quote
Old 03/09/2014, 06:23 AM   #178
xeeZ
Huge Clucker
 
Join Date: Feb 2013
Posts: 320
Reputation: 382
Default Re: JIT compiler v1.2.5

What do you mean?
xeeZ is offline   Reply With Quote
Old 28/03/2015, 06:58 PM   #179
xeeZ
Huge Clucker
 
Join Date: Feb 2013
Posts: 320
Reputation: 382
Default Re: JIT compiler v1.2.5

JIT 2.0.3 is released!
  • Fixed modulo operator producing incorrect results with negative operand
  • Added floatcmp() intrinsic
  • Added an include file
  • Slightly optimized jumps and native calls
Download
xeeZ is offline   Reply With Quote
Old 31/03/2015, 05:23 PM   #180
kaZax
Big Clucker
 
kaZax's Avatar
 
Join Date: Jan 2013
Location: Kazakhstan
Posts: 63
Reputation: 12
Default Re: JIT compiler v2.0.3

Code:
[19:20:41]  Loading plugin: jit.so
[19:20:41]   Failed (/usr/lib32/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by plugins/jit.so))
How to fix?
Debian 7 x64 Wheezy
__________________
vk.com
kaZax is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
PAWN Compiler Error Unable to execute Compiler.. Geeboi_Mehdi General 13 07/11/2015 05:26 PM
Zeex's compiler or original compiler? And why? Rodney Francalim Scripting Help 1 23/09/2014 01:26 AM
Please help ( PAWN Compiler "Error Unable to execute Compiler...") morocco Scripting Help 4 05/02/2013 04:34 PM
about the compiler Geeboi_Mehdi Scripting Help 1 13/08/2012 05:35 PM
[Pawno Compiler] Unable to Execute the Compiler Fabio11 Client Support 6 26/09/2010 10:37 PM


All times are GMT. The time now is 12:51 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.