SA-MP Forums

Go Back   SA-MP Forums > SA-MP Scripting and Plugins > Scripting Help > Help Archive

 
 
Thread Tools Display Modes
Old 06/11/2010, 05:19 PM   #1
Tom_Dedi
Big Clucker
 
Join Date: Oct 2008
Location: Germany
Posts: 71
Reputation: 0
Default An error has occured. (Error ID: 2014, Commands out of sync; you can't run this command now)

Hello Guys,

I have some problems with mysql with this command I want create a Car and insert into the MYSQL database

http://pastebin.com/b4DSdd9X

and all work fine my account system all I can update and insert alle perfekt
but only after I use /auto nothing work
This Error I get
http://pastebin.com/pKwMGsH3
I use this mysql Plugin
http://forum.sa-mp.com/showthread.php?t=56564

I need help fast

- Dedi
Tom_Dedi is offline  
Old 07/11/2010, 09:56 AM   #2
Tom_Dedi
Big Clucker
 
Join Date: Oct 2008
Location: Germany
Posts: 71
Reputation: 0
Default Re: An error has occured. (Error ID: 2014, Commands out of sync; you can't run this command now)

I need Help fast!
Why noone can help?
Tom_Dedi is offline  
Old 07/11/2010, 11:27 AM   #3
Rac3r
Gangsta
 
Join Date: May 2007
Posts: 500
Reputation: 40
Default Re: An error has occured. (Error ID: 2014, Commands out of sync; you can't run this command now)

Although SA-MP forums are great for getting answers, I suggest you also debug the command. Stick some printf() under some lines to see where it stops working.

Also, I think your string size of 128 for mystr is too small, try something higher (256, 512).
Rac3r is offline  
Old 07/11/2010, 01:01 PM   #4
Tom_Dedi
Big Clucker
 
Join Date: Oct 2008
Location: Germany
Posts: 71
Reputation: 0
Default Re: An error has occured. (Error ID: 2014, Commands out of sync; you can't run this command now)

It isnt Stop Working all work but the server send this sql code to mysql database an than mysql system nothing more work
now I set string to 512 this error is already here.
Tom_Dedi is offline  
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Several commands, error ??? Hudgens Help Archive 5 31/10/2010 02:57 PM
Oh my god, my .PAWN file ereased when the error occured :O Universal Help Archive 9 03/02/2010 07:33 PM
Trying to log all the admin commands error MisterTickle Help Archive 5 14/09/2009 11:12 AM
Commands Error :S GforceNL Help Archive 6 16/08/2009 03:02 PM
1 error with commands for classes Pawno_Master Help Archive 5 11/06/2009 07:58 PM


All times are GMT. The time now is 05:40 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.