SA-MP Forums

Go Back   SA-MP Forums > SA-MP DL Edition > SA-MP 0.3.DL

Reply
 
Thread Tools Display Modes
Old 09/01/2019, 06:28 PM   #1
Stefhan
Big Clucker
 
Stefhan's Avatar
 
Join Date: Nov 2014
Location: Netherlands
Posts: 130
Reputation: 0
Default Blender collision.

So in Blender ( I have no experience at all with modelling ) I have been trying to simply delete a few things from an object. ( CJ's house interior aka carlscrap.dff https://dev.prineside.com/en/gtasa_s...476-carlscrap/ )

The things I want to delete:

The window at the front of the house ( Just the part so you can see through it. )
The black door collision at the front of the house.
The door on the side of the house.
The door upstairs leading to the dressing room.
The door upstairs next to the dressing room. ( Not deleted in the recorded footage below. )

This all worked fine, I used kdff gui and followed Kalcor's guide to try and get it in-game, eventually I managed to do so with the mesh faces option & optimization enabled for the .col file. However, in-game, I ran into an issue. There's this invisible collision that I can't seem to find in Blender or Collision Editor II. I can't get rid of it and I have no idea what is causing it.




I even tried splitting the object in two seperate objects. ( as seen in the screenshots below )

I noticed this line ( assumed it was an UV thing with the texture ) and decided to try and split the object in two:




This didn't help either, the invisible wall remained regardless, before I even added the second part of the object.

In the attached files you can find the original .dff and .txd as well as my edited .col and .dff.

Could anyone please help me? I am not sure if I should post this here, so if I wasn't ment to, I'm very sorry. Many thanks for your help in advance. I have checked out guides and tried to figure out what the problem was on my own, since the 7th of January. I've really tried everything I can on my own and really need assistance.
Attached Files
File Type: rar cjhouseint.rar (243.8 KB, 5 views)
__________________
Beginner in scripting.
Stefhan is offline   Reply With Quote
Old 09/01/2019, 09:38 PM   #2
Silverback
Little Clucker
 
Silverback's Avatar
 
Join Date: Feb 2010
Location: Ukraine
Posts: 6
Reputation: 17
Default Re: [HELP]Blender collision.

You've got one extra edge on your model that you must to remove. See my screenshoot
To fix it, enable the wireframe view (key "Z"), enable Show Normal Face on the right menu and you'll see it
Attached Images
File Type: png Без имени-1.png (77.8 KB, 15 views)
Silverback is offline   Reply With Quote
Old 10/01/2019, 04:21 PM   #3
Stefhan
Big Clucker
 
Stefhan's Avatar
 
Join Date: Nov 2014
Location: Netherlands
Posts: 130
Reputation: 0
Default Re: [HELP]Blender collision.

Quote:
Originally Posted by Silverback View Post
You've got one extra edge on your model that you must to remove. See my screenshoot
To fix it, enable the wireframe view (key "Z"), enable Show Normal Face on the right menu and you'll see it
When I try to select the blue lines nothing happens.
__________________
Beginner in scripting.
Stefhan is offline   Reply With Quote
Old 10/01/2019, 04:50 PM   #4
Silverback
Little Clucker
 
Silverback's Avatar
 
Join Date: Feb 2010
Location: Ukraine
Posts: 6
Reputation: 17
Default Re: [HELP]Blender collision.



There are two edges, you need to select the longest and remove it
Silverback is offline   Reply With Quote
Old 10/01/2019, 07:40 PM   #5
DarkBr
Huge Clucker
 
Join Date: Feb 2017
Location: ∫ f(x) dx
Posts: 373
Reputation: 11
Default Re: Blender collision.

I had a similar problem, but for the Unreal Engine, I modeled some railroad vehicles and when it came to seeing the interior everything went wrong, I was sad because of the great effort I made and I could not get the job done. I do not really know why this happens, but I think you should see how other *******RS use and model their work.
DarkBr is offline   Reply With Quote
Old 10/01/2019, 09:28 PM   #6
Stefhan
Big Clucker
 
Stefhan's Avatar
 
Join Date: Nov 2014
Location: Netherlands
Posts: 130
Reputation: 0
Default Re: [HELP]Blender collision.

Quote:
Originally Posted by Silverback View Post


There are two edges, you need to select the longest and remove it
I removed the large edge and it didn't solve the problem.

Hate to ask, since you've already helped so much, but can you do it and send me the .dff?

If not, I guess I'm giving up.
__________________
Beginner in scripting.
Stefhan is offline   Reply With Quote
Old 11/01/2019, 01:36 AM   #7
Yaozu
Little Clucker
 
Yaozu's Avatar
 
Join Date: May 2018
Location: UK, River Styx
Posts: 44
Reputation: 65
Default Re: Blender collision.

I have corrected the collision for you (Attached to this reply).

This is annoying when this happens; there are a bunch of different methods in order to correct this, from using different methods to generate cols and by welding vertices.

Welding the vertices mostly works I find but other times it doesn't which I then use different methods of generating cols.

Right click the object and convert to editable mesh
Click vertex mode
Select all the vertices
Scroll down to weld
Set the value to 0.001
And hit enter and then convert it to editable mesh again
Then export (You can keep the original model and just use the one edited for the col, if texturing is messed up for example)
Attached Files
File Type: zip CJ House Interior.zip (83.9 KB, 4 views)
__________________
Yaozu is online now   Reply With Quote
Old 11/01/2019, 11:59 AM   #8
Stefhan
Big Clucker
 
Stefhan's Avatar
 
Join Date: Nov 2014
Location: Netherlands
Posts: 130
Reputation: 0
Default Re: Blender collision.

Quote:
Originally Posted by Yaozu View Post
I have corrected the collision for you (Attached to this reply).

This is annoying when this happens; there are a bunch of different methods in order to correct this, from using different methods to generate cols and by welding vertices.

Welding the vertices mostly works I find but other times it doesn't which I then use different methods of generating cols.

Right click the object and convert to editable mesh
Click vertex mode
Select all the vertices
Scroll down to weld
Set the value to 0.001
And hit enter and then convert it to editable mesh again
Then export (You can keep the original model and just use the one edited for the col, if texturing is messed up for example)
Thanks a lot friend, and everyone else as well!
__________________
Beginner in scripting.
Stefhan is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
blender vs samp f0Re3t SA-MP 0.3.DL 4 24/12/2017 01:35 PM
Question about Blender and what it does? Dokins SA-MP 0.3.DL 2 09/12/2017 02:26 AM
No veh collision vs vehicles with collision issue Kar Scripting Help 5 10/05/2015 11:08 PM
3ds max or blender SourceCode Everything and Nothing 6 15/11/2011 05:08 PM
Weather blender niCe Help Archive 13 12/10/2009 09:47 PM


All times are GMT. The time now is 11:57 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.