SA-MP Forums

Go Back   SA-MP Forums > SA-MP > General

Reply
 
Thread Tools Display Modes
Old 18/03/2013, 07:17 PM   #1
Tomboeg
Gangsta
 
Tomboeg's Avatar
 
Join Date: Aug 2010
Location: Somewhere between 0.2x and 0.3a.
Posts: 835
Reputation: 664
Default SAMP Add a 'A new version of samp is available' text at the start of samp client.

Like i said in the title.

This will help everyone to notice that there is a new version of SAMP out!
Since there are always a bunch of people that aren't aware of a new server/client release version.
I don't see why this isn't already added. Won't be a big deal or part to script/build.

Since this is a priority i decided to write a topic about it here.
Keep it high people so the developers can reach and see it.

Thank you.
__________________
Steam:

Twitch:
Tomboeg is offline   Reply With Quote
Old 18/03/2013, 07:35 PM   #2
Mr.Anonymous
Gangsta
 
Mr.Anonymous's Avatar
 
Join Date: Jul 2011
Location: Every ban list
Posts: 887
Reputation: 178
Default Re: SAMP Add a 'A new version of samp is available' text at the start of samp client.

Don't you think people have to download SA-MP client again for that? That will be exactly the same thing actually.
Mr.Anonymous is offline   Reply With Quote
Old 18/03/2013, 07:36 PM   #3
Tomboeg
Gangsta
 
Tomboeg's Avatar
 
Join Date: Aug 2010
Location: Somewhere between 0.2x and 0.3a.
Posts: 835
Reputation: 664
Default Re: SAMP Add a 'A new version of samp is available' text at the start of samp client.

Quote:
Originally Posted by Mr.Anonymous View Post
Don't you think people have to download SA-MP client again for that? That will be exactly the same thing actually.
Exactly.

That's where the notification is for.
A possible 'download here' link won't be too bad either.
__________________
Steam:

Twitch:
Tomboeg is offline   Reply With Quote
Old 18/03/2013, 07:42 PM   #4
Tamer
High-roller
 
Tamer's Avatar
 
Join Date: Nov 2011
Location: Turkey
Posts: 1,183
Reputation: 169
Default Re: SAMP Add a 'A new version of samp is available' text at the start of samp client.

I created a topic about this earlier in Scripting Discussion,it had agreement but didn't last long. I hope this one does.
__________________
The three stages of truth:

- Ridicule.
- Violent opposition.
- Acceptance.


Quote:
The greatest hypnotist on the planet Earth is an oblong box in the corner of the room. It is constantly telling us what to believe is real. If you can persuade people that what they see with their eyes is what there is to see you've got them. you know because they'll laugh in your face of an explanation that portrays the biggest picture of what's happening... and they have.
Tamer is offline   Reply With Quote
Old 18/03/2013, 07:54 PM   #5
Hiddos
High-roller
 
Hiddos's Avatar
 
Join Date: Sep 2008
Posts: 4,829
Reputation: 2182
Default Re: SAMP Add a 'A new version of samp is available' text at the start of samp client.

Quote:
Originally Posted by tomboeg View Post
Since this is a priority i decided to write a topic about it here.
How is this a priority? Some servers choose to use an older SA-MP version, if the players would get told to update to a version that isn't the server's version, they'll get confused.
__________________
Quote:
Originally Posted by DeWolf View Post
For fuck's sake people, this whole thread is fucked up now.
Hiddos is offline   Reply With Quote
Old 18/03/2013, 08:10 PM   #6
Tomboeg
Gangsta
 
Tomboeg's Avatar
 
Join Date: Aug 2010
Location: Somewhere between 0.2x and 0.3a.
Posts: 835
Reputation: 664
Default Re: SAMP Add a 'A new version of samp is available' text at the start of samp client.

Notification would be just fine. Up to them if they update or not.

I can tell you that more people get confused by the fact that they can't find or realise that there is a later/newer version than player on older versions.
__________________
Steam:

Twitch:
Tomboeg is offline   Reply With Quote
Old 18/03/2013, 08:19 PM   #7
Rock
Huge Clucker
 
Rock's Avatar
 
Join Date: Feb 2013
Location: C:\Windows\Rock.dll
Posts: 333
Reputation: 29
Default Re: SAMP Add a 'A new version of samp is available' text at the start of samp client.

Great Idea.
__________________
Just Rock
Rock is offline   Reply With Quote
Old 19/03/2013, 11:30 AM   #8
Guest9328472398472
Guest
 
Posts: n/a
Default Re: SAMP Add a 'A new version of samp is available' text at the start of samp client.

I think it would be useless. If people need to update, then they would OR the server owner would notify his/her players that the client needs to be updated in order to play. If people don't wanna update, they don't have to.
  Reply With Quote
Old 19/03/2013, 12:06 PM   #9
Scenario
Godfather
 
Scenario's Avatar
 
Join Date: Feb 2010
Location: Heaven
Posts: 8,105
Reputation: 701
Default Re: SAMP Add a 'A new version of samp is available' text at the start of samp client.

What if some SA:MP noob sees the notification, updates, and then can't access their favorite server? Not everyone knows that SA:MP client/server versions have to match in order for the player to be able to access the server.

It's more work than it's worth!
Scenario is offline   Reply With Quote
Old 19/03/2013, 12:17 PM   #10
Vince
Spam Machine
 
Vince's Avatar
 
Join Date: Sep 2007
Location: Belgium
Posts: 10,975
Reputation: 2649
Default Re: SAMP Add a 'A new version of samp is available' text at the start of samp client.

Every reputable server will update their server within a week of a major release or they'll risk losing players. Nevertheless, I think we can all agree that a notification would be a better way of telling that there is a client/server mismatch, rather than the meaningless 'Connecting to x.x.x.x ...' message.

For some odd reason, there is a GetPlayerVersion function, but it's useless since a connection can't be established with a client/server mismatch.
__________________
Vince is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samp client crash. Scrillex Scripting Help 4 10/03/2012 09:49 PM
Samp Client HotRod Client Support 4 03/12/2010 07:51 PM
Hey [Samp MAC Client]? odlemoreten General 17 17/09/2010 05:55 AM
[Plugin] [REL]SAMP-MySQL v0.15 - SAMP 0.3 supported!!! corrected version uploaded... ADreNaLiNe-DJ Plugin Development 1016 04/08/2010 09:43 PM


All times are GMT. The time now is 11:57 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.