SA-MP Forums

Go Back   SA-MP Forums > SA-MP Scripting and Plugins > Scripting Help > Tutorials

Reply
 
Thread Tools Display Modes
Old 10/08/2019, 05:42 AM   #1
G3ORG3
Little Clucker
 
Join Date: Nov 2018
Posts: 12
Reputation: 0
Default How to fix : ("I couldn't load any gamemode scripts. Please verify your server.cfg")

How to Fix

I couldn't load any gamemode scripts. Please verify your server.cfg


Hello Guys,
I'm G3ORG3, I am a scripter and pawno is kinda easy for me.
This is the error you will get while starting the server!
Quote:
Originally Posted by server-logs.txt
[07:46:03] I couldn't load any gamemode scripts. Please verify your server.cfg
[07:46:03] It needs a gamemode0 line at the very least
READ THIS - IMPORTANT:
[] Make sure your gamemode name doesnot have dashes and other stuffs. (EG: "-","/","#","!","+","_")
[] Make sure that your file that contains the gamemode has been named as "gamemodes"
[] Make sure you gamemode script is compiled and contains ".amx" file.

There are many ways to fix this!

The First Step
Quote:
If you got the following error. You will have to open "server.cfg"

You will see something like this:
PHP Code:
echo Executing Server Config... 
lanmode 1 
rcon_password 
************* 
maxplayers 100 
port 7777 
hostname YourServerName
gamemode0 YourGameModeName
filterscripts YourFilterScripts
announce 1 
plugins YourPlugins
query 1 
chatlogging 0 
weburl 
onfoot_rate 40 
incar_rate 40 
weapon_rate 40 
stream_distance 700.0 
stream_rate 1500 
maxnpc 2 
logtimeformat 
[%H:%M:%S
The Reason for the error:
This Error appears because you have not typed the gamemode name in the "gamemodes" file in your script files and No variable typed for your gamemode

Fixed :
You should type the correct name and then, type "1" in front of it!

Example
PHP Code:
echo Executing Server Config...  
lanmode 1  
rcon_password 
*************  
maxplayers 100  
port 7777  
hostname 
gamemode0 YourGameModeName 1
filterscripts 
announce 1  
plugins YourPlugins 
query 1  
chatlogging 0  
weburl  
onfoot_rate 40  
incar_rate 40  
weapon_rate 40  
stream_distance 700.0  
stream_rate 1500  
maxnpc 2  
logtimeformat  
[%H:%M:%S
If those are correct, the next step
The Second Step
Quote:
Sometimes, That happens because you don't have compiled it. If you don't compile it. The .amx file will not be appeared.

Fixed

You should compile it(.pwn file)!

If those good, step to 3rd
The Third Step
Quote:
The gamemode script is needed to be in the "gamemodes" folder. It must contain the .pwn and the .amx file.
And if that Folder is named as "gamemode", that will make this error!

Fixed


Change the "gamemode" folder nams to "Gamemodes"

---------------------------

Okay, Guys! If you have any problem with this, contact me

Discord : @TR3DI3T3R#1951

Don't forget to repute me if this is helpful for you!
__________________
Continental Roleplay

Last edited by G3ORG3; 10/08/2019 at 06:44 AM. Reason: Some Grammar Items xd
G3ORG3 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[ERROR] I couldn't load any gamemode scripts. Please verify your server.cfg - (It needs a gamemode0 line at least) G3ORG3 Scripting Help 8 10/08/2019 05:51 AM
Problem, I couldn't load any gamemode scripts. Please verify your server.cfg Magnezia Scripting Help 1 20/08/2015 03:49 AM
[HELP] I couldn't load any gamemode scripts. Please verify your server.cfg Shura Scripting Help 9 21/11/2014 09:04 PM
"I couldn't load any gamemode scripts." Gogorakis Scripting Help 8 06/06/2014 10:39 PM
couldn't load any gamemode scripts. Please verify your server.cfg Jaber_Brown Help Archive 7 26/05/2010 10:51 AM


All times are GMT. The time now is 08:53 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.