SA-MP Forums

Go Back   SA-MP Forums > SA-MP Server > Server Support

Reply
 
Thread Tools Display Modes
Old 31/01/2020, 05:07 PM   #1
kaisersouse
High-roller
 
kaisersouse's Avatar
 
Join Date: Jun 2006
Location: Subaru Forester
Posts: 2,799
Reputation: 1024
Default Anyone running latest SA-MP server under CentOS 8?

Bringing Everystuff back in a couple weeks, wanted to use the latest CentOS version. Anyone having issues under CentOS 8?

Appreciate all answers, as long as they don't consist of "Use {insert non-CentOS Linux distro} instead"

Thanks!
__________________
Life is like a box of cheap-ass no cocoa garbage dollar-store chocolate.

Ban UIF
kaisersouse is offline   Reply With Quote
Old 01/02/2020, 12:44 PM   #2
Jeroen52
Gangsta
 
Jeroen52's Avatar
 
Join Date: Oct 2008
Location: The Netherlands
Posts: 882
Reputation: 74
Default Re: Anyone running latest SA-MP server under CentOS 8?

You should contact the management team of Red County Roleplay, especially fr0st.

These are the announcements in their Discord about CentOS 8.

Code:
[7:34 PM] TommyB: Hello @everyone,

As I'm sure most of you are aware, RCRP and other SA-MP servers we host have been experiencing periodic player disconnections. After a bit of investigating, we've discovered that this is in fact a flaw in how the SA-MP server process itself runs on newer Linux distributions.

When we moved over to our new dedicated server, we also upgraded the operating system from CentOS 7.x to CentOS 8.x. These player drops started happening as soon as we launched on the new server. I first thought the server itself was crashing, but noticed the process was never actually killed. Originally, this lead me to believe that someone may have been attacking the server, but I couldn't find anything out of the ordinary in our server monitoring software either. That's when I drew parallels to an issue that some server owners experienced when trying to run SA-MP servers on Debian 9, another Linux distro. 

Unfortunately, the cause of this issue has never been identified, nor has a fix ever been discovered. fr0st is currently in the process of troubleshooting what the problem could be, so I hope we'll have good news to share soon! Until then, the server will likely continue to experience these random drops. I apologize for the convenience, but we're very much aware of the issue and are actively trying to work out a solution. 

Thanks!!
[9:11 PM] TommyB: @here We're gonna be restarting everything in about 10 minutes. I apologize for the inconvenience since it's peak hours and all, but we'd rather try and get to the bottom of the connection issues as soon as possible
[2:00 AM] fr0st: The fix implemented yesterday appears to have resolved the issue so far. Thanks for your patience.
__________________
Jeroen52 is offline   Reply With Quote
Old 03/02/2020, 03:42 PM   #3
kaisersouse
High-roller
 
kaisersouse's Avatar
 
Join Date: Jun 2006
Location: Subaru Forester
Posts: 2,799
Reputation: 1024
Default Re: Anyone running latest SA-MP server under CentOS 8?

Interesting. Did they say what the fix was?
__________________
Life is like a box of cheap-ass no cocoa garbage dollar-store chocolate.

Ban UIF
kaisersouse is offline   Reply With Quote
Old 15/07/2020, 01:22 AM   #4
Kcrimlen
Little Clucker
 
Join Date: Dec 2012
Posts: 1
Reputation: 0
Default Re: Anyone running latest SA-MP server under CentOS 8?

Try installing these:

Code:
yum -y groupinstall "Compatibility libraries"
yum -y install zlib.i686 #Y already present
yum -y install libpng.i686 #N
yum -y install fontconfig.i686 #N
yum -y install libpng12-1.2.50-10.el7.i686 #N
yum -y install libjpeg-turbo.i686 #N
yum -y install libXau.i686 #N #N
yum -y install libXdmcp.i686 #N
yum -y install libXpm.i686 #N
yum -y install libxml2.i686 #N
yum -y install gd.i686 #N
yum -y install libXmu.i686 #N
yum -y install motif.i686 #N
yum -y install libunwind.i686 #N
yum -y install mesa-libGLU.i686 #N
yum -y install libXaw.i686 libXi.i686 #N #N
yum -y install libcom_err.i686 keyutils-libs.i686 libverto.i686 #N #N #N
yum -y install krb5-libs.i686 #N
yum -y install openssl-libs.i686 #Y (by preceding)
yum -y install ncurses-libs.i686 #N
yum -y install pcre-devel.i686 #N
yum -y install freeglut #N
yum -y install freeglut.i686 #for /usr/lib/libglut.so.3 #N
yum -y install glib2.i686 #N
yum -y install compat-libtiff3.i686 #N
Kcrimlen is offline   Reply With Quote
Old 15/07/2020, 04:44 AM   #5
XGreen
Huge Clucker
 
XGreen's Avatar
 
Join Date: May 2014
Location: Manila
Posts: 207
Reputation: 8
Default Re: Anyone running latest SA-MP server under CentOS 8?

Hmmm interesting thing to know.

Currently, what are the most stable OS for running a server?
XGreen is offline   Reply With Quote
Old 15/07/2020, 06:11 AM   #6
Inspiron
Huge Clucker
 
Inspiron's Avatar
 
Join Date: Jul 2013
Location: Mount Chiliad
Posts: 233
Reputation: 18
Default Re: Anyone running latest SA-MP server under CentOS 8?

I tried Centos 8 to run my samp server, but it was missing lots of stuff I didn't care to look into. Simply downgraded to Centos 7 and its fine.
__________________

Website | Discord
Inspiron is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CentOS 7 running MariaDB won't run lib Tass007 Server Support 22 21/12/2017 12:37 AM
[SOLVED] Running sa-mp on Centos 6.5 Roel Server Support 2 23/06/2014 07:03 PM
How to setup FTP to a box running CentOS 6? Deal-or-die Server Support 3 08/01/2013 06:46 PM
How to setup FTP on a box running CentOS 6? Deal-or-die Server Support 10 06/01/2013 02:39 PM
Congratulations! You are running the latest version of YSI! maisto5 Help Archive 3 19/04/2011 12:09 PM


All times are GMT. The time now is 11:02 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.