SA-MP Forums

Go Back   SA-MP Forums > SA-MP Scripting and Plugins > Scripting Help

Reply
 
Thread Tools Display Modes
Old 29/05/2017, 04:27 PM   #1
czop1223
Little Clucker
 
Join Date: Jul 2012
Posts: 48
Reputation: 0
Default undefined symbol Iter_Single

I'm trying to use y_iterate for Vehicles. So what I did was:

new Iterator:Vehicles[MAX_VEHICLES];

Then when adding the vehicle

Iter_Add(Vehicles, gameid);

i get these errors

error 017: undefined symbol "Iter_Single@Vehicles"
error 017: undefined symbol "Iterator@Vehicles"

at the Iter_Add line

how do I fix it? Weird
czop1223 is offline   Reply With Quote
Old 29/05/2017, 04:43 PM   #2
SyS
High-roller
 
SyS's Avatar
 
Join Date: Oct 2015
Posts: 1,948
Reputation: 504
Default Re: undefined symbol Iter_Single

new Iterator:Vehicles<MAX_VEHICLES>
SyS is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I get multiple errors on the include MSelection [UNDEFINED SYMBOL AND SYMBOL IS NEVER USED] Gorgeousmaniac Scripting Help 2 21/08/2016 07:31 PM
symbol lookup error: plugins/mysql.so: undefined symbol: compress Grzechuso Scripting Help 2 06/01/2016 04:52 PM
error 017: undefined symbol "ReadPlayer" and error 017: undefined symbol "WritePlayer" brandypol Scripting Help 8 26/08/2014 07:16 PM
undefined symbol and symbol is assigned a value that is never used Proph3t Scripting Help 2 11/04/2013 03:54 PM
[HELP]Undefined symbol errors when symbol is defined PCheriyan007 Help Archive 9 07/07/2011 02:09 AM


All times are GMT. The time now is 07:53 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.