SA-MP Forums

Go Back   SA-MP Forums > SA-MP DL Edition > SA-MP 0.3.DL

Reply
 
Thread Tools Display Modes
Old 07/04/2019, 05:01 PM   #1
Konewka
Big Clucker
 
Konewka's Avatar
 
Join Date: Aug 2010
Posts: 73
Reputation: 2
Default Vehicles and peds disappear

Hello and welcome. I'm a Blender newbie, which means I have basic knowledge of getting around with the software.

I am trying to figure out as to why both vehicles and peds are disappearing when being insinde of my custom made garage underneath LSPD parking on Pershing Square. Not sure if the issue arise because of the location on the map or bad/corrupted .dff created with Blender, all by me. Here's a footage of this unknown behaviour.




Debugging shows following results:
1. No vehicles, nor peds disappear when spawned inside the object's boundries, BUT;
2. Leaving object's boundries (reaching original GTA's object surface, ie. street) and returning causes vehicles to disappear;
3. It has something to do with the original object (Model: carimp_lan.dff ID: 4032), as placed back on top of one another cease this to happen;
4. AddSimpleModel function inside "artconfig" file has been modified, replacing custom object with different IDs, including the original object's ID;
5. Problem has nothing to do with LODs.

Should you need more information to be provided by me, I'll be more than happy to do so. If you have any hints on how to fix this issue, please share it with me.

Thank you kindly.
Konewka is offline   Reply With Quote
Old 07/04/2019, 05:13 PM   #2
Mrhind
Little Clucker
 
Mrhind's Avatar
 
Join Date: Mar 2019
Location: Somewhere in the world.
Posts: 37
Reputation: 39
Default Re: Vehicles and peds disappear

This happens because depth in the underworld is very low. (your model)
It happened to me once I tried to make a parking near the train tracks (underground), on one side of the parking lot, the character or vehicle, disappeared, I guess that's why, since the depth of the underground underworld has a "limit" "of visualization so to speak.

Although, I'm not totally sure, since this doesn't happen everywhere, u should try.

Example:
(is a normal map created with objects of sa-mp)

Screenshot 1
Screenshot 2
Screenshot 3
Screenshot 4
__________________

Actually retired from the Pawn programming.
If you want to communicate with me, use the links below.


Model Developer - Version 0.3 DL.
Use the links below to access my Portfolio.

_____
Mrhind is offline   Reply With Quote
Old 07/04/2019, 05:37 PM   #3
Konewka
Big Clucker
 
Konewka's Avatar
 
Join Date: Aug 2010
Posts: 73
Reputation: 2
Default Re: Vehicles and peds disappear

Quote:
Originally Posted by Mrhind View Post
This happens because depth in the underworld is very low. (your model)
It happened to me once I tried to make [...]
Thank you for your reply. I tried to align the bottom surface (the one you walk/drive on) with the original object, no result. Can you extend your explanation as to what you are suggesting to do?
Konewka is offline   Reply With Quote
Old 07/04/2019, 05:58 PM   #4
Mrhind
Little Clucker
 
Mrhind's Avatar
 
Join Date: Mar 2019
Location: Somewhere in the world.
Posts: 37
Reputation: 39
Default Re: Vehicles and peds disappear

Quote:
Originally Posted by Konewka View Post
Thank you for your reply. I tried to align the bottom surface (the one you walk/drive on) with the original object, no result. Can you extend your explanation as to what you are suggesting to do?
You can try to re-design the map or do it in another way, the last option is that you don't make the map so deep. (Take as an example the parking lots of SA, its size more than anything)
Although, as I said before, I'm not sure if this happens everywhere.
__________________

Actually retired from the Pawn programming.
If you want to communicate with me, use the links below.


Model Developer - Version 0.3 DL.
Use the links below to access my Portfolio.

_____
Mrhind is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Peds (NPC-s) TokicMajstor Scripting Help 15 07/02/2019 11:05 AM
Peds and vehicles objects Glimma Scripting Help 3 01/08/2013 04:13 AM
Anti Car Disappear - it may NEVER disappear! Jochemd Help Archive 4 31/08/2010 08:21 AM
Vehicles Disappear After a short amount of time Rosco_Rich Help Archive 5 06/07/2010 07:17 PM


All times are GMT. The time now is 04:15 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.