SA-MP Forums

Go Back   SA-MP Forums > SA-MP Scripting and Plugins > Scripting Help > Help Archive

 
 
Thread Tools Display Modes
Old 29/05/2010, 10:43 AM   #1
Brice|Bryce
Big Clucker
 
Join Date: Jan 2010
Posts: 86
Reputation: 0
Default Compile error?

Everytime I try to compile a GM I get this error.

Code:
C:\Users\Main\Desktop\San Andreas\gamemodes\larp.pwn(21) : fatal error 100: cannot read from file: "utils"

Compilation aborted.Pawn compiler 3.2.3664	 	 	Copyright (c) 1997-2006, ITB CompuPhase


1 Error.
Any idea how to fix it?
Brice|Bryce is offline  
Old 29/05/2010, 10:46 AM   #2
(SF)Noobanatior
Gangsta
 
Join Date: Dec 2006
Posts: 544
Reputation: 2
Default Re: Compile error?

you need utils.inc in the include folder
or if its inn a folder off your gm you can go #include "Utils\utils.inc" instead of #include <utils.inc>
(SF)Noobanatior is offline  
Old 29/05/2010, 11:00 AM   #3
Brice|Bryce
Big Clucker
 
Join Date: Jan 2010
Posts: 86
Reputation: 0
Default Re: Compile error?

Quote:
Originally Posted by (SF)Noobanatior
you need utils.inc in the include folder
or if its inn a folder off your gm you can go #include "Utils\utils.inc" instead of #include <utils.inc>
I got utils.inc in the include folder.
Brice|Bryce is offline  
Old 29/05/2010, 11:13 AM   #4
TheInnocentOne
Guest
 
Posts: n/a
Default Re: Compile error?

You have placed utils.inc in the wrong include folder.

It needs to be in pawno/include not /include. To clarify, there is a folder called include inside the pawno folder. Place utils.inc in there.
 
Old 29/05/2010, 11:19 AM   #5
Brice|Bryce
Big Clucker
 
Join Date: Jan 2010
Posts: 86
Reputation: 0
Default Re: Compile error?

Quote:
Originally Posted by TheInnocentOne
You have placed utils.inc in the wrong include folder.

It needs to be in pawno/include not /include. To clarify, there is a folder called include inside the pawno folder. Place utils.inc in there.
It has always been in there.
Brice|Bryce is offline  
Old 29/05/2010, 11:37 AM   #6
(SF)Noobanatior
Gangsta
 
Join Date: Dec 2006
Posts: 544
Reputation: 2
Default Re: Compile error?

what does line 21 say
(SF)Noobanatior is offline  
Old 29/05/2010, 11:53 AM   #7
Brice|Bryce
Big Clucker
 
Join Date: Jan 2010
Posts: 86
Reputation: 0
Default Re: Compile error?

Quote:
Originally Posted by (SF)Noobanatior
what does line 21 say
#include <utils>
Brice|Bryce is offline  
Old 29/05/2010, 12:04 PM   #8
[HiC]TheKiller
High-roller
 
Join Date: Mar 2008
Location: New Zealand
Posts: 2,629
Reputation: 410
Default Re: Compile error?

Make sure if you have multiple coppies of the PAWN program you pick the one with the utlis include. Also, the includes folder is

YourSampServerDirectory - PAWNO - INCLUDES

Hope this helped =].
__________________
[HiC]TheKiller is offline  
Old 29/05/2010, 12:14 PM   #9
aircombat
High-roller
 
Join Date: Feb 2010
Posts: 1,535
Reputation: 9
Default Re: Compile error?

if u have multiple pawno in ur computer make sure than the include in the pawno/include of the program (pawno) u use
__________________

aircombat is offline  
Old 29/05/2010, 01:14 PM   #10
Brice|Bryce
Big Clucker
 
Join Date: Jan 2010
Posts: 86
Reputation: 0
Default Re: Compile error?

Quote:
Originally Posted by Etch ❽ H
if u have multiple pawno in ur computer make sure than the include in the pawno/include of the program (pawno) u use
Thanks heaps, that was it. I used to just search for Pawno and use anything I find.
Brice|Bryce is offline  
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Compile error help zalyy Help Archive 24 22/04/2010 07:48 PM
Error on compile monster010 Help Archive 5 08/10/2009 07:03 PM
error when compile Sfinx_17 Help Archive 4 23/08/2009 01:32 AM
Compile Error. Can Someone Compile For Me Please? RolePlay360 Help Archive 2 11/03/2009 09:56 PM


All times are GMT. The time now is 01:57 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.