SA-MP Forums

Go Back   SA-MP Forums > SA-MP Scripting and Plugins > Scripting Help

Reply
 
Thread Tools Display Modes
Old 10/10/2011, 12:27 PM   #1
Awesome™
Little Clucker
 
Awesome™'s Avatar
 
Join Date: Aug 2011
Location: Germany
Posts: 24
Reputation: 4
Default OnVehicleDeath() isn't called when vehicle enters water

Hey guys.

I heard, the function is called when vehicle enters water, too.
So I tried it by myself. (Print & SendClientMessage)

But it isn't. :/ Why?
Awesome™ is offline   Reply With Quote
Old 10/10/2011, 01:48 PM   #2
Dragony92
Banned
 
Join Date: Feb 2011
Location: Belgrade, Serbia
Posts: 484
Reputation: 60
Default Re: OnVehicleDeath() isn't called when vehicle enters water

http://wiki.sa-mp.com/wiki/OnVehicleDeath
Note: This callback will also be called when a vehicle enters water

Is it so hard to use ******?
Dragony92 is offline   Reply With Quote
Old 10/10/2011, 07:55 PM   #3
hittt
Little Clucker
 
Join Date: Jan 2010
Posts: 30
Reputation: 3
Default Re: OnVehicleDeath() isn't called when vehicle enters water

LOL @ the misunderstanding..

Well, the vehicle needs to get partially submerged. It wont be called if it just touches the water.
__________________

hittt is offline   Reply With Quote
Old 20/01/2012, 01:20 AM   #4
jamesbond007
Gangsta
 
jamesbond007's Avatar
 
Join Date: Oct 2009
Location: Canadia
Posts: 787
Reputation: 56
Default Re: OnVehicleDeath() isn't called when vehicle enters water

yes this
jamesbond007 is offline   Reply With Quote
Old 20/01/2012, 02:00 AM   #5
cessil
High-roller
 
cessil's Avatar
 
Join Date: Apr 2009
Posts: 1,346
Reputation: 296
Default Re: OnVehicleDeath() isn't called when vehicle enters water

try adding prints under OnVehicleSpawn and see if you can just script a work around that way
cessil is offline   Reply With Quote
Old 20/01/2012, 02:41 AM   #6
jamesbond007
Gangsta
 
jamesbond007's Avatar
 
Join Date: Oct 2009
Location: Canadia
Posts: 787
Reputation: 56
Default Re: OnVehicleDeath() isn't called when vehicle enters water

Quote:
Originally Posted by cessil View Post
try adding prints under OnVehicleSpawn and see if you can just script a work around that way
What's OnVehicleSpawn got to do with this? i dont understand...
jamesbond007 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Vehicle death + water Cameltoe Help Archive 2 20/08/2010 05:44 PM
Text on bot/pickup, Possible when player enters bot's vehicle Moustafa Help Archive 0 02/09/2009 10:43 AM
Player not detected when he enters the vehicle? Yoyoyo Help Archive 4 26/06/2009 03:48 AM
When player Enters vehicle...help! Static_X Help Archive 23 02/02/2009 08:55 PM


All times are GMT. The time now is 09:12 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.