SA-MP Forums

Go Back   SA-MP Forums > SA-MP > Client Support

Reply
 
Thread Tools Display Modes
Old 04/05/2020, 09:31 AM   #1
[DK]GHOST_DOG
Little Clucker
 
Join Date: Feb 2008
Location: Athens, Greece
Posts: 4
Reputation: 0
Default Weird Lag on Windows 10 / Volume Control Fix

Hey guys, I hope you are all doing well during this Quarantine.

On topic now; I have a very good solid build. Ryzen 5 2600, RX Vega 56, 16GB of RAM etc.
SA:MP runs fluently locked 90 FPS all the time, but at some points there's a sudden vissible "lag" meanwhile no FPS drop. While on rest games using the Windows Volume Control, it causes lag, here's the opposite. Whenever i get those "laggy" moments, using my Volume Control will fix it and get me a smooth gaming for a little bit.. Keep in mind I use a 144Hz monitor which 90FPS constant lock is visible difference, but those laggy moments feels like FPS go down at 60 or something (PC still reports 89-93 FPS though)

I am using Windows 10 Pro x64 (18362). All my drivers are updated, AMD on latest 20.4.2 etc. Audio card updated to latest Realtek drivers etc. This does not happen on Single Player, only on SA:MP and I've tried numerous servers to see (so if it was textdraw of some certain server or so).. Happens even with F7 and hidden text. I'll try to capture a video of it.

What I have tried:
-Updated every single driver (BIOS, Chipset, AMD, Audio etc)
-Run SA:MP with admin rights
-Disabled Compatibility -> Fullscreen optimization
-Removed any stats/screen info about FPS (RivaTuner or Fraps)
-CLEAN installation of GTA:SA/SA:MP (R4) (even deleting gta_sa.set and samp config etc)
-Tried other gta_sa.exe's.
-Different servers, few without any textdraw or weird GUI text etc
-Local server with default sa:mp scripts
-PC is always on High Performance mode, CPU stock or 4Ghz overclock, same for the GPU. (apparently I'm certain this is not Hardware related but, but software one or settings.)
-Tried crashes.asi who someone told me maybe it could help me uncap my FPS just for test (ikr 100+ is bugged gameplay) - Did not work at all. Just helped run SA-MP on window with instant alt-enter press.

Every other game is running fluently on my computer, only SA:MP is getting this laggy bug, idk why.

Game runs 5% cpu, 5% gpu. I tried DirectX 2 (Graphic Mod) the other day (couldn't get it to work on SA:MP though) and game on single player was running perfect, 40 percent cpu, 60-70 percent on GPU. I just don't get why SA:MP get's laggy while reporting 90 FPS at some points.. It happens on random moments or when I change camera (or re-center it).. Any idea on what else I could try to solve this?
[DK]GHOST_DOG is offline   Reply With Quote
Old 04/05/2020, 10:25 AM   #2
Hazon
Huge Clucker
 
Hazon's Avatar
 
Join Date: May 2018
Location: Who cares ?
Posts: 206
Reputation: 37
Default Re: Weird Lag on Windows 10 / Volume Control Fix

All drivers are fine to you, I mean are they up-to-date.
Hazon is offline   Reply With Quote
Old 04/05/2020, 01:24 PM   #3
Uberanwar
Gangsta
 
Uberanwar's Avatar
 
Join Date: May 2012
Location: Malaysia
Posts: 893
Reputation: 63
Default Re: Weird Lag on Windows 10 / Volume Control Fix

I used to have similar problems. What I did is by reinstalling all my laptop device drivers, due to the fact that Windows 10 Updates messed up my device drivers (which is a known major issue in Windows 10 affecting a lot of PCs: https://www.howtogeek.com/658676/win...e-being-fixed/) and caused lags although I have a good laptop specs.

I have a lot of friends who encountered the same problem in Windows 10, and these solutions that I will share to you will hopefully fix yours. It will improve your overall pc performance, stability and most of your problems.

First and foremost, DO NOT use ANY automatic driver updater softwares, although is it from reputable companies. Don't even trust Windows 10 automatic device driver updates. Grab OEM (Original equipment manufacturer) drivers. For instance, if you have an Acer laptop like me, go to Acer's website. Make sure the website is based on your region (important!). Then look up your device drivers based on your PC's model. This is mine, https://www.acer.com/ac/en/MY/conten...t-product/7605 which is based on my country/region (Malaysia). Download all the relevant device drivers then install them accordingly. It is highly suggested that you install Chipset Driver beforehand, then proceed installing the other drivers.

Fun fact: I applied the same solutions few days ago on my friend's PC, had a very huge performance boost and stability. It also fixed his keyboard issue that he has been facing for two years!

Other solution is perhaps you could try installing SA-MP Addon (a quick ****** Search will do)
Uberanwar is offline   Reply With Quote
Old 04/05/2020, 06:56 PM   #4
[DK]GHOST_DOG
Little Clucker
 
Join Date: Feb 2008
Location: Athens, Greece
Posts: 4
Reputation: 0
Default Re: Weird Lag on Windows 10 / Volume Control Fix

Perhaps if you did not tl;dr the thread you'd answer your questions already.
I never rely on update, I manually install everything. Even DDU when upgrading graphics card. I know my way through Windows, I've studied as an IT however first time I come across such a thing. As I said my drivers are in perfect shape. I can run GTA V maxed out on 120fps, and whatever I want. I just can't get SA:MP to run smoothly for some unknown reason.

Rep added, SA:MP Addon did the fix.

Last edited by [DK]GHOST_DOG; 05/05/2020 at 12:12 AM.
[DK]GHOST_DOG is offline   Reply With Quote
Old 05/05/2020, 09:13 PM   #5
Uberanwar
Gangsta
 
Uberanwar's Avatar
 
Join Date: May 2012
Location: Malaysia
Posts: 893
Reputation: 63
Default Re: Weird Lag on Windows 10 / Volume Control Fix

Glad that helps!
Uberanwar is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[Include] g_cars - Control the windows and doors Goncho28 Includes 0 11/08/2015 09:38 PM
How to change position of on-screen green volume control bar (Windows 7)? Sevenstar4ever Everything and Nothing 15 10/10/2011 06:07 PM
Volume control help please! xbox360boy66 Everything and Nothing 5 23/08/2011 12:44 AM
[Tool/Web/Other] [PHP]Leandro Control Panel Windows v1 - English LeeandRo Tools and Files 23 15/07/2010 05:31 AM


All times are GMT. The time now is 01:19 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.