SA-MP Forums

Go Back   SA-MP Forums > SA-MP Server > Server Support

Reply
 
Thread Tools Display Modes
Old 28/07/2013, 10:04 AM   #1
Libra_PL
Huge Clucker
 
Libra_PL's Avatar
 
Join Date: Aug 2010
Location: Poland
Posts: 307
Reputation: 41
Default My server is once visible and once not.

Hello.

I've got a problem related to my server.
A long time ago I portforwarded and everything worked fine. But very often I'm experiencing a problem.
When I open my server, there are a few possible things:
- my server works for me (added in favourites list) and for other players too (usually after first server launch) *
If I close the server and I open again, other issues might appear:
- my server works for me, but no one other can see (tested with 6 other players) *
- my server works for me, but for some other works (1-2 see, 4-5 don't see)
- my server doesn't work for me and it doesn't for everyone *
- my server doesn't work for me, but it works for some other (not always everyone)
These effects are completely random, but these with ' * ' appear more often. I'm trying any way to fix this, usually I move my folder (that includes my scripts) to other locations. Sometimes I just open and close the server 10-30 times or I wait a few minutes.

I should have this fixed before 2nd August, because we (me and 29 other players) have an event in-game. There's a specifed time when it will be started, so I shouldn't be late. Of course, it must be hosted on my computer.

And one thing: I'm trying to don't change anything in server.cfg (I'm editing announce, hostname and maxplayers only).

And the question: How to fix this?

Thanks for any answers.
__________________


An unique new minigame in SA-MP, you are welcome!


Libra_PL is offline   Reply With Quote
Old 31/07/2013, 01:51 PM   #2
Libra_PL
Huge Clucker
 
Libra_PL's Avatar
 
Join Date: Aug 2010
Location: Poland
Posts: 307
Reputation: 41
Default Re: My server is once visible and once not.

Bump.
__________________


An unique new minigame in SA-MP, you are welcome!


Libra_PL is offline   Reply With Quote
Old 31/07/2013, 01:55 PM   #3
jessejanssen
Huge Clucker
 
Join Date: Apr 2008
Posts: 222
Reputation: 698
Default Re: My server is once visible and once not.

Did you set a static IP in your router? Else every time you restart your PC you have a quite big chance you got a different 'internal' IP to which the port is forwarded to.

Best regards,
Jesse
__________________
R.I.P. all people who passed away on the MH17
jessejanssen is offline   Reply With Quote
Old 31/07/2013, 02:22 PM   #4
Inspiron
Big Clucker
 
Inspiron's Avatar
 
Join Date: Jul 2013
Location: Home
Posts: 161
Reputation: 11
Default Re: My server is once visible and once not.

As jessejanssen said, Your IP don't seems to be stati. Get a static IP from your ISP and you won't get this. I hope
Inspiron is offline   Reply With Quote
Old 31/07/2013, 04:53 PM   #5
Libra_PL
Huge Clucker
 
Libra_PL's Avatar
 
Join Date: Aug 2010
Location: Poland
Posts: 307
Reputation: 41
Default Re: My server is once visible and once not.

My IP is dynamic, but it changes only after router reset. I always have same IP while I'm launching 5, 10 or 50 times and I don't touch my modem at this time.

I usually launch once every 20-30 seconds with 5 seconds break, to ask other does it work or it doesn't.
__________________


An unique new minigame in SA-MP, you are welcome!


Libra_PL is offline   Reply With Quote
Old 31/07/2013, 04:59 PM   #6
Inspiron
Big Clucker
 
Inspiron's Avatar
 
Join Date: Jul 2013
Location: Home
Posts: 161
Reputation: 11
Default Re: My server is once visible and once not.

Post server logs !
Inspiron is offline   Reply With Quote
Old 31/07/2013, 06:49 PM   #7
jessejanssen
Huge Clucker
 
Join Date: Apr 2008
Posts: 222
Reputation: 698
Default Re: My server is once visible and once not.

Go to cmd.exe, type "ipconfig", check the IP on the "IPv4" line, make sure that's the same as the IP you've forwarded it to in your router/modem. If you have a dynamic IP this isn't the same, you can change the dynamic/static IP setting yourself!

Best regards,
Jesse
__________________
R.I.P. all people who passed away on the MH17
jessejanssen is offline   Reply With Quote
Old 31/07/2013, 09:07 PM   #8
ColorHost-Kevin
High-roller
 
ColorHost-Kevin's Avatar
 
Join Date: May 2011
Location: Hollywood,MD
Posts: 1,603
Reputation: 138
Default Re: My server is once visible and once not.

You would need your new IP everytime your connecting, since you say its not static.
__________________
█| Colorhost Premium Web Hosting And Cheap SAMP Servers in US and NL! 100 Slots For $7.95! With Hosted tab for $25.35!
█| Offering Services to customers since 2009! - Now Supporting Direct Credit Card Payments and Bitcoin!
█| Check us out today! https://colorhost.co
ColorHost-Kevin is offline   Reply With Quote
Old 02/08/2013, 04:56 PM   #9
Libra_PL
Huge Clucker
 
Libra_PL's Avatar
 
Join Date: Aug 2010
Location: Poland
Posts: 307
Reputation: 41
Default Re: My server is once visible and once not.

Quote:
Originally Posted by jessejanssen View Post
Go to cmd.exe, type "ipconfig", check the IP on the "IPv4" line, make sure that's the same as the IP you've forwarded it to in your router/modem. If you have a dynamic IP this isn't the same, you can change the dynamic/static IP setting yourself!

Best regards,
Jesse
Good point. I checked out and I found that my IPv4 was 192.168.1.4. It's changing all the time after every reset. But it wasn't working, because I portforwarded only to 192.168.1.1, 192.168.1.2 and 192.168.1.3. Not sure if 5, 6... also appear, but that might be a reason.

I hope I fixed that problem, so MUCH thanks for you. I didn't think before to check this.
__________________


An unique new minigame in SA-MP, you are welcome!


Libra_PL is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
my server is not visible to the Internet list Impori0 Server Support 11 23/06/2012 10:39 PM
CP is not visible BlackWolf120 Help Archive 2 08/01/2011 03:03 PM
Personal server not visible to others LShome Server Support 0 19/02/2010 11:27 PM
[SOLVED] Server Problem. Server not visible for friends. Juanxz Server Support 0 26/01/2010 09:34 AM
NPC's not visible Jason_Larson Help Archive 21 15/10/2009 10:00 AM


All times are GMT. The time now is 09:37 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.