SA-MP Forums

Go Back   SA-MP Forums > SA-MP Scripting and Plugins > Scripting Help

Reply
 
Thread Tools Display Modes
Old 14/06/2018, 09:15 AM   #1
Heress
Huge Clucker
 
Heress's Avatar
 
Join Date: Mar 2018
Location: Lithuania
Posts: 262
Reputation: 7
Exclamation Error with udb_hash

I created login/register system, I solved all error/warning, but where is one

C:\Users\Nerijus\Desktop\Serveris 0.3.7\gamemodes\pls.pwn( 4998 ) : error 021: symbol already defined: "udb_hash"

4998||stock udb_hash(buf[])
4999||{
5000|| new length=strlen(buf);
5001|| new s1 = 1;
5002|| new s1 = 0;
5003|| new n;
5004|| for (n=0; n<length; n++)
5005|| {
5006|| s1 = (s1 + buf[n]) % 65521;
5007|| s2 = (s2 + s1) % 65521;
5008|| }
5009|| return (s2 << 16) + s1;
5010||}

Please help!
Heress is offline   Reply With Quote
Old 14/06/2018, 09:16 AM   #2
Shadow0707
Big Clucker
 
Join Date: Sep 2016
Posts: 92
Reputation: 7
Default Re: Error with udb_hash

just remove all of that then compile
Shadow0707 is offline   Reply With Quote
Old 14/06/2018, 09:28 AM   #3
Heress
Huge Clucker
 
Heress's Avatar
 
Join Date: Mar 2018
Location: Lithuania
Posts: 262
Reputation: 7
Default Re: Error with udb_hash

I Compiled, but now I have Run time error

Script[gamemodes/pls.amx]:Run time error 19:"File or function is not found"
Number of vehicles models: 0
Heress is offline   Reply With Quote
Old 14/06/2018, 09:33 AM   #4
Shadow0707
Big Clucker
 
Join Date: Sep 2016
Posts: 92
Reputation: 7
Default Re: Error with udb_hash

post your server log here

make sure your include has the same version with your plugins
Shadow0707 is offline   Reply With Quote
Old 14/06/2018, 09:40 AM   #5
Heress
Huge Clucker
 
Heress's Avatar
 
Join Date: Mar 2018
Location: Lithuania
Posts: 262
Reputation: 7
Default Re: Error with udb_hash

----------
Loaded log file: "server_log.txt".
----------

SA-MP Dedicated Server
----------------------
v0.3.7-R2, (C)2005-2015 SA-MP Team

[12:37:47]
[12:37:47] Server Plugins
[12:37:47] --------------
[12:37:47] Loading plugin: streamer
[12:37:47]

*** Streamer Plugin v2.9.3 by Incognito loaded ***

[12:37:47] Loaded.
[12:37:47] Loaded 1 plugins.

[12:37:47]
[12:37:47] Filterscripts
[12:37:47] ---------------
[12:37:47] Loading filterscript 'ufo.amx'...
[12:37:47] Loading filterscript 'sweeper.amx'...
[12:37:47] Loading filterscript 'sms.amx'...
[12:37:47] Loading filterscript 'ms.amx'...
[12:37:47] Loading filterscript 'md.amx'...
[12:37:47] Loading filterscript 'orob.amx'...
[12:37:47] Loading filterscript 'mdgb.amx'...
[12:37:47] Loaded 7 filterscripts.

[12:37:47] Script[gamemodes/pls.amx]: Run time error 19: "File or function is not found"
[12:37:47] Number of vehicle models: 0
Heress is offline   Reply With Quote
Old 14/06/2018, 09:43 AM   #6
Shadow0707
Big Clucker
 
Join Date: Sep 2016
Posts: 92
Reputation: 7
Default Re: Error with udb_hash

show me your includes you might have some missing plugin
Shadow0707 is offline   Reply With Quote
Old 14/06/2018, 09:46 AM   #7
Heress
Huge Clucker
 
Heress's Avatar
 
Join Date: Mar 2018
Location: Lithuania
Posts: 262
Reputation: 7
Default Re: Error with udb_hash

https://imgur.com/a/w29OKJB
Heress is offline   Reply With Quote
Old 14/06/2018, 09:49 AM   #8
Shadow0707
Big Clucker
 
Join Date: Sep 2016
Posts: 92
Reputation: 7
Default Re: Error with udb_hash

not that one

the thing in your gm
example: #include <streamer>
Shadow0707 is offline   Reply With Quote
Old 14/06/2018, 09:52 AM   #9
Heress
Huge Clucker
 
Heress's Avatar
 
Join Date: Mar 2018
Location: Lithuania
Posts: 262
Reputation: 7
Default Re: Error with udb_hash

I have #include <streamer>

https://imgur.com/a/Rl2LN1B
Heress is offline   Reply With Quote
Old 14/06/2018, 10:05 AM   #10
Shadow0707
Big Clucker
 
Join Date: Sep 2016
Posts: 92
Reputation: 7
Default Re: Error with udb_hash

make sure your gamemode .amx is in gamemode folder
Shadow0707 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
udb_hash nezo2001 Scripting Help 4 06/07/2015 04:14 PM
udb_hash TheSnaKe Scripting Help 4 16/03/2015 03:45 PM
udb_hash BoU3A Scripting Help 10 22/09/2013 02:40 PM
error 017: undefined symbol "udb_hash" lewismichaelbbc Scripting Help 2 29/05/2012 03:23 PM
udb_hash help Ironboy500[TW] Help Archive 2 31/10/2010 12:08 PM


All times are GMT. The time now is 02:56 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.