SA-MP Forums

Go Back   SA-MP Forums > SA-MP Server > Server Support

Reply
 
Thread Tools Display Modes
Old 19/06/2010, 07:59 AM   #1
neko.sempai.1
Little Clucker
 
Join Date: Jun 2010
Posts: 3
Reputation: 0
Default Gamemode fails to start, but only on linux.

My gamemode fails to load with
Code:
----------
Loaded log file: "server_log.txt".
----------

SA-MP Dedicated Server
----------------------
v0.3a R7, (C)2005-2010 SA-MP Team

[06:47:40] 
[06:47:40] Server Plugins
[06:47:40] --------------
[06:47:40] Loading plugin: xStreamer.so
[06:47:40] xStreamer plugin loaded
[06:47:40]  Loaded.
[06:47:40] Loaded 1 plugins.

[06:47:40] 
[06:47:40] Ban list
[06:47:40] --------
[06:47:40] Loaded: samp.ban
[06:47:40] 
[06:47:40] 
[06:47:40] Filter Scripts
[06:47:40] ---------------
[06:47:40]  Loading filter script 'xStreamer.amx'...
[06:47:40] xStreamer: xStreamer filterscript has been detected
[06:47:40]  Loading filter script 'zinutes.amx'...
[06:47:40]  Loading filter script 'Burnout.amx'...
[06:47:40]  Loading filter script 'bugs.amx'...
[06:47:40]  Loaded 4 filter scripts.

[06:47:40] Script[gamemodes/GRP10.amx]: Run time error 19: "File or function is not found"
I've tried disabling every plugin and removing the functions using them, but I still get this error.

Also, plase note, how my gamemode isn't even started to execute. I call a print function in the beggining of it:
Code:
main()
{
	print("Server launched. Starting setup");
}
and there's nothing in the log.

Also, the server runs well on windows xp (5.1.x), vista and 7, but doesn't run on debian 5.0, because of the error described above.

EDIT: I haven't tried disabling xStreamer, though... Possibly it or it's filterscript could be causing trouble (since filterscripts load before gamemodes) and xStreamer is fairly old, designed for 0.2.x, however the log clearly says "gamemodes/GRP10.amx" and the .amx doesn't even start to load, as pointed out above.

EDIT 2: Tried disabling that too, removed functions using it, but no luck... I still get the same error. It's really strange how my gamemode is not cross-platform compatible. Are there any notes on the case currently available? Please let me know.
neko.sempai.1 is offline   Reply With Quote
Old 19/06/2010, 08:56 AM   #2
Karlip
High-roller
 
Join Date: Oct 2007
Location: Click To Show
Posts: 1,479
Reputation: 102
Default Re: Gamemode fails to start, but only on linux.

Are you sure you aren't missing some plugins or has the GM compiled with any errors?
__________________
Karlip is offline   Reply With Quote
Old 19/06/2010, 10:11 AM   #3
Cardinaal
Big Clucker
 
Join Date: Apr 2010
Posts: 61
Reputation: 0
Default Re: Gamemode fails to start, but only on linux.

Code:
[06:47:40] Script[gamemodes/GRP10.amx]: Run time error 19: "File or function is not found"
!!!!!
Obviously your gamemode script does not have a .amx file.
Compile it and fix errors if there are any.
Cardinaal is offline   Reply With Quote
Old 19/06/2010, 10:23 AM   #4
ev0lution
Gangsta
 
ev0lution's Avatar
 
Join Date: Jul 2009
Posts: 681
Reputation: 380
Default Re: Gamemode fails to start, but only on linux.

Quote:
Originally Posted by Cardinaal
Code:
[06:47:40] Script[gamemodes/GRP10.amx]: Run time error 19: "File or function is not found"
!!!!!
Obviously your gamemode script does not have a .amx file.
Compile it and fix errors if there are any.
Lol'd

__________________
ev0lution is offline   Reply With Quote
Old 19/06/2010, 10:53 AM   #5
neko.sempai.1
Little Clucker
 
Join Date: Jun 2010
Posts: 3
Reputation: 0
Default Re: Gamemode fails to start, but only on linux.

Quote:
Originally Posted by Karlip
Are you sure you aren't missing some plugins or has the GM compiled with any errors?
GM has compiled with no errors nor warnings. All plugins should be present, some outdated, but the server fails even if they are disabled and their functions are not called at all.

Also, I did check if the gamemode was present and I wouldn't make such mistakes, I've been coding samp servers for 5 years or so.

If the gamemode would be missing, the error I would receive should read:
Quote:
I couldn't load any gamemode scripts. Please verify your server.cfg
It needs a gamemode0 line at the very least.
furthermore, the server wouldn't start at all, which is not the case as the server does start, but fails to initiate the gamemode, even though it is compiled well and works flawlessly on windows.
neko.sempai.1 is offline   Reply With Quote
Old 19/06/2010, 11:03 AM   #6
neko.sempai.1
Little Clucker
 
Join Date: Jun 2010
Posts: 3
Reputation: 0
Default Re: Gamemode fails to start, but only on linux.

I've changed the gamemode to 'bare.amx' provided with the default package of SA:MP server. With current plugins and filterscripts, it worked just fine.

Quote:
Also, plase note, how my gamemode isn't even started to execute. I call a print function in the beggining of it:
Code:
main()
{
	print("Server launched. Starting setup");
}
and there's nothing in the log.
Quote:
[06:47:40] Loaded 4 filter scripts.
--------> ? ? ? <------------
[06:47:40] Script[gamemodes/GRP10.amx]: Run time error 19: "File or function is not found"
Please give me ideas...
neko.sempai.1 is offline   Reply With Quote
Old 19/06/2010, 12:17 PM   #7
Westie
Gangsta
 
Westie's Avatar
 
Join Date: Jul 2009
Posts: 857
Reputation: 63
Default Re: Gamemode fails to start, but only on linux.

Check what plugins you need. You might have compiled in natives that depend on lets say, the mySQL plugin for example.
Westie is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux Server FFS Will not start, keeps restarting Jason_Borne420 Server Support 18 27/08/2013 10:48 AM
problem on linux server wont start oOhossamOo Server Support 3 23/05/2010 02:53 AM
Server won't start on linux | Help needed ASAP KKashimia Server Support 3 16/11/2009 06:00 PM
[Tool/Web/Other] [PHP] How to start / stop Linux Server d123 Server Support 6 11/05/2009 09:00 AM
Linux server problem- Wont start. xxonlinexx Server Support 9 29/12/2008 07:35 PM


All times are GMT. The time now is 05:02 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.